aboutsummaryrefslogtreecommitdiff
path: root/polish/libgadu
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
commit2fa62596744270745d9d0540f5bbd839f6b78d23 (patch)
treeb7e5a1ec8ce92178c23aff878c9671b8c96b7b89 /polish/libgadu
parente496938a05b08a6dc0a4f3562f7615a574354e2e (diff)
downloadports-2fa62596744270745d9d0540f5bbd839f6b78d23.tar.gz
ports-2fa62596744270745d9d0540f5bbd839f6b78d23.zip
Notes
Diffstat (limited to 'polish/libgadu')
-rw-r--r--polish/libgadu/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
index e77a71469932..dfc8d8952c44 100644
--- a/polish/libgadu/Makefile
+++ b/polish/libgadu/Makefile
@@ -25,17 +25,19 @@ CONFIGURE_ARGS= --enable-shared --disable-static --with-pthread \
USE_LDCONFIG= yes
-OPTIONS= OPENSSL "Build with OpenSSL support" on
-
PLIST_FILES= include/libgadu.h \
lib/libgadu.la \
lib/libgadu.so \
lib/libgadu.so.3 \
libdata/pkgconfig/libgadu.pc
+OPTIONS_DEFINE= OPENSSL
+OPENSSL_DESC= Build with OpenSSL support
+OPTIONS_DEFAULT=OPENSSL
+
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.else
CONFIGURE_ARGS+= --without-openssl
@@ -46,7 +48,7 @@ post-patch:
pre-install:
# OpenSSL from base system lacks .pc file for pkgconfig
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
@${REINPLACE_CMD} -e 's|openssl| |g' ${WRKSRC}/pkgconfig/libgadu.pc
.endif