aboutsummaryrefslogtreecommitdiff
path: root/polish/sap/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-11-05 15:46:23 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-11-05 15:46:23 +0000
commitac6e50b2a6a71008ca1e6dd9e5ffaec33d757299 (patch)
tree61d74d73666bc2d722ab44d551a85825e19bbde7 /polish/sap/Makefile
parent0656250a3aa8a66e7f10c6d82a33670a2e80bc81 (diff)
downloadports-ac6e50b2a6a71008ca1e6dd9e5ffaec33d757299.tar.gz
ports-ac6e50b2a6a71008ca1e6dd9e5ffaec33d757299.zip
Notes
Diffstat (limited to 'polish/sap/Makefile')
-rw-r--r--polish/sap/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/polish/sap/Makefile b/polish/sap/Makefile
new file mode 100644
index 000000000000..1724e6620971
--- /dev/null
+++ b/polish/sap/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: sap
+# Date created: Fri 9 July 2004
+# Whom: Aleksander Fafula <alex@bsdguru.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sap
+PORTVERSION= 0.2
+CATEGORIES= polish
+MASTER_SITES= http://www.terravista.pt/Mussulo/1345/sap/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alex@bsdguru.org
+COMMENT= A command line Polish-English and English-Polish dictionary
+
+USE_REINPLACE= yes
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|PREFIX=/usr|PREFIX=${PREFIX}|g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|#define DICTIONARIES_DIRECTORY "/usr/lib/sap/"|#define DICTIONARIES_DIRECTORY "${PREFIX}/lib/sap/"|g' ${WRKSRC}/src/configuration.h_UNIX
+
+.include <bsd.port.mk>