aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /polish
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'polish')
-rw-r--r--polish/kadu/Makefile4
-rw-r--r--polish/qfaktury/Makefile4
-rw-r--r--polish/qnapi/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index cc7fb33e68e7..9eebafc729db 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -37,10 +37,10 @@ GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USES= cmake compiler:c++11-lib gettext-runtime \
- libarchive pkgconfig readline tar:bzip2
+ libarchive pkgconfig qt:5 readline tar:bzip2
USE_XORG= x11 xext xfixes xscrnsaver
USE_GNOME= glib20
-USE_QT5= concurrent core dbus gui multimedia network \
+USE_QT= concurrent core dbus gui multimedia network \
qml quick script scripttools sql webkit widgets x11extras \
xml xmlpatterns buildtools_build linguisttools_build \
qmake_build imageformats_run sql-sqlite3_run
diff --git a/polish/qfaktury/Makefile b/polish/qfaktury/Makefile
index 59d43680c106..9c794c9f54d1 100644
--- a/polish/qfaktury/Makefile
+++ b/polish/qfaktury/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF
MAINTAINER= meritus@innervision.pl
COMMENT= Polish invoicing desktop program
-USES= qmake
-USE_QT4= uic_build moc_build rcc_build corelib gui xml qt3support
+USES= qmake qt:4
+USE_QT= uic_build moc_build rcc_build corelib gui xml qt3support
PORTDOCS= ChangeLog.txt ReadMe.txt ReleaseNotes.txt TODO.txt
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index 046227a164f5..025c27905490 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= 7z:archivers/p7zip
USE_GITHUB= yes
-USES= compiler:c++11-lib pkgconfig qmake
+USES= compiler:c++11-lib pkgconfig qmake qt:5
USE_GL= gl
-USE_QT5= buildtools_build core gui network widgets xml
+USE_QT= buildtools_build core gui network widgets xml
CXXFLAGS+= -I${LOCALBASE}/include/maia