aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 18:34:22 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 18:34:22 +0000
commite984a3a1c448241310006307c6865ab24014b7e3 (patch)
treef32ee7b1238a5be5178c342fb367d0842295aaf9 /polish
parent75802bbff37ed86639abbfae24fe09ec44208234 (diff)
downloadports-e984a3a1c448241310006307c6865ab24014b7e3.tar.gz
ports-e984a3a1c448241310006307c6865ab24014b7e3.zip
Notes
Diffstat (limited to 'polish')
-rw-r--r--polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt b/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt
new file mode 100644
index 000000000000..6f1d6216ab0a
--- /dev/null
+++ b/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt
@@ -0,0 +1,16 @@
+CMake 2.8.12 fix.
+
+http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=9ce60ff509c4ff27fe861fc5b2080f50897a68c4
+changed the arguments of the internal macro QT4_CREATE_MOC_COMMAND which the
+port uses directly, so we have to adapt.
+--- plugins/jabber_protocol/3rdparty/CMakeLists.txt.orig 2013-11-03 19:28:58.000000000 +0200
++++ plugins/jabber_protocol/3rdparty/CMakeLists.txt 2013-11-03 19:29:04.000000000 +0200
+@@ -26,7 +26,7 @@
+ get_filename_component (_basename ${_current_MOC} NAME_WE)
+ set (_header ${_abs_FILE})
+ set (_moc ${_abs_PATH}/${_current_MOC})
+- QT4_CREATE_MOC_COMMAND (${_header} ${_moc} "${_moc_INCS}" "")
++ QT4_CREATE_MOC_COMMAND (${_header} ${_moc} "${_moc_INCS}" "" "")
+ MACRO_ADD_FILE_DEPENDENCIES (${_abs_FILE} ${_moc})
+ endforeach (_current_MOC_INC)
+ endif (_match)