aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-08-29 15:01:46 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-08-29 15:01:46 +0000
commitf2904b6af86bf31288fb14f77c4147d547f2331f (patch)
tree0f24ce676070cd2b3017f761db8f5e49e00c5b07 /polish
parentdf286138e91ba031330ebdf325b268e778d4bedc (diff)
downloadports-f2904b6af86bf31288fb14f77c4147d547f2331f.tar.gz
ports-f2904b6af86bf31288fb14f77c4147d547f2331f.zip
Notes
Diffstat (limited to 'polish')
-rw-r--r--polish/ekg/Makefile6
-rw-r--r--polish/ekg2/Makefile21
-rw-r--r--polish/kadu/Makefile30
-rw-r--r--polish/qnapi/Makefile8
4 files changed, 23 insertions, 42 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index 4b230d8bc1e6..15199f465db4 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://ekg.chmurka.net/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Text-mode Gadu-Gadu client
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- gadu:${PORTSDIR}/polish/libgadu
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libgadu.so:${PORTSDIR}/polish/libgadu
GNU_CONFIGURE= yes
USES= gmake pathfix pkgconfig
@@ -33,7 +33,7 @@ OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL
ASPELL_CONFIGURE_ON= --enable-aspell
-ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/polish/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/polish/aspell
OPENSSL_CONFIGURE_OFF= --without-openssl
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index f96010a47966..89edf53289ab 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://pl.ekg2.org/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Text-mode Gadu-Gadu, Jabber, and IRC client
-LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/libgadu \
+ libexpat.so:${PORTSDIR}/textproc/expat2
LICENSE= GPLv2
@@ -51,18 +51,18 @@ OPTIONS_DEFAULT=ASPELL
ASPELL_CONFIGURE_ON= --with-aspell
ASPELL_CONFIGURE_OFF= --without-aspell
-ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
ASPELL_RUN_DEPENDS= ${LOCALBASE}/share/aspell/pl.rws:${PORTSDIR}/polish/aspell
GPG_CONFIGURE_ON= --with-gpg
GPG_CONFIGURE_OFF= --without-gpg
-GPG_LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
- gpg-error:${PORTSDIR}/security/libgpg-error
+GPG_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
GPG_RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
GSM_CONFIGURE_ON= --with-libgsm
GSM_CONFIGURE_OFF= --without-libgsm
-GSM_LIB_DEPENDS= gsm:${PORTSDIR}/audio/gsm
+GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
GTK2_CONFIGURE_ON= --with-gtk
GTK2_CONFIGURE_OFF= --without-gtk
@@ -72,19 +72,20 @@ NLS_USES= gettext
PERL_CONFIGURE_ON= --with-perl
PERL_CONFIGURE_OFF= --without-perl
+PERL_USES= perl5
PYTHON_CONFIGURE_ON= --with-python
PYTHON_CONFIGURE_OFF= --without-python
SQLITE_CONFIGURE_ON= --with-sqlite3
SQLITE_CONFIGURE_OFF= --without-sqlite3
-SQLITE_LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
UNICODE_CONFIGURE_ON= --enable-unicode
XOSD_CONFIGURE_ON= --with-libxosd
XOSD_CONFIGURE_OFF= --without-libxosd
-XOSD_LIB_DEPENDS= xosd:${PORTSDIR}/misc/xosd
+XOSD_LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd
.include <bsd.port.options.mk>
@@ -92,10 +93,6 @@ XOSD_LIB_DEPENDS= xosd:${PORTSDIR}/misc/xosd
USE_GNOME+= gtk20
.endif
-.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
-.endif
-
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
.endif
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 70f9f4df36f8..db5d980b811e 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -21,19 +21,12 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
pl-libgadu>=1.11.1:${PORTSDIR}/polish/libgadu
-LIB_DEPENDS= mpdclient:${PORTSDIR}/audio/libmpdclient \
- sndfile:${PORTSDIR}/audio/libsndfile \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- qca:${PORTSDIR}/devel/qca \
- idn:${PORTSDIR}/dns/libidn \
- png15:${PORTSDIR}/graphics/png \
- gadu:${PORTSDIR}/polish/libgadu \
- freetype:${PORTSDIR}/print/freetype2 \
- qzeitgeist:${PORTSDIR}/sysutils/qzeitgeist \
- enchant:${PORTSDIR}/textproc/enchant \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile \
+ libqca.so:${PORTSDIR}/devel/qca \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libgadu.so:${PORTSDIR}/polish/libgadu \
+ libenchant.so:${PORTSDIR}/textproc/enchant
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
# TODO ntrack and ntrack-qt (needs porting) ?
@@ -43,15 +36,14 @@ GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
-USES= cmake pkgconfig gettext iconv
-USE_XORG= ice sm x11 xau xcb xdmcp xext xfixes xrender xscrnsaver
+USES= cmake pkgconfig
+USE_XORG= xscrnsaver
CMAKE_ARGS= -DKADU_VERSION:STRING="${DISTVERSION}" -DWITH_ENCHANT=ON
# Setting KADU_VERSION disables git invocation
-USE_QT4= corelib dbus declarative gui network phonon qtestlib script \
- scripttools svg webkit xml xmlpatterns linguist_build \
- moc_build qmake_build rcc_build uic_build imageformats_run \
- sql-sqlite3_run
+USE_QT4= dbus gui network phonon script scripttools webkit xml \
+ linguist_build moc_build qmake_build rcc_build uic_build \
+ imageformats_run sql-sqlite3_run
WANT_GNOME= yes
INSTALLS_ICONS= yes
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index ece7a3ed8f1e..38c5436c64fa 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -12,16 +12,8 @@ COMMENT= Qt4 based subtitle downloader
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
-USES= gettext iconv
-USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= corelib gui network xml qmake_build moc_build uic_build rcc_build
USE_KDE4= kdehier
QMAKE_ARGS= PREFIX=${PREFIX} KDE4_PREFIX=${KDE4_PREFIX}