aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-08-29 16:41:00 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-08-29 16:41:00 +0000
commit1d5842af382ed5915d5c1aee7f48897d42ec8544 (patch)
tree231f4a1f9502ea8b33f41cb06ff368a717a2341d /polish
parentdca7bff7eb3b08640abdfbf41b7e70cd1a5367db (diff)
downloadports-1d5842af382ed5915d5c1aee7f48897d42ec8544.tar.gz
ports-1d5842af382ed5915d5c1aee7f48897d42ec8544.zip
Notes
Diffstat (limited to 'polish')
-rw-r--r--polish/kadu/Makefile41
-rw-r--r--polish/kadu/distinfo4
-rw-r--r--polish/kadu/files/emoticons-CMakeLists.txt10
-rw-r--r--polish/kadu/pkg-plist3
4 files changed, 33 insertions, 25 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index d6fd985cd052..fb4965c84ca4 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kadu
-PORTVERSION= 0.12.0
+PORTVERSION= 0.12.1
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
@@ -23,13 +23,21 @@ COMMENT= Internet communicator supporting Gadu-Gadu and Jabber/XMPP
LICENSE= GPLv2
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
- pl-libgadu>=1.11.0:${PORTSDIR}/polish/libgadu
-LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
- gadu.3:${PORTSDIR}/polish/libgadu \
- idn.17:${PORTSDIR}/dns/libidn \
- mpdclient.2:${PORTSDIR}/audio/libmpdclient \
- qca.2:${PORTSDIR}/devel/qca \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+ pl-libgadu>=1.11.1:${PORTSDIR}/polish/libgadu
+LIB_DEPENDS= mpdclient:${PORTSDIR}/audio/libmpdclient \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ qca:${PORTSDIR}/devel/qca \
+ idn:${PORTSDIR}/dns/libidn \
+ png15:${PORTSDIR}/graphics/png \
+ gadu:${PORTSDIR}/polish/libgadu \
+ freetype:${PORTSDIR}/print/freetype2 \
+ qzeitgeist:${PORTSDIR}/sysutils/qzeitgeist \
+ enchant:${PORTSDIR}/textproc/enchant \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
# TODO ntrack and ntrack-qt (needs porting) ?
@@ -40,14 +48,18 @@ GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
USE_CMAKE= yes
-USE_XORG= xscrnsaver
+USE_PKGCONFIG= build
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_XORG= ice sm x11 xau xdmcp xext xfixes xrender xscrnsaver
CMAKE_ARGS= -DKADU_VERSION:STRING="${DISTVERSION}" -DWITH_ENCHANT=ON
# Setting KADU_VERSION disables git invocation
MAKE_JOBS_SAFE= yes
-USE_QT4= dbus gui network script scripttools webkit xml phonon \
- linguist_build moc_build qmake_build rcc_build uic_build \
- imageformats_run sql-sqlite3_run
+USE_QT4= corelib dbus declarative gui network phonon qtestlib script \
+ scripttools svg webkit xml xmlpatterns linguist_build \
+ moc_build qmake_build rcc_build uic_build imageformats_run \
+ sql-sqlite3_run
WANT_GNOME= yes
INSTALLS_ICONS= yes
@@ -60,7 +72,6 @@ GG_EMOTS_DESC= Install GG-compatible emoticons
PLIST_SUB+= GG_EMOTS=""
DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
${GG7_EMOTS_DISTFILE}:additions
-EXTRA_PATCHES+= ${FILESDIR}/emoticons-CMakeLists.txt
.else
PLIST_SUB+= GG_EMOTS="@comment "
.endif
@@ -72,11 +83,15 @@ post-patch:
@${FIND} ${WRKSRC} -exec ${GREP} -q "#!/bin/bash" {} \; \
-exec ${REINPLACE_CMD} -e 's|#!/bin/bash|#!/usr/bin/env bash|g' {} \;
+post-install:
.if ${PORT_OPTIONS:MGG_EMOTS}
@cd ${WRKSRC}/varia/themes/emoticons && \
${TAR} -zxf ${_DISTDIR}/${GG6_EMOTS_DISTFILE} && \
${MV} kompatybilne_z_GG6 gg6_compatible && \
cd gg6_compatible && ${TAR} -zxf ${_DISTDIR}/${GG7_EMOTS_DISTFILE}
+ @cd ${WRKSRC}/varia/themes/emoticons && \
+ ${COPYTREE_SHARE} gg6_compatible ${DATADIR}/themes/emoticons
+
.endif
.include <bsd.port.mk>
diff --git a/polish/kadu/distinfo b/polish/kadu/distinfo
index b46336528214..1b386b145c64 100644
--- a/polish/kadu/distinfo
+++ b/polish/kadu/distinfo
@@ -1,5 +1,5 @@
-SHA256 (kadu/kadu-0.12.0.tar.bz2) = 7de16df61f7900a7e6569cf4a2eaf20d11177bde430c2db2b25f591714f4c27e
-SIZE (kadu/kadu-0.12.0.tar.bz2) = 5914017
+SHA256 (kadu/kadu-0.12.1.tar.bz2) = 3cd05e17bb79eb6c63633db63de118822a92a5e4ca068f92995eac1eadab843e
+SIZE (kadu/kadu-0.12.1.tar.bz2) = 5942292
SHA256 (kadu/kompatybilne_z_GG6.tar.gz) = f8a84acd8512fd8fc38e394aa564e6b6d7ec2e9fe9864bdf0c5b8f2edb23da6f
SIZE (kadu/kompatybilne_z_GG6.tar.gz) = 254637
SHA256 (kadu/dodatkowe_emoty_GG7.tar.gz) = aebeb45b6ac9139620032436f7b565aa5729a0165d1c361a473c1195b8807450
diff --git a/polish/kadu/files/emoticons-CMakeLists.txt b/polish/kadu/files/emoticons-CMakeLists.txt
deleted file mode 100644
index 1be792002bc9..000000000000
--- a/polish/kadu/files/emoticons-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- varia/themes/emoticons/CMakeLists.txt.orig 2011-09-14 00:57:00.000000000 +0200
-+++ varia/themes/emoticons/CMakeLists.txt 2011-09-14 00:57:34.000000000 +0200
-@@ -1,6 +1,7 @@
- set (EMOTICON_THEMES
- penguins
- tango
-+ gg6_compatible
- )
-
- if (EMOTICON_THEMES)
diff --git a/polish/kadu/pkg-plist b/polish/kadu/pkg-plist
index 2f8607d7bd24..c6986291aca6 100644
--- a/polish/kadu/pkg-plist
+++ b/polish/kadu/pkg-plist
@@ -691,6 +691,7 @@ share/icons/hicolor/32x32/apps/kadu.png
share/icons/hicolor/48x48/apps/kadu.png
share/icons/hicolor/64x64/apps/kadu.png
share/icons/hicolor/128x128/apps/kadu.png
+share/icons/hicolor/256x256/apps/kadu.png
%%DATADIR%%/AUTHORS
%%DATADIR%%/COPYING
%%DATADIR%%/ChangeLog
@@ -4104,6 +4105,8 @@ share/icons/hicolor/128x128/apps/kadu.png
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/128x128/apps
@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/cmake/Modules