aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/kports-qt4/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 12:40:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 12:40:32 +0000
commit61000f23278e2896df05e4dcb2fa6fcdf1c33643 (patch)
tree2eef8dc8057844b13440984edd0115f961a53036 /ports-mgmt/kports-qt4/Makefile
parent4e29df1229e8f7aeb6bce65481987a85a1ee53b5 (diff)
Notes
Diffstat (limited to 'ports-mgmt/kports-qt4/Makefile')
-rw-r--r--ports-mgmt/kports-qt4/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index b7514fb5873b..df1af6f7214f 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kports
-# Date created: Thu Jan 12 12:47:58 UTC 2006
-# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
-#
+# Created by: Hannes Hauswedell <hannes.hauswedell@gmail.com>
# $FreeBSD$
-#
PORTNAME= kports
PORTVERSION= 0.8.2
@@ -29,24 +25,25 @@ HAS_CONFIGURE= yes
LATEST_LINK= kports-qt4
-OPTIONS= DEBUG "Add Debugging Symbols" off \
- OXYGEN "Pull in Oxygen icons (recommended)" on \
- KDEBASE "Pull in kdebase-runtime for kdesu" on
+OPTIONS_DEFINE= DEBUG OXYGEN KDEBASE
+OPTIONS_DEFAULT= OXYGEN KDEBASE
+OXYGEN_DESC= Pull in Oxygen icons (recommended)
+KDEBASE_DESC= Pull in kdebase-runtime for kdesu
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_OXYGEN)
+.if ${PORT_OPTIONS:MOXYGEN}
USE_KDE4= oxygen
.endif
-.if !defined(WITHOUT_KDEBASE)
+.if ${PORT_OPTIONS:MKDEBASE}
USE_KDE4= runtime
.endif
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/data/kports.desktop
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
pre-configure:
@(${ECHO_CMD} "CONFIG += debug" >> ${WRKSRC}/src/src.pro)
@(${ECHO_CMD} "CONFIG -= release warn_off" >> ${WRKSRC}/src/src.pro)
@@ -59,11 +56,11 @@ do-configure:
${QMAKE} -unix ${QMAKE_ARGS} kports.pro
post-install:
-.if defined(WITHOUT_OXYGEN)
+.if ! ${PORT_OPTIONS:MOXYGEN}
@${CAT} pkg-message.nooxygen
.endif
-.if defined(WITHOUT_KDEBASE)
+.if ! ${PORT_OPTIONS:MKDEBASE}
@${CAT} pkg-message.nokdebase
.endif