aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/kports-qt4/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-01-24 19:38:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-01-24 19:38:36 +0000
commit08ceca4c554fe24acb3c69ccb719788a98a4dbcf (patch)
tree7f08a0a21fa16e8875d1c8c5d893c85280319c40 /ports-mgmt/kports-qt4/Makefile
parent946a9c012b9f25d164d8c026af23f06ab0694aae (diff)
downloadports-08ceca4c554fe24acb3c69ccb719788a98a4dbcf.tar.gz
ports-08ceca4c554fe24acb3c69ccb719788a98a4dbcf.zip
Notes
Diffstat (limited to 'ports-mgmt/kports-qt4/Makefile')
-rw-r--r--ports-mgmt/kports-qt4/Makefile36
1 files changed, 31 insertions, 5 deletions
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index 34980eb729e4..ec058cd2086a 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -7,29 +7,55 @@
PORTNAME= kports
PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ports-mgmt kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= hannes.hauswedell@gmail.com
-COMMENT= Powerful KDE-Frontend to the Ports
+MAINTAINER= kports@soulrebel.in-berlin.de
+COMMENT= KDE3-Version of your favorite frontend to the Ports
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
-PREFIX= ${KDE_PREFIX}
RUN_DEPENDS+= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
-OPTIONS= PORTAUDIT "Require Portaudit" on
+OPTIONS= PORTAUDIT "Require Portaudit" on \
+ KDESU "With KDE3 kdesu" on \
+ KDESU4 "With KDE4 kdesu" off \
+ GKSU "With gksu" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+PKGMESSAGE= ${FILESDIR}/pkg-message.nosu
+.endif
+
.if !defined(WITHOUT_PORTAUDIT)
RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
+.if defined(WITH_KDESU)
+RUN_DEPENDS+= ${LOCALBASE}/bin/kdesu:${PORTSDIR}/x11/kdebase3
+.endif
+
+.if defined(WITH_KDESU4)
+RUN_DEPENDS+= ${LOCALBASE}/kde4/lib/kde4/libexec/kdesu:${PORTSDIR}/x11/kdebase4-runtime
+.endif
+
+.if defined(WITH_GKSU)
+RUN_DEPENDS+= ${LOCALBASE}/bin/gksu:${PORTSDIR}/sysutils/gksu
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/src/kports.desktop
+
+post-install:
+.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.post.mk>