aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/kports
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-03 16:11:50 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-03 16:11:50 +0000
commitc4b8c509f813adf80aa474076770c161bfeffe86 (patch)
treec6bc04d5e5dbee63d85e1602df278595109e6858 /ports-mgmt/kports
parent9927f69ee0d193b1d43613868a29a7a122eacfe9 (diff)
downloadports-c4b8c509f813adf80aa474076770c161bfeffe86.tar.gz
ports-c4b8c509f813adf80aa474076770c161bfeffe86.zip
Notes
Diffstat (limited to 'ports-mgmt/kports')
-rw-r--r--ports-mgmt/kports/Makefile42
-rw-r--r--ports-mgmt/kports/distinfo3
-rw-r--r--ports-mgmt/kports/pkg-descr10
-rw-r--r--ports-mgmt/kports/pkg-message13
-rw-r--r--ports-mgmt/kports/pkg-plist12
5 files changed, 80 insertions, 0 deletions
diff --git a/ports-mgmt/kports/Makefile b/ports-mgmt/kports/Makefile
new file mode 100644
index 000000000000..31cd858ca589
--- /dev/null
+++ b/ports-mgmt/kports/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: kports
+# Date created: Thu Jan 12 12:47:58 UTC 2006
+# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kports
+PORTVERSION= 0.6.0
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hannes.hauswedell@gmail.com
+COMMENT= Powerful KDE-Frontend to the Ports
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+USE_AUTOTOOLS= libtool:15
+PREFIX= ${KDE_PREFIX}
+
+RUN_DEPENDS+= ${PREFIX}/sbin/portupgrade:${PORTSDIR}/sysutils/portupgrade
+RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
+
+OPTIONS= PORTAUDIT "Require Portaudit" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= doesn't compile properly on 4.x systems
+.endif
+
+.if !defined(WITHOUT_PORTAUDIT)
+RUN_DEPENDS+= ${PREFIX}/sbin/portaudit:${PORTSDIR}/security/portaudit
+.endif
+
+post-install:
+# @${CAT} ${PKGDIR}/pkg-message
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/kports/distinfo b/ports-mgmt/kports/distinfo
new file mode 100644
index 000000000000..95669f3b5275
--- /dev/null
+++ b/ports-mgmt/kports/distinfo
@@ -0,0 +1,3 @@
+MD5 (kports-0.6.0.tar.bz2) = 9b5c67a649a0fe61496eb78cd777707f
+SHA256 (kports-0.6.0.tar.bz2) = c04a1529cfa5657349932048923dfadca0d400edde34a53e2db3792b0d5b59ab
+SIZE (kports-0.6.0.tar.bz2) = 637071
diff --git a/ports-mgmt/kports/pkg-descr b/ports-mgmt/kports/pkg-descr
new file mode 100644
index 000000000000..f99677b37f4c
--- /dev/null
+++ b/ports-mgmt/kports/pkg-descr
@@ -0,0 +1,10 @@
+KPorts is KDE-Frontend to the FreeBSD-Ports and in future also to the
+OpenBsd-Ports, PkgSrc and maybe others.
+You can browse and search through your Portstree and perform actions
+like Upgrades, Installs, Uninstall a.s.o. More advanced features like
+setting Options and Vulnerability checking are also available. For a
+complete list, check the Homepage or the Changelog.
+Functionality is KPorts' main goal, not simplification by reducing
+options; however KPorts should be rather easy to use.
+
+WWW: http://kports.sf.net
diff --git a/ports-mgmt/kports/pkg-message b/ports-mgmt/kports/pkg-message
new file mode 100644
index 000000000000..0e312f031160
--- /dev/null
+++ b/ports-mgmt/kports/pkg-message
@@ -0,0 +1,13 @@
+==========================================================
+ WARNING:
+
+ Portupgrade has an unfixed bug that prevents
+ KPorts from processing output correctly.
+ Until the issue is solved, please go to
+
+ http://kports.sf.net
+
+ and download patched portupgrade files.
+
+ Sorry for the inconvenience
+=========================================================
diff --git a/ports-mgmt/kports/pkg-plist b/ports-mgmt/kports/pkg-plist
new file mode 100644
index 000000000000..7ac0e9d0590e
--- /dev/null
+++ b/ports-mgmt/kports/pkg-plist
@@ -0,0 +1,12 @@
+bin/kports
+bin/kports_client
+share/applnk/System/kports.desktop
+share/apps/kports/kports-splash.jpg
+share/apps/kports/kportsui.rc
+share/doc/HTML/en/kports/index.cache.bz2
+share/doc/HTML/en/kports/index.docbook
+share/icons/hicolor/16x16/apps/kports.png
+share/icons/hicolor/32x32/apps/kports.png
+@dirrm share/doc/HTML/en/kports/common
+@dirrm share/doc/HTML/en/kports
+@dirrm share/apps/kports