aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portal
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2016-02-20 14:31:40 +0000
committerFrederic Culot <culot@FreeBSD.org>2016-02-20 14:31:40 +0000
commita5d74e7c64b95a34f1fba66809d22f082aadc6a3 (patch)
tree428b35efbc9a847bf19deab826c83fea1c33f621 /ports-mgmt/portal
parent14baca0ae8df8a8e442664b5ac815250c9525b22 (diff)
downloadports-a5d74e7c64b95a34f1fba66809d22f082aadc6a3.tar.gz
ports-a5d74e7c64b95a34f1fba66809d22f082aadc6a3.zip
Notes
Diffstat (limited to 'ports-mgmt/portal')
-rw-r--r--ports-mgmt/portal/Makefile24
-rw-r--r--ports-mgmt/portal/distinfo2
-rw-r--r--ports-mgmt/portal/pkg-descr8
3 files changed, 34 insertions, 0 deletions
diff --git a/ports-mgmt/portal/Makefile b/ports-mgmt/portal/Makefile
new file mode 100644
index 000000000000..b8f00efa0893
--- /dev/null
+++ b/ports-mgmt/portal/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= portal
+PORTVERSION= 0.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Front-end to pkg(8)
+
+LICENSE= BSD2CLAUSE
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+USE_GITHUB= yes
+GH_ACCOUNT= culot
+GH_TAGNAME= 0.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portal/distinfo b/ports-mgmt/portal/distinfo
new file mode 100644
index 000000000000..eec8965df911
--- /dev/null
+++ b/ports-mgmt/portal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (culot-portal-0.1_GH0.tar.gz) = 4242824317a1c7b97140e4b34b884df3ca88de8e53cc0217038b152e7f58f99e
+SIZE (culot-portal-0.1_GH0.tar.gz) = 29623
diff --git a/ports-mgmt/portal/pkg-descr b/ports-mgmt/portal/pkg-descr
new file mode 100644
index 000000000000..d2e7a9bac584
--- /dev/null
+++ b/ports-mgmt/portal/pkg-descr
@@ -0,0 +1,8 @@
+Portal is a front-end to FreeBSD's package manipulation tool pkg(8).
+
+Currently, the application is a MVP (Minimum Viable Product) which
+provides only the following features: packages listing and searching,
+installation and deinstallation of packages, and filtering based on
+the package state.
+
+WWW: https://github.com/culot/portal