aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/porte
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2008-11-05 01:46:11 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2008-11-05 01:46:11 +0000
commit2c8ba55ce142e2442ee0d5bf21b8dc726c016b92 (patch)
treefcec358b73d4e9830998576378e1c813b8b2a1d3 /ports-mgmt/porte
parentdda2b6721da4aa50383feccef4b06135b08c4f64 (diff)
downloadports-2c8ba55ce142e2442ee0d5bf21b8dc726c016b92.tar.gz
ports-2c8ba55ce142e2442ee0d5bf21b8dc726c016b92.zip
Notes
Diffstat (limited to 'ports-mgmt/porte')
-rw-r--r--ports-mgmt/porte/Makefile36
-rw-r--r--ports-mgmt/porte/distinfo3
-rw-r--r--ports-mgmt/porte/pkg-descr5
-rw-r--r--ports-mgmt/porte/pkg-plist15
4 files changed, 59 insertions, 0 deletions
diff --git a/ports-mgmt/porte/Makefile b/ports-mgmt/porte/Makefile
new file mode 100644
index 000000000000..f52f6a2571dc
--- /dev/null
+++ b/ports-mgmt/porte/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: porte
+# Date created: November 4, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= porte
+PORTVERSION= 0.0.1
+CATEGORIES= ports-mgmt haskell
+MASTER_SITES= http://kerneled.org/releases/
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= FreeBSD ports index search and statistical analysis tool
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-stringsearch>=0.2.1.1:${PORTSDIR}/textproc/hs-stringsearch
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.hs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/porte/distinfo b/ports-mgmt/porte/distinfo
new file mode 100644
index 000000000000..c0d926e12320
--- /dev/null
+++ b/ports-mgmt/porte/distinfo
@@ -0,0 +1,3 @@
+MD5 (porte-0.0.1.tar.gz) = ce874e99b7fc9f8e4cb233b550d047a3
+SHA256 (porte-0.0.1.tar.gz) = cb776f8bbb0c82e508788b1055c91f1af742d540ceca8abe9d9952f6b49a9a4f
+SIZE (porte-0.0.1.tar.gz) = 3625
diff --git a/ports-mgmt/porte/pkg-descr b/ports-mgmt/porte/pkg-descr
new file mode 100644
index 000000000000..d6579f3f73ab
--- /dev/null
+++ b/ports-mgmt/porte/pkg-descr
@@ -0,0 +1,5 @@
+Porte provides a simple, fast and efficient interface to searching
+FreeBSD ports index fields. It also has a simple statistics mode which
+allows collecting frequency statistics for these fields.
+
+WWW: http://www.kerneled.org/
diff --git a/ports-mgmt/porte/pkg-plist b/ports-mgmt/porte/pkg-plist
new file mode 100644
index 000000000000..b373dd532fa7
--- /dev/null
+++ b/ports-mgmt/porte/pkg-plist
@@ -0,0 +1,15 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSporte-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSporte-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Porte/Ports.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Porte/Statistics.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Porte/Tool.hi
+bin/porte
+%%SUBDIR%%/register.sh
+share/doc/porte-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/porte-%%PORTVERSION%%
+@dirrm lib/porte-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Porte
+@dirrm lib/porte-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/porte-%%PORTVERSION%%
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister porte
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old