aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portlint/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-17 20:17:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-17 20:17:46 +0000
commit1f93b36619d5f56a56153328d54b294db333c3df (patch)
tree151231957004048c248f0a01415fd078b46d059a /ports-mgmt/portlint/Makefile
parentca27c348e14b78c0a5496f0d650f2c0d7472a242 (diff)
Update to 2.5.0.
* Add some linenumbers to the whole file search * Hack the direct command use code some more * Add a check for the deprecated USE_MESA * Allow PKGCATEGORY not in CATEGORIES [1] * Allow %B in pkg-plist, as it has a valid prefix [1] * Allow simple rm -f, it needs no redirection [1] * Add portlintgrep.pl, an example on how to use portlint to find certain portlint problems in the ports tree [2] Submitted by: dinoex [1] eik [2]
Notes
Notes: svn path=/head/; revision=94190
Diffstat (limited to 'ports-mgmt/portlint/Makefile')
-rw-r--r--ports-mgmt/portlint/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index fac1be4e1dee..5b788582c495 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.4.8
+PORTVERSION= 2.5.0
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
@@ -33,9 +33,13 @@ pre-patch:
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/portlint.pl
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/portlintgrep.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portlint.pl ${PREFIX}/bin/portlint
${INSTALL_MAN} ${WRKSRC}/portlint.1 ${MAN1PREFIX}/man/man1
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/portlintgrep.pl ${EXAMPLESDIR}/portlintgrep
.include <bsd.port.mk>