aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portlint/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-20 00:31:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-20 00:31:20 +0000
commitbebd08942129441555bad9dd6a2febff9212d3f8 (patch)
tree21261678b2f6fe672fe848693d1701367315c830 /ports-mgmt/portlint/Makefile
parentd88a8e8b3a4d5f5e3de506265c383bb8d19e71eb (diff)
Notes
Diffstat (limited to 'ports-mgmt/portlint/Makefile')
-rw-r--r--ports-mgmt/portlint/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index f8f298613b42..e10bd1dde1fd 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.3.3
-PORTREVISION= 5
+PORTVERSION= 2.4.0
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
@@ -18,8 +17,9 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= A verifier for FreeBSD port directory
NO_BUILD= yes
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/src
USE_PERL5= yes
+USE_REINPLACE= yes
SRC= ${.CURDIR}/src
@@ -28,8 +28,14 @@ MAN1= portlint.1
do-fetch:
@${DO_NADA}
+pre-patch:
+ @${CP} -R ${SRC} ${WRKDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/portlint.pl
+
do-install:
- ${INSTALL_SCRIPT} ${SRC}/portlint.pl ${PREFIX}/bin/portlint
- ${INSTALL_MAN} ${SRC}/portlint.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/portlint.pl ${PREFIX}/bin/portlint
+ ${INSTALL_MAN} ${WRKSRC}/portlint.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>