aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2017-03-29 15:28:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2017-03-29 15:28:55 +0000
commit3379f32b1504335c5319aa79916273742fb63524 (patch)
tree23f4c55a885b6293f10ddc5f655b3506bac59484 /ports-mgmt/portlint
parent6874b5c049ec374b17a998653a02bf8178c66433 (diff)
downloadports-3379f32b1504335c5319aa79916273742fb63524.tar.gz
ports-3379f32b1504335c5319aa79916273742fb63524.zip
Notes
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.pl17
2 files changed, 16 insertions, 4 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index ac3194c51c49..fde76669458a 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.17.6
-PORTREVISION= 1
+PORTVERSION= 2.17.7
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 163a29b17e10..ec90d67197ce 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.399 2016/12/23 23:18:20 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.401 2017/03/29 15:26:37 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 17;
-my $micro = 6;
+my $micro = 7;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1142,6 +1142,19 @@ sub check_depends_syntax {
"USES[+]=gmake.");
}
+ my %udeps = (
+ 'bison' => 'bison',
+ 'fmake' => 'fmake',
+ 'libexecinfo.so' => 'execinfo',
+ );
+ foreach my $udep (keys %udeps) {
+ if ($m{'dep'} =~ /^$udep/) {
+ &perror("WARN", $file, -1, "dependency to $udep ".
+ "listed in $j. consider using ".
+ "USES[+]=$udeps{$udep}.");
+ }
+ }
+
# check USE_QT
if ($m{'dep'} =~ /^(qt\d)+$/) {
&perror("WARN", $file, -1, "dependency to $1 ".