aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portsnap/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-10-31 18:12:17 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-10-31 18:12:17 +0000
commit7dc5e40d448e5507a5e3e53561c78846594bfd64 (patch)
tree975360e4acff6a600da3ad9e51bf1b2cfc24fdb2 /ports-mgmt/portsnap/Makefile
parentc45fd3c4d98672c15ebbbc39623b7a5893eaf2f9 (diff)
downloadports-7dc5e40d448e5507a5e3e53561c78846594bfd64.tar.gz
ports-7dc5e40d448e5507a5e3e53561c78846594bfd64.zip
Notes
Diffstat (limited to 'ports-mgmt/portsnap/Makefile')
-rw-r--r--ports-mgmt/portsnap/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/ports-mgmt/portsnap/Makefile b/ports-mgmt/portsnap/Makefile
new file mode 100644
index 000000000000..6305f269e133
--- /dev/null
+++ b/ports-mgmt/portsnap/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Ports tree snapshot utility
+# Date created: 29 October 2004
+# Whom: cperciva@daemonology.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= portsnap
+PORTVERSION= 0.2
+CATEGORIES= sysutils net
+MASTER_SITES= http://www.daemonology.net/portsnap/
+
+MAINTAINER= cperciva@daemonology.net
+COMMENT= Provides secure snapshots of the ports directory
+
+# The freebsd-sha1 port is marked IGNORE for some versions of FreeBSD,
+# but for those sha1 should be found in /sbin/, so this should be safe.
+RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff \
+ sha1:${PORTSDIR}/sysutils/freebsd-sha1 \
+ freebsd-update-verify:${PORTSDIR}/security/freebsd-update
+
+MAN5= portsnap.conf.5
+MAN8= portsnap.8
+PLIST_FILES= etc/portsnap.conf.sample sbin/portsnap
+PLIST_DIRS= portsnap
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/portsnap ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/portsnap.conf.5 ${PREFIX}/man/man5/
+ ${INSTALL_MAN} ${WRKSRC}/portsnap.8 ${PREFIX}/man/man8/
+ ${INSTALL_DATA} ${WRKSRC}/portsnap.conf \
+ ${PREFIX}/etc/portsnap.conf.sample
+ ${MKDIR} ${PREFIX}/portsnap
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>