aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/porttools/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-03-02 00:40:53 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-03-02 00:40:53 +0000
commitcae75110cc2937087576c178ff441b74c955b14b (patch)
tree29d5b1ee38c82043ea361b3f3d507733af92cde6 /ports-mgmt/porttools/Makefile
parentc31cfbdd893d7ffa92d00e7aa9254dfdd83bce6a (diff)
Notes
Diffstat (limited to 'ports-mgmt/porttools/Makefile')
-rw-r--r--ports-mgmt/porttools/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index 935d7fd9cc22..a3b816f0eef7 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= porttools
PORTVERSION= 0.99
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= ports-mgmt
MASTER_SITES= SF
@@ -14,11 +14,8 @@ LICENSE= BSD
RUN_DEPENDS= portlint:${PORTSDIR}/ports-mgmt/portlint \
cdiff:${PORTSDIR}/textproc/cdiff \
- sudo:${PORTSDIR}/security/sudo
-
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install-docs
-.endif
+ sudo:${PORTSDIR}/security/sudo \
+ svn:${PORTSDIR}/devel/subversion
MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
# Make the version information of porttools itself
@@ -45,4 +42,8 @@ NEWFILE_DESC= Enable newfile support
RUN_DEPENDS+= newfile:${PORTSDIR}/devel/newfile
.endif
+.if ${PORT_OPTIONS:MDOCS}
+INSTALL_TARGET= install install-docs
+.endif
+
.include <bsd.port.mk>