aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portupgrade/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-04-20 16:43:12 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-04-20 16:43:12 +0000
commit88d871230895bb950e01f4a327d7b22b50a95eee (patch)
tree5c2ffc3485dcbccb64af24f014b51f35fee3ced4 /ports-mgmt/portupgrade/Makefile
parente39c09a64a50631b614a140af4b9e5435385c956 (diff)
downloadports-88d871230895bb950e01f4a327d7b22b50a95eee.tar.gz
ports-88d871230895bb950e01f4a327d7b22b50a95eee.zip
Notes
Diffstat (limited to 'ports-mgmt/portupgrade/Makefile')
-rw-r--r--ports-mgmt/portupgrade/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index a8d7b5feda5c..0153048a5bb4 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -10,20 +10,20 @@ PORTVERSION= 2.4.9.3
PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= ports-mgmt
-MASTER_SITES= http://github.com/pkgtools/pkgtools/tarball/${GITVERSION}/
-DISTNAME= pkgtools-pkgtools-${GITVERSION}
+MASTER_SITES= SF/portupgrade/pkgtools/${PORTVERSION}/
+DISTNAME= pkgtools-${PORTVERSION}
MAINTAINER= bryan@shatow.net
COMMENT= FreeBSD ports/packages administration and management tool suite
+LICENSE= BSD
+
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend" on \
BDB1 "Use Berkeley DB 1.85 as backend" off
CONFLICTS_INSTALL= portupgrade-devel-*
-FETCH_ARGS= -Fpr
-GITVERSION= b99f3ce
-
+USE_BZIP2= yes
USE_RUBY= yes
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
@@ -67,7 +67,7 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
.endif
# parsedate is needed for date globbing
-.if ${RUBY_DEFAULT_VER} == "1.9"
+.if ${RUBY_VER} == 1.9
RUN_DEPENDS+= ${RUBY_SITELIBDIR}/parsedate.rb:${PORTSDIR}/devel/ruby-date2
.endif