aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/poudriere-devel/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-07-21 23:42:04 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-07-21 23:42:04 +0000
commitdecbf9379338c57fb89f2148fa1c426b332566e1 (patch)
treeb430f007be687fc1f4e3048323f9984af2fe3b0e /ports-mgmt/poudriere-devel/Makefile
parentea0532cb22e2cd51aa376b27f2001e889ea19767 (diff)
downloadports-decbf9379338c57fb89f2148fa1c426b332566e1.tar.gz
ports-decbf9379338c57fb89f2148fa1c426b332566e1.zip
Notes
Diffstat (limited to 'ports-mgmt/poudriere-devel/Makefile')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 1e39f313e22d..92e164756c52 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= poudriere
-PORTVERSION= 3.0.99.20130629
+PORTVERSION= 3.0.99.20130721
CATEGORIES= ports-mgmt
MASTER_SITES= http://fossil.etoilebsd.net/poudriere/tarball/ \
LOCAL/bdrewery/${PORTNAME}/
@@ -14,7 +14,7 @@ COMMENT= Port build and test system
LICENSE= BSD
-FSL_CHKIN= 5b2608fcc7
+FSL_CHKIN= 6abae2a52c
MANCOMPRESSED= yes
MAN8= poudriere.8
@@ -24,9 +24,11 @@ OPTIONS_DEFINE= ZSH
CONFLICTS_INSTALL= poudriere-[0-9]*
PLIST_FILES= etc/poudriere.conf.sample \
+ etc/poudriere.d/hooks/bulk.sh.sample \
etc/poudriere.d/hooks/pkgbuild.sh.sample \
etc/rc.d/poudriere \
bin/poudriere \
+ libexec/poudriere/cpdup \
libexec/poudriere/dirwatch \
libexec/poudriere/dirempty \
libexec/poudriere/make_index \
@@ -47,6 +49,7 @@ PLIST_FILES= etc/poudriere.conf.sample \
share/poudriere/jail.sh \
share/poudriere/options.sh \
share/poudriere/ports.sh \
+ share/poudriere/processonelog.sh \
share/poudriere/queue.sh \
share/poudriere/status.sh \
share/poudriere/testport.sh
@@ -65,12 +68,8 @@ PLIST_DIRS= libexec/poudriere \
PLIST_FILES+= share/zsh/site-functions/_poudriere
PLIST_DIRSTRY+= share/zsh/site-functions
PLIST_DIRSTRY+= share/zsh/
-.endif
-
-post-install:
-.if ${PORT_OPTIONS:MZSH}
- @${MKDIR} ${PREFIX}/share/zsh/site-functions/
- @${INSTALL_DATA} ${WRKSRC}/zsh-completions ${PREFIX}/share/zsh/site-functions/_poudriere
+.else
+MAKE_ENV+= NO_ZSH=yes
.endif
.include <bsd.port.mk>