aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/tinderbox-devel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-11-08 21:35:17 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-11-08 21:35:17 +0000
commit13107432e80efe7cd412ef61001e642d12e38ec7 (patch)
tree61a8f32984b3c0a9105c21fc5980c761ab0ed2c7 /ports-mgmt/tinderbox-devel
parent8f5504f187ad5895aadbf58d7d76b6289ffe65aa (diff)
downloadports-13107432e80efe7cd412ef61001e642d12e38ec7.tar.gz
ports-13107432e80efe7cd412ef61001e642d12e38ec7.zip
Notes
Diffstat (limited to 'ports-mgmt/tinderbox-devel')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile7
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh28
2 files changed, 30 insertions, 5 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 95e6d9e2d925..8526c7a94a20 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -1,12 +1,9 @@
-# Ports collection makefile for: misc/tinderbox
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-# Date created: 31 december 2005
-#
+# Created by: Edwin Groothuis <edwin@mavetju.org>
# $FreeBSD$
PORTNAME= tinderbox
DISTVERSION= 3.4${SNAP}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
diff --git a/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh b/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh
new file mode 100644
index 000000000000..7821348a339d
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh
@@ -0,0 +1,28 @@
+--- ./lib/tinderlib.sh.orig 2012-11-07 10:17:43.000000000 +0100
++++ ./lib/tinderlib.sh 2012-11-07 10:18:27.000000000 +0100
+@@ -23,7 +23,7 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+ #
+-# $MCom: portstools/tinderbox/lib/tinderlib.sh,v 1.55.2.9 2012/04/04 10:38:41 beat Exp $
++# $MCom: portstools/tinderbox/lib/tinderlib.sh,v 1.55.2.10 2012/05/21 01:19:28 marcus Exp $
+ #
+
+ tinderLocJail () {
+@@ -225,6 +225,7 @@
+ requestMount () {
+ # set up defaults
+ _type=""
++ _options=""
+ _srcloc=""
+ _dstloc=""
+ _nullfs=0
+@@ -632,7 +633,7 @@
+
+ for r in ${reqs} ; do
+ if [ "${use_pkgng}" = "yes" ]; then
+- if [ -z $(pkg info -qgO ${r}) ]; then
++ if [ -z $(pkg info -q ${r}) ]; then
+ missing="${missing} ${r}"
+ error=1
+ fi