aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/tinderbox
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-12 13:48:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-12 13:48:12 +0000
commit9d84cc1d368c01cd5ad0e807c2d983ddee5d5d87 (patch)
treee0cdfc450559995bded04fef06a85dd8f07e44a9 /ports-mgmt/tinderbox
parent731703aac08b9ea50542e36753013a62317bf290 (diff)
downloadports-9d84cc1d368c01cd5ad0e807c2d983ddee5d5d87.tar.gz
ports-9d84cc1d368c01cd5ad0e807c2d983ddee5d5d87.zip
Notes
Diffstat (limited to 'ports-mgmt/tinderbox')
-rw-r--r--ports-mgmt/tinderbox/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 6c2fc05b6588..57f2fbc24afe 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -6,7 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -22,7 +22,7 @@ OPTIONS= PGSQL "With pgsql" On \
MYSQL "With mysql" Off
NO_BUILD= yes
-USE_APACHE= yes
+USE_APACHE= 1.3+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -43,7 +43,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
@@ -53,6 +53,13 @@ post-extract:
${MV} ${WRKSRC}/www-exp/${f} ${WRKSRC}/www-exp/${f}-dist
.endfor
+post-patch:
+.if defined(WITH_MYSQL)
+ ${REINPLACE_CMD} \
+ -e 's,DB_MAN_PREREQS=.*,DB_MAN_PREREQS="databases/p5-DBD-mysql${MYSQL_VER} databases/mysql${MYSQL_VER}-client",' \
+ ${WRKSRC}/lib/setup-mysql.sh
+.endif
+
do-install:
${MKDIR} ${PREFIX}/tinderbox/scripts
${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts