aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/tinderbox
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-06-03 13:24:58 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-06-03 13:24:58 +0000
commit1b23215da886be7c5e707e16dc709d278893f389 (patch)
tree1063cfca1e0a5ca912060e93c722e24356cb47df /ports-mgmt/tinderbox
parent091aa2789841a798b628098821a0eeacb6f0bcf1 (diff)
Notes
Diffstat (limited to 'ports-mgmt/tinderbox')
-rw-r--r--ports-mgmt/tinderbox/Makefile8
-rw-r--r--ports-mgmt/tinderbox/distinfo6
-rw-r--r--ports-mgmt/tinderbox/files/patch-buildscript27
-rw-r--r--ports-mgmt/tinderbox/files/patch-www-exp__core__TinderboxDS.php14
-rw-r--r--ports-mgmt/tinderbox/files/patch-www-exp__module__moduleBuildPorts.php11
-rw-r--r--ports-mgmt/tinderbox/files/pkg-message.in12
-rw-r--r--ports-mgmt/tinderbox/pkg-plist1
7 files changed, 68 insertions, 11 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 68e91d2a9f2d..17e4c2403956 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -5,9 +5,8 @@
# $FreeBSD$
PORTNAME= tinderbox
-DISTVERSION= ${PORTVERSION}-${PORTREVISION}
-PORTVERSION= 2.4.2
-PORTREVISION= 2 # cvs snapshot from 2008-05-19 14:00
+#DISTVERSION= ${PORTVERSION}-${PORTREVISION}
+PORTVERSION= 2.4.3
CATEGORIES= ports-mgmt
MASTER_SITES= http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
DIST_SUBDIR= tinderbox
@@ -121,6 +120,9 @@ post-patch:
${WRKSRC}/lib/setup-mysql.sh
@${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
+ @${RM} ${WRKSRC}/buildscript.orig
+ @${RM} ${WRKSRC}/www-exp/core/TinderboxDS.php.orig
+ @${RM} ${WRKSRC}/www-exp/module/moduleBuildPorts.php.orig
do-install:
${MKDIR} ${PREFIX}/tinderbox/scripts
diff --git a/ports-mgmt/tinderbox/distinfo b/ports-mgmt/tinderbox/distinfo
index b1fdceea3117..b8c91d68c393 100644
--- a/ports-mgmt/tinderbox/distinfo
+++ b/ports-mgmt/tinderbox/distinfo
@@ -1,6 +1,6 @@
-MD5 (tinderbox/tinderbox-2.4.2-2.tar.gz) = 2d3125d1305eb06a7aaff345430dbaf6
-SHA256 (tinderbox/tinderbox-2.4.2-2.tar.gz) = 288b1cbab0b253b05ccff785605ececcf8eb2a6a5e83b0ccd4783a5b2b360358
-SIZE (tinderbox/tinderbox-2.4.2-2.tar.gz) = 140732
+MD5 (tinderbox/tinderbox-2.4.3.tar.gz) = 88f97d526b4d42dedaf5cc8c2adaab0c
+SHA256 (tinderbox/tinderbox-2.4.3.tar.gz) = 2a540b50342813dd4cf82791028878db6dba2c40af4cb7118f239f7a2286a72c
+SIZE (tinderbox/tinderbox-2.4.3.tar.gz) = 131585
MD5 (tinderbox/favicon.ico) = 1d2e9e267ca81f0ef5bc7b9c391aaced
SHA256 (tinderbox/favicon.ico) = 842f1e23dcfcee24d4d7578381256256cda994347751fb332b6eb2182eae216e
SIZE (tinderbox/favicon.ico) = 4710
diff --git a/ports-mgmt/tinderbox/files/patch-buildscript b/ports-mgmt/tinderbox/files/patch-buildscript
new file mode 100644
index 000000000000..870b7c56e3fe
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-buildscript
@@ -0,0 +1,27 @@
+--- ./buildscript.orig 2008-06-03 15:17:08.000000000 +0300
++++ ./buildscript 2008-06-03 15:20:37.000000000 +0300
+@@ -103,6 +103,12 @@
+
+ L=$(echo ${LOCALBASE} | sed 's,^/,,')
+ X=$(echo ${X11BASE} | sed 's,^/,,')
++
++NOD=$(echo ${NOPORTDOCS} | sed 's,^/,,')
++NOE=$(echo ${NOPORTEXAMPLES} | sed 's,^/,,')
++NPD=$(echo ${NOPORTDATA} | sed 's,^/,,')
++Z=`ident ${dir}/Makefile | grep 'FreeBSD:' | sed 's/^[ \t]*//'`
++
+
+ if [ $phase = 1 ]; then
+
+@@ -110,6 +116,11 @@
+ echo "maintained by: $(make maintainer)"
+ echo "building for: $(uname -rm)"
+ echo "port directory: ${dir}"
++
++ echo "Makefile ident: ${Z}"
++ echo "prefixes: LOCALBASE=${L} X11BASE=${X}"
++ echo "NO* env vars: NOPORTDOCS=${NOD} NOPORTEXAMPLES=${NOE} NOPORTDATA=${NPD}"
++
+ echo "build started at $(date)"
+
+ echo "FETCH_DEPENDS=${FD}"
diff --git a/ports-mgmt/tinderbox/files/patch-www-exp__core__TinderboxDS.php b/ports-mgmt/tinderbox/files/patch-www-exp__core__TinderboxDS.php
new file mode 100644
index 000000000000..38799701d61f
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-www-exp__core__TinderboxDS.php
@@ -0,0 +1,14 @@
+--- ./www-exp/core/TinderboxDS.php.orig 2008-06-02 07:11:02.000000000 +0300
++++ ./www-exp/core/TinderboxDS.php 2008-06-03 15:38:24.000000000 +0300
+@@ -372,6 +372,11 @@
+ if ($sortby == "") $sortby = "Port_Directory";
+ if ($sortby == "Port_Directory") $sortbytable = "p";
+ if ($sortby == "Port_Maintainer") $sortbytable = "p";
++ if ($sortby == "Last_Built") {
++ $sortbytable = "bp";
++ $sortby = "Last_Built desc";
++ }
++
+ $query = "SELECT p.*,
+ bp.Last_Built,
+ bp.Last_Status,
diff --git a/ports-mgmt/tinderbox/files/patch-www-exp__module__moduleBuildPorts.php b/ports-mgmt/tinderbox/files/patch-www-exp__module__moduleBuildPorts.php
new file mode 100644
index 000000000000..8b4d57e33f66
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-www-exp__module__moduleBuildPorts.php
@@ -0,0 +1,11 @@
+--- ./www-exp/module/moduleBuildPorts.php.orig 2008-06-03 15:53:53.000000000 +0300
++++ ./www-exp/module/moduleBuildPorts.php 2008-06-03 15:54:42.000000000 +0300
+@@ -145,7 +145,7 @@
+ $build_id = false;
+ }
+
+- $ports = $this->TinderboxDS->getLatestPorts( $build_id, 20 );
++ $ports = $this->TinderboxDS->getLatestPorts( $build_id, 30 );
+
+ if( is_array( $ports ) && count( $ports ) > 0 ) {
+ $this->template_assign( 'data', $this->modulePorts->get_list_data( $build_name, $ports ) );
diff --git a/ports-mgmt/tinderbox/files/pkg-message.in b/ports-mgmt/tinderbox/files/pkg-message.in
index 18ae33f0698c..17a5f86b8428 100644
--- a/ports-mgmt/tinderbox/files/pkg-message.in
+++ b/ports-mgmt/tinderbox/files/pkg-message.in
@@ -58,14 +58,14 @@ The following walkthrough is the tinderbox environment setup:
- Comment out the lines after "for www", and uncomment the lines "for www-exp".
- Edit the file %%PREFIX%%/tinderbox/scripts/www-exp/inc_ds.php
- (copy from inc_ds.php-dist)
+ (copy from inc_ds.php.dist)
- $DB_HOST should be localhost
- $DB_DRIVER should be pgsql
- $DB_USER should be tinderbox
- Edit the file %%PREFIX%%/tinderbox/scripts/www-exp/inc_tinderbox.php
- (copy from inc_tinderbox.php-dist)
+ (copy from inc_tinderbox.php.dist)
- $rootdir should be %%PREFIX%%/tinderbox
- $wwwrooturi should be /tb
@@ -75,9 +75,11 @@ The following walkthrough is the tinderbox environment setup:
The following walkthrough is the initial tinderbox population setup
and should be executed in %%PREFIX%%/tinderbox/scripts.
+- ./tc init
+
- Create a jail. A jail is a chrooted version of the FreeBSD operating
- system, for example 6.0-RELEASE or 5.4-RELEASE:
- ./create Jail -j 5.4 -d "FreeBSD 5.4-RELEASE" -t RELENG_5_4_0_RELEASE -u CVSUP
+ system, for example 7-STABLE or 7.0-RELEASE:
+ ./create Jail -j 7 -d "FreeBSD 7.0-RELEASE" -t RELENG_7_0_0_RELEASE -u CVSUP
You can have multiple jails on a single machine.
This takes a while.
@@ -86,7 +88,7 @@ and should be executed in %%PREFIX%%/tinderbox/scripts.
This takes a while.
- And then link the two together in a build:
- ./create Build -b 5.4-FreeBSD -j 5.4 -p FreeBSD -d "5.4-RELEASE with FreeBSD ports tree"
+ ./create Build -b 7.0-FreeBSD -j 7 -p FreeBSD -d "7.0-RELEASE with FreeBSD ports tree"
The following walkthrough is the webserver setup:
diff --git a/ports-mgmt/tinderbox/pkg-plist b/ports-mgmt/tinderbox/pkg-plist
index ed0ce52154f7..3d251a972abf 100644
--- a/ports-mgmt/tinderbox/pkg-plist
+++ b/ports-mgmt/tinderbox/pkg-plist
@@ -37,6 +37,7 @@ tinderbox/scripts/pnohang.c
tinderbox/scripts/portbuild
tinderbox/scripts/rawenv.dist
tinderbox/scripts/setup.sh
+tinderbox/scripts/tbkill.sh
tinderbox/scripts/tc
tinderbox/scripts/tinderbox-mysql.schema
tinderbox/scripts/tinderbox-pgsql.schema