aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-08-31 09:12:27 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-08-31 09:12:27 +0000
commit695b6582cf86449e404194569ea80b1e42765a0a (patch)
tree70e1275bf4749b9ea677ed2d4a8f6b53566c15bd /ports-mgmt
parent4d6002ac38cd731583e550bd7c8e1878728ecdab (diff)
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/distilator/Makefile4
-rw-r--r--ports-mgmt/distilator/distinfo6
-rw-r--r--ports-mgmt/distilator/files/patch-Makefile11
3 files changed, 6 insertions, 15 deletions
diff --git a/ports-mgmt/distilator/Makefile b/ports-mgmt/distilator/Makefile
index 6baa5b654c7f..19a7b7371382 100644
--- a/ports-mgmt/distilator/Makefile
+++ b/ports-mgmt/distilator/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= distilator
-PORTVERSION= 1.1
+PORTVERSION= 1.1.1
CATEGORIES= ports-mgmt
MASTER_SITES= https://critical.ch/distilator/ \
LOCAL/ehaupt
@@ -11,6 +11,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line script to check the availability of a ports distfiles
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.18.4_1:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-ftp>=0.3.1:ftp/py-requests-ftp@${PY_FLAVOR}
@@ -20,5 +21,6 @@ NO_ARCH= yes
NO_BUILD= yes
PLIST_FILES= bin/distilator
+SHEBANG_FILES= distilator.py
.include <bsd.port.mk>
diff --git a/ports-mgmt/distilator/distinfo b/ports-mgmt/distilator/distinfo
index 937ceb1ef2ef..f818aa5a3992 100644
--- a/ports-mgmt/distilator/distinfo
+++ b/ports-mgmt/distilator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535469016
-SHA256 (distilator-1.1.tar.gz) = 7a519ee86a1a045b6df8c22147b875389eb6e693520ed6c41d1e4d6ce1cd1462
-SIZE (distilator-1.1.tar.gz) = 3289
+TIMESTAMP = 1535706294
+SHA256 (distilator-1.1.1.tar.gz) = beb0061b3cdcc496319af9f862ed0cfd87f8fdccbf291d4ae37190a14df4bb40
+SIZE (distilator-1.1.1.tar.gz) = 3316
diff --git a/ports-mgmt/distilator/files/patch-Makefile b/ports-mgmt/distilator/files/patch-Makefile
deleted file mode 100644
index 3ff6e9cb656f..000000000000
--- a/ports-mgmt/distilator/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2018-08-28 07:45:48 UTC
-+++ Makefile
-@@ -8,7 +8,7 @@ all:
-
- install:
- @mkdir -p ${DESTDIR}${PREFIX}/bin
-- install -o root -g wheel -m 0555 distilator.py ${DESTDIR}${PREFIX}/bin/distilator
-+ install distilator.py ${DESTDIR}${PREFIX}/bin/distilator
-
- deinstall:
- rm -f ${DESTDIR}${PREFIX}/bin/distilator