aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-06-12 10:00:11 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-06-12 10:00:11 +0000
commit7cb16a9d07d9d5dc5bed7efc99978c49cbcea42d (patch)
tree299f48d57d6ce52d078d0eae24a64b4930563076 /ports-mgmt
parenta282c0ee647a4ae36bdb1142efb451bf2e5b3435 (diff)
downloadports-7cb16a9d07d9d5dc5bed7efc99978c49cbcea42d.tar.gz
ports-7cb16a9d07d9d5dc5bed7efc99978c49cbcea42d.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile8
-rw-r--r--ports-mgmt/portupgrade/Makefile8
2 files changed, 16 insertions, 0 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 74e66937e113..fce5dd56c23e 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 74e66937e113..fce5dd56c23e 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \