aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-12-26 22:41:02 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-12-26 22:41:02 +0000
commit0e0be270949dae9c80e5c29925e370941b7d88e8 (patch)
treecc8b0f6465f7f81a06a414de66bd4c39463b4b9e /ports-mgmt
parent822f7be52d81a9013f5e23c1024a9dbad38a31bc (diff)
downloadports-0e0be270949dae9c80e5c29925e370941b7d88e8.tar.gz
ports-0e0be270949dae9c80e5c29925e370941b7d88e8.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile14
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/distinfo4
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/files/pkg-install.in4
3 files changed, 7 insertions, 15 deletions
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index 845cbbdf4de9..338f61b9e8cd 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= FreeBSD-Portindex
-PORTVERSION= 3.2
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= ports-mgmt perl5
MASTER_SITES= http://www.infracaninophile.co.uk/portindex/
PKGNAMEPREFIX= p5-
@@ -11,7 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matthew@FreeBSD.org
COMMENT= Incremental FreeBSD ports INDEX file generation
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
BUILD_DEPENDS= p5-BerkeleyDB>0:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -21,14 +20,12 @@ NO_ARCH= yes
# GraphViz not required for portindex to run or generate GraphViz
# format output: this is only needed to render the output on the same
# machine.
-OPTIONS_DEFINE= GRAPHVIZ
+OPTIONS_DEFINE= GRAPHVIZ
GRAPHVIS_DESCR= Add GraphViz run-time dependency
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGRAPHVIZ}
-RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
-.endif
+GRAPHVIZ_RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
USES+= perl5
USE_XZ= yes
@@ -45,8 +42,7 @@ SUB_FILES+= pkg-install
SUB_LIST+= CACHE_DIR=${CACHE_DIR} \
CACHE_OWNER=${CACHE_OWNER} \
CACHE_GROUP=${CACHE_GROUP} \
- CACHE_MODE=${CACHE_MODE} \
- CFG_FILE=${PREFIX}/etc/portindex.cfg
+ CACHE_MODE=${CACHE_MODE}
post-install: install-conf
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/distinfo b/ports-mgmt/p5-FreeBSD-Portindex/distinfo
index 7737c3171100..d5ccafcde5e7 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/distinfo
+++ b/ports-mgmt/p5-FreeBSD-Portindex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FreeBSD-Portindex-3.2.tar.xz) = e459a9be1294b9881b86a83d4fe4abb59a898130cc69e5e2d8ae68bf0560d9b1
-SIZE (FreeBSD-Portindex-3.2.tar.xz) = 56036
+SHA256 (FreeBSD-Portindex-3.3.tar.xz) = cd047f92efdc0a54be567287b2f09e095f9a9aa4b66f5674610284a4f3cce04e
+SIZE (FreeBSD-Portindex-3.3.tar.xz) = 56192
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/files/pkg-install.in b/ports-mgmt/p5-FreeBSD-Portindex/files/pkg-install.in
index baf28ebae373..efa3f50ca131 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/files/pkg-install.in
+++ b/ports-mgmt/p5-FreeBSD-Portindex/files/pkg-install.in
@@ -9,7 +9,6 @@ CACHE_DIR=%%CACHE_DIR%%
CACHE_OWNER=%%CACHE_OWNER%%
CACHE_GROUP=%%CACHE_GROUP%%
CACHE_MODE=%%CACHE_MODE%%
-CFG_FILE=%%CFG_FILE%%
case $2 in
@@ -26,9 +25,6 @@ case $2 in
chown ${CACHE_OWNER}:${CACHE_GROUP} ${CACHE_GROUP}
chmod ${CACHE_MODE} ${CACHE_DIR}
fi
- if [ ! -f ${CFG_FILE} ] ; then
- cp -p ${CFG_FILE}.sample ${CFG_FILE}
- fi
;;
esac