aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-05-01 22:56:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-05-01 22:56:32 +0000
commit8fc3f412bd20616f369e2bbbabb50512a4f3726f (patch)
tree70c1d5c84d9cd201e14e8039911360eb663c6382 /ports-mgmt
parent36386700123ab9059184105524cf2f4d2d4b8e9d (diff)
downloadports-8fc3f412bd20616f369e2bbbabb50512a4f3726f.tar.gz
ports-8fc3f412bd20616f369e2bbbabb50512a4f3726f.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_cleanup/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/ports-mgmt/pkg_cleanup/Makefile b/ports-mgmt/pkg_cleanup/Makefile
index e73a5d47faad..d6c3e9d7111e 100644
--- a/ports-mgmt/pkg_cleanup/Makefile
+++ b/ports-mgmt/pkg_cleanup/Makefile
@@ -19,6 +19,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/pkg_cleanup
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not compile on FreeBSD 9.X
+.endif
+
do-extract:
${MKDIR} ${WRKSRC}
${CP} -R ${FILESDIR}/* ${WRKSRC}
@@ -30,4 +36,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pkg_cleanup ${PREFIX}/sbin/pkg_cleanup
${INSTALL_MAN} ${WRKSRC}/pkg_cleanup.1 ${MAN1PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>