aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-16 11:16:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-16 11:16:41 +0000
commitb2fac3aa96bfa73edfb9afc1478b2e6e70c032fd (patch)
treee156495ba35da4ab796cf9cc4ce9aa0e796ae94b /ports-mgmt
parent47be7a61c97731aa5fe34c56767ad5e10bb5c5d2 (diff)
downloadports-b2fac3aa96bfa73edfb9afc1478b2e6e70c032fd.tar.gz
ports-b2fac3aa96bfa73edfb9afc1478b2e6e70c032fd.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg-devel/Makefile1
-rw-r--r--ports-mgmt/pkg-devel/files/patch-libpkg_pkg_config28
-rw-r--r--ports-mgmt/pkg/Makefile1
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg_pkg_config28
4 files changed, 58 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index 559ac7612096..d172d25e6b65 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg-devel/files/patch-libpkg_pkg_config b/ports-mgmt/pkg-devel/files/patch-libpkg_pkg_config
new file mode 100644
index 000000000000..208477937f38
--- /dev/null
+++ b/ports-mgmt/pkg-devel/files/patch-libpkg_pkg_config
@@ -0,0 +1,28 @@
+--- libpkg/pkg_config.c.orig 2013-12-16 08:52:39.000000000 +0100
++++ libpkg/pkg_config.c 2013-12-16 12:09:13.093549000 +0100
+@@ -293,6 +293,7 @@
+ static size_t c_size = sizeof(c) / sizeof(struct config_entry);
+
+ static void pkg_config_kv_free(struct pkg_config_kv *);
++static void pkg_config_value_free(struct pkg_config_value *);
+ static void pkg_config_free(struct pkg_config *conf);
+ static struct pkg_repo *pkg_repo_new(const char *name, const char *url);
+
+@@ -440,7 +441,7 @@
+ continue;
+ }
+ if (!conf->fromenv) {
+- pkg_config_free(conf);
++ HASH_FREE(conf->list, pkg_config_value, pkg_config_value_free);
+ conf->list = NULL;
+ obj_walk_array(cur, conf);
+ }
+@@ -452,7 +453,7 @@
+ continue;
+ }
+ if (!conf->fromenv) {
+- pkg_config_free(conf);
++ HASH_FREE(conf->kvlist, pkg_config_kv, pkg_config_kv_free);
+ conf->kvlist = NULL;
+ obj_walk_object(cur, conf);
+ }
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 7a7fa23ca300..d73eebac927f 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-libpkg_pkg_config b/ports-mgmt/pkg/files/patch-libpkg_pkg_config
new file mode 100644
index 000000000000..208477937f38
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg_pkg_config
@@ -0,0 +1,28 @@
+--- libpkg/pkg_config.c.orig 2013-12-16 08:52:39.000000000 +0100
++++ libpkg/pkg_config.c 2013-12-16 12:09:13.093549000 +0100
+@@ -293,6 +293,7 @@
+ static size_t c_size = sizeof(c) / sizeof(struct config_entry);
+
+ static void pkg_config_kv_free(struct pkg_config_kv *);
++static void pkg_config_value_free(struct pkg_config_value *);
+ static void pkg_config_free(struct pkg_config *conf);
+ static struct pkg_repo *pkg_repo_new(const char *name, const char *url);
+
+@@ -440,7 +441,7 @@
+ continue;
+ }
+ if (!conf->fromenv) {
+- pkg_config_free(conf);
++ HASH_FREE(conf->list, pkg_config_value, pkg_config_value_free);
+ conf->list = NULL;
+ obj_walk_array(cur, conf);
+ }
+@@ -452,7 +453,7 @@
+ continue;
+ }
+ if (!conf->fromenv) {
+- pkg_config_free(conf);
++ HASH_FREE(conf->kvlist, pkg_config_kv, pkg_config_kv_free);
+ conf->kvlist = NULL;
+ obj_walk_object(cur, conf);
+ }