aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-03-21 01:00:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-03-21 01:00:11 +0000
commitfa0ae8e3fb004c9d69494ea43b754fd6f9034c5b (patch)
tree1f28d5ca039078170d8209565c178c33e9847719 /ports-mgmt
parent40691da394b592b2f57c14880e82532609d9ae0f (diff)
downloadports-fa0ae8e3fb004c9d69494ea43b754fd6f9034c5b.tar.gz
ports-fa0ae8e3fb004c9d69494ea43b754fd6f9034c5b.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.pl20
2 files changed, 17 insertions, 6 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 089af27dde31..fba03ed32300 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.13.4
-PORTREVISION= 1
+PORTVERSION= 2.13.5
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index bd480040f1cd..9b55324197fd 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.212 2011/02/15 16:12:07 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.216 2011/03/21 00:58:39 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 13;
-my $micro = 4;
+my $micro = 5;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -1750,6 +1750,7 @@ sub checkmakefile {
USE_RCORDER => 'USE_RC_SUBR',
INSTALLS_SHLIB => 'USE_LDCONFIG',
APACHE_COMPAT => 'USE_APACHE',
+ USE_XPM => 'USE_X11=xpm',
);
@deplist = (\%deprecated);
@@ -2081,8 +2082,8 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
if ((defined($cflags) && $cflags =~ /-I/) ||
(defined($cxxflags) && $cxxflags =~ /-I/)) {
&perror("WARN", $file, -1, "Consider passing include paths ".
- "to configure via CPPFLAGS environment variable ".
- "i.e. CPPFLAGS=\"-I...\" in CONFIGURE_ENV)");
+ "to configure via the CPPFLAGS macro ".
+ "(i.e. CPPFLAGS=-I...)");
}
}
@@ -2100,6 +2101,7 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
if ($configure_env =~ /(FC)=/ ||
$configure_env =~ /(F77)=/ ||
+ $configure_env =~ /(CPPFLAGS)=/ ||
$configure_env =~ /(FFLAGS)=/) {
&perror("FATAL", $file, -1, "$1 is already ".
"passed in CONFIGURE_ENV via bsd.gcc.mk. If you need to ".
@@ -2765,6 +2767,16 @@ MAINTAINER COMMENT
if ($verbose);
$tmp = $sections[$idx];
+ # Check for direct assignment of BUILD_DEPENDS to RUN_DEPENDS.
+ if ($tmp =~ /\nRUN_DEPENDS=[ \t]*\${BUILD_DEPENDS}/) {
+ &perror("FATAL", $file, -1, "RUN_DEPENDS should not be set to ".
+ "\${BUILD_DEPENDS} as \${BUILD_DEPENDS} includes other ".
+ "implicit dependencies. Instead, copy the explicit dependencies ".
+ "from BUILD_DEPENDS to RUN_DEPENDS. See ".
+ "http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-depend.html#AEN2154 ".
+ "for more details.");
+ }
+
# NOTE: EXEC_DEPENDS is obsolete, so it should not be listed.
@linestocheck = qw(
EXTRACT_DEPENDS LIB_DEPENDS PATCH_DEPENDS BUILD_DEPENDS RUN_DEPENDS