aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-26 21:16:25 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-10-26 21:16:25 +0000
commit39f6bb61b3fc7e8149126aeaf3dea4460a3cad7f (patch)
tree5cb2a54f9e445ea7fbdb2f787141dc1dcac5e876 /ports-mgmt
parent547b3c6fb9c5d09b970ee24883cb5cc0ba694755 (diff)
downloadports-39f6bb61b3fc7e8149126aeaf3dea4460a3cad7f.tar.gz
ports-39f6bb61b3fc7e8149126aeaf3dea4460a3cad7f.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile13
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/distinfo4
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/pkg-plist1
3 files changed, 15 insertions, 3 deletions
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index 0b34d36512ae..00062aca4500 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= FreeBSD-Portindex
-PORTVERSION= 2.4
+PORTVERSION= 2.6
CATEGORIES= ports-mgmt perl5
MASTER_SITES= http://www.infracaninophile.co.uk/portindex/
PKGNAMEPREFIX= p5-
@@ -18,6 +18,17 @@ LICENSE= BSD
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
+# GraphViz not required for portindex to run or generate GraphViz
+# format output: this is only needed to render the output on the same
+# machine.
+OPTIONS= GRAPHVIZ "Add GraphViz run-time dependency" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GRAPHVIZ) && !defined(WITHOUT_GRAPHVIZ)
+RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
+.endif
+
USE_XZ= yes
PERL_CONFIGURE= yes
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/distinfo b/ports-mgmt/p5-FreeBSD-Portindex/distinfo
index ea3bc87b718a..2eb40e541ab2 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/distinfo
+++ b/ports-mgmt/p5-FreeBSD-Portindex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FreeBSD-Portindex-2.4.tar.xz) = 78f461e35dcadb9fb79665c698825fd54e081030858cf023bedfeb47b73891d0
-SIZE (FreeBSD-Portindex-2.4.tar.xz) = 50724
+SHA256 (FreeBSD-Portindex-2.6.tar.xz) = 909ea1b4ff67ea08617a54452b6ed9e999787d6ff3458cb59fb6aa81ecc67c13
+SIZE (FreeBSD-Portindex-2.6.tar.xz) = 51828
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/pkg-plist b/ports-mgmt/p5-FreeBSD-Portindex/pkg-plist
index d57c77443617..eac191f58cff 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/pkg-plist
+++ b/ports-mgmt/p5-FreeBSD-Portindex/pkg-plist
@@ -8,6 +8,7 @@ etc/portindex.cfg.sample
@exec [ ! -f %B/portindex.cfg ] && cp -p %B/%f %B/portindex.cfg || true
%%SITE_PERL%%/FreeBSD/Portindex/Config.pm
%%SITE_PERL%%/FreeBSD/Portindex/Category.pm
+%%SITE_PERL%%/FreeBSD/Portindex/GraphViz.pm
%%SITE_PERL%%/FreeBSD/Portindex/Port.pm
%%SITE_PERL%%/FreeBSD/Portindex/Tree.pm
%%SITE_PERL%%/FreeBSD/Portindex/TreeObject.pm