aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2014-07-28 13:21:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2014-07-28 13:21:06 +0000
commit5577d18b3fd5223a8a0bd7ca4678ba644bdbcd62 (patch)
tree80de1e238fca65c665a46b56289834f78600ccab /ports-mgmt
parentd675c18153bb20cd65c9ca1817b3655760c20ae7 (diff)
downloadports-5577d18b3fd5223a8a0bd7ca4678ba644bdbcd62.tar.gz
ports-5577d18b3fd5223a8a0bd7ca4678ba644bdbcd62.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl9
2 files changed, 7 insertions, 4 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 2563e1df6025..bd1e051eaf1b 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.15.3
+PORTVERSION= 2.15.4
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 3d54a2973013..6397abfda738 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.325 2014/07/12 14:39:55 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.327 2014/07/28 13:15:56 marcus Exp $
#
use strict;
@@ -24,6 +24,7 @@ use warnings;
use Getopt::Std;
use File::Find;
use IPC::Open2;
+use File::Basename;
use POSIX qw(strftime);
sub perror($$$$);
@@ -50,7 +51,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 15;
-my $micro = 3;
+my $micro = 4;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -1046,7 +1047,9 @@ sub checkpatch {
return;
}
- if (length $file > 100) {
+ my $bfile = basename($file);
+
+ if (length $bfile > 100) {
&perror("FATAL", $file, -1, "make sure patch file names contain no ".
"more than 100 characters.");
}