aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-30 06:06:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-30 06:06:55 +0000
commit7788e6b3f8481ff4b8eb283d4dc6fe82f0252f96 (patch)
treee76ef1a256fd5dbb3ad86930a4240ef6d9b3b231 /ports-mgmt
parent742369318968d5311396c8b32626960f9b19b6c4 (diff)
downloadports-7788e6b3f8481ff4b8eb283d4dc6fe82f0252f96.tar.gz
ports-7788e6b3f8481ff4b8eb283d4dc6fe82f0252f96.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/bpm/Makefile10
-rw-r--r--ports-mgmt/bpm/files/bpm.desktop.in9
-rw-r--r--ports-mgmt/bpm/pkg-plist3
3 files changed, 20 insertions, 2 deletions
diff --git a/ports-mgmt/bpm/Makefile b/ports-mgmt/bpm/Makefile
index ff50fec51a5c..461d08054bea 100644
--- a/ports-mgmt/bpm/Makefile
+++ b/ports-mgmt/bpm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bpm
PORTVERSION= 0.4.1b
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= sysutils
MASTER_SITES= http://www.meowfishies.com/code/bpm/
EXTRACT_SUFX= .tgz
@@ -18,11 +18,13 @@ COMMENT= A graphical BSD ports collection manager
RUN_DEPENDS= portupgrade:${PORTSDIR}/sysutils/portupgrade
USE_X_PREFIX= yes
-USE_GNOME= gtk20
+USE_GNOME= gtk20 desktopfileutils
USE_REINPLACE= yes
MAKE_ENV+= OSTYPE="${OPSYS}"
+SUB_FILES= bpm.desktop
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e "s|-lintl|-lintl -L${LOCALBASE}/lib|g"
@@ -30,4 +32,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS+=|& ${PTHREAD_CFLAGS}|; \
s|^LDLIBS+=|& ${PTHREAD_LIBS}|' ${WRKSRC}/src/Makefile
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/bpm.desktop ${PREFIX}/share/applications/bpm.desktop
+ @-update-desktop-database
+
.include <bsd.port.mk>
diff --git a/ports-mgmt/bpm/files/bpm.desktop.in b/ports-mgmt/bpm/files/bpm.desktop.in
new file mode 100644
index 000000000000..ad773b9d6038
--- /dev/null
+++ b/ports-mgmt/bpm/files/bpm.desktop.in
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Comment=The BSD Ports Manipulator
+Name=BPM
+Exec=gnomesu %%PREFIX%%/bin/bpm
+Encoding=UTF-8
+Terminal=false
+Type=Application
+Icon=%%PREFIX%%/share/bpm/pixmaps/pkg_48.png
+Categories=Application;System;
diff --git a/ports-mgmt/bpm/pkg-plist b/ports-mgmt/bpm/pkg-plist
index fe24b9008851..e1f9ea3fb0a0 100644
--- a/ports-mgmt/bpm/pkg-plist
+++ b/ports-mgmt/bpm/pkg-plist
@@ -9,6 +9,9 @@ libexec/bpm/fetch-wrapper
%%DATADIR%%/pixmaps/pkg_48.png
%%DATADIR%%/pixmaps/lock_48.png
share/locale/en_CA/LC_MESSAGES/bpm.mo
+share/applications/bpm.desktop
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrm libexec/bpm
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true