aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-07-18 21:39:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-07-18 21:39:07 +0000
commit1af714157df4a49d7e554fb031614abd31db1f71 (patch)
treec0093ea55e8d0c9d5102922e7fc1eba11d907515 /ports-mgmt
parentc079ebc850f72c0ab452279238b69b453742af5e (diff)
downloadports-1af714157df4a49d7e554fb031614abd31db1f71.tar.gz
ports-1af714157df4a49d7e554fb031614abd31db1f71.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl14
2 files changed, 8 insertions, 8 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index fdfa471bb51d..82df303561fe 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.12.0
+PORTVERSION= 2.12.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 2dd59f6ed7d7..0b7c2897567d 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.184 2009/07/09 00:59:29 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.187 2009/07/18 21:39:30 marcus Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 12;
-my $micro = 0;
+my $micro = 1;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -911,7 +911,7 @@ sub checkplist {
}
if ($_ =~ m#man/([^/]+/)?man([$manchapters])/([^\.]+\.[$manchapters])(\.gz)?$#) {
- if ($4 eq '') {
+ if (!$4) {
$plistman{$2} .= ' ' . $3;
if ($mancompress) {
&perror("FATAL", $file, $.,
@@ -928,7 +928,7 @@ sub checkplist {
}
}
$plistmanall{$2} .= ' ' . $3;
- if ($1 ne '') {
+ if ($1) {
$manlangs{substr($1, 0, length($1) - 1)}++;
}
}
@@ -1960,13 +1960,13 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
}
#
- # whole file: check for --build, --mandir, --infodir, and --prefix
+ # whole file: check for --build, --mandir, and --infodir
# when GNU_CONFIGURE
#
if (exists $makevar{GNU_CONFIGURE} &&
$makevar{GNU_CONFIGURE} ne '' &&
- $makevar{CONFIGURE_ARGS} =~ /--(prefix|build|(man|info)dir)/) {
- &perror("WARN", $file, -1, "--build, --mandir, --infodir and --prefix ".
+ $makevar{CONFIGURE_ARGS} =~ /--(build|(man|info)dir)/) {
+ &perror("WARN", $file, -1, "--build, --mandir, and --infodir ".
"are not needed in CONFIGURE_ARGS as they are already set in ".
"bsd.port.mk.");
}