aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-19 21:23:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-19 21:23:01 +0000
commit1f420b6602c313ed7de08edeeb7483afcb45a2b2 (patch)
tree24284a64ff601e79ea68bcdd905fce5d5fd391b5 /ports-mgmt
parent870db9ed5a17e6a973261a1459174b9c56146454 (diff)
downloadports-1f420b6602c313ed7de08edeeb7483afcb45a2b2.tar.gz
ports-1f420b6602c313ed7de08edeeb7483afcb45a2b2.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.14
-rw-r--r--ports-mgmt/portlint/src/portlint.pl17
3 files changed, 15 insertions, 8 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 82df303561fe..8de8a131a7be 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.12.1
+PORTVERSION= 2.12.2
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.1 b/ports-mgmt/portlint/src/portlint.1
index fe4a36a54501..e918a65a5c67 100644
--- a/ports-mgmt/portlint/src/portlint.1
+++ b/ports-mgmt/portlint/src/portlint.1
@@ -1,5 +1,5 @@
.\" $FreeBSD$
-.\" $MCom: portlint/portlint.1,v 1.9 2006/05/30 04:47:45 marcus Exp $
+.\" $MCom: portlint/portlint.1,v 1.10 2009/12/19 21:05:23 marcus Exp $
.\"
.\" Copyright (c) 1997 by Jun-ichiro Hagino <itojun@itojun.org>.
.\" All Rights Reserved. Absolutely no warranty.
@@ -48,7 +48,7 @@ Some of the committers prefer
.Pa ${VARIABLE}
instead of
.Pa $(VARIABLE) ,
-even though they are semantically same.
+even though they are semantically the same.
.It Fl c
Committer flag.
It will add several checks useful only for committers.
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 0b7c2897567d..387c1d82c605 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.187 2009/07/18 21:39:30 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.191 2009/12/19 21:19:43 marcus Exp $
#
use strict;
@@ -29,7 +29,7 @@ use IPC::Open2;
use POSIX qw(strftime);
sub perror($$$$);
-our ($opt_a, $opt_A, $opt_b, $opt_C, $opt_c, $opt_g, $opt_h, $opt_t, $opt_v, $opt_M, $opt_N, $opt_B, $opt_V, @ALLOWED_FULL_PATHS);
+our ($opt_a, $opt_A, $opt_b, $opt_C, $opt_c, $opt_g, $opt_h, $opt_t, $opt_v, $opt_M, $opt_N, $opt_B, $opt_V, @ALLOWED_FULL_PATHS, @MASTERSITES_WHITELIST);
my ($err, $warn);
my ($extrafile, $parenwarn, $committer, $verbose, $usetabs, $newport,
@@ -46,11 +46,12 @@ $contblank = 1;
$portdir = '.';
@ALLOWED_FULL_PATHS = qw(/boot/loader.conf /compat/ /dev/null /etc/inetd.conf);
+@MASTERSITES_WHITELIST = qw(googlecode.com);
# version variables
my $major = 2;
my $minor = 12;
-my $micro = 1;
+my $micro = 2;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -708,6 +709,11 @@ sub checkplist {
&perror("WARN", $file, $., "use \%\%SITE_PERL\%\% ".
"instead of lib/perl5/site_perl/\%\%PERL_VER\%\%.");
}
+ if ($osname ne 'NetBSD' && m'([\w\d]+-portbld-freebsd\d+\.\d+)') {
+ &perror("WARN", $file, $., "possible direct use of the ".
+ "CONFIGURE_TARGET value ($1). Consider using the plist ".
+ "substitution %%CONFIGURE_TARGET%% instead.");
+ }
$seen_special++ if /[\%\@]/;
$seen_dirrm_docsdir++ if /^(\%\%PORTDOCS\%\%)?\@dirrm\s+\%\%DOCSDIR\%\%/ || /^(\%\%PORTDOCS\%\%)?\@unexec\s+(\/bin\/)?rmdir\s+\%D\/\%\%DOCSDIR\%\%\s+2\>\s*\/dev\/null\s+\|\|\s+(\/usr\/bin\/)?true/;
if ($_ =~ /^\@/) {
@@ -839,7 +845,7 @@ sub checkplist {
"If possible, install this file with a different name.");
}
- if ($_ =~ m|/a.out$| && $_ !~ /^\@/) {
+ if ($_ =~ m|/a\.out$| && $_ !~ /^\@/) {
&perror("WARN", $file, $., "this port installs a file named ".
"\"a.out\". This file may be deleted if ".
"daily_clean_disks_enable=\"YES\" in /etc/periodic.conf. ".
@@ -2293,7 +2299,8 @@ DIST_SUBDIR EXTRACT_ONLY
}
# check number of MASTER_SITES
- if ($makevar{MASTER_SITES} ne '') {
+ if ($makevar{MASTER_SITES} ne '' &&
+ ! grep {$makevar{MASTER_SITES} =~ m|$_|} @MASTERSITES_WHITELIST) {
my @sites = split(/\s+/, $makevar{MASTER_SITES});
if (scalar(@sites) == 1) {
&perror("WARN", $file, -1, "only one MASTER_SITE configured. ".