aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-19 06:58:42 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-19 06:58:42 +0000
commit0aa3e2b9c01fb86da8f285ed9d44ded4c38dcbf9 (patch)
treee919e7c1c12384c3aca5b35bffda471f83d8510e /ports-mgmt
parent2078556294410f7aafd3e8a8d6f83f22a7b93754 (diff)
downloadports-0aa3e2b9c01fb86da8f285ed9d44ded4c38dcbf9.tar.gz
ports-0aa3e2b9c01fb86da8f285ed9d44ded4c38dcbf9.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile1
-rw-r--r--ports-mgmt/portlint/src/portlint.pl10
2 files changed, 6 insertions, 5 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 071beec2ecca..064a873c8663 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.10.2
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 3cce0d33f58e..58a2903ec066 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.163 2009/01/18 18:49:03 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.164 2009/01/19 06:57:51 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_g $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -1894,7 +1894,7 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
#
# whole file: CONFIGURE_ENV
#
- if ($whole =~ /\nCONFIGURE_ENV[?:]?=\s*([^\\\n]+(\\\n[^\\\n]+)*)/) {
+ if ($whole =~ /\nCONFIGURE_ENV[?:+]?=\s*([^\\\n]+(\\\n[^\\\n]+)*)/) {
my $configure_env = $1;
my $cflags = undef;
my $cxxflags = undef;
@@ -1937,10 +1937,10 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
if ($configure_env =~ /(FC)=/ ||
$configure_env =~ /(F77)=/ ||
- $configure_env =~ /(FCFLAGS)=/) {
- &perror("FATAL", $file, -1, "The Fortran flag, $1 is already ".
+ $configure_env =~ /(FFLAGS)=/) {
+ &perror("FATAL", $file, -1, "$1 is already ".
"passed in CONFIGURE_ENV via bsd.gcc.mk. If you need to ".
- "override the the default value, alter $1 in the Makefile ".
+ "override the default value, alter $1 in the Makefile ".
"instead with $1=...");
}
}