aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2013-10-20 15:01:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2013-10-20 15:01:13 +0000
commit350039f5895526c62b34b1b5a7531b7bddb15007 (patch)
tree87011df0cfbbce254fd6794ed179c097af1336f8 /ports-mgmt
parent39dbe443bded70e491f4392177c56b810bae2605 (diff)
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 6795c4d7caac..fcb9a0c89e5b 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -10,6 +10,8 @@ DISTFILES= # none
MAINTAINER= marcus@FreeBSD.org
COMMENT= Verifier for FreeBSD port directory
+LICENSE= BSD
+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/src
USES= perl5
@@ -20,22 +22,14 @@ SRC= ${.CURDIR}/src
PLIST_FILES= bin/portlint \
man/man1/portlint.1.gz
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-PLIST_FILES+= %%EXAMPLESDIR%%/portlintgrep
-PLIST_DIRS= %%EXAMPLESDIR%%
-.endif
-
-do-fetch:
- @${DO_NADA}
+PORTEXAMPLES= portlintgrep
pre-patch:
@${CP} -R ${SRC} ${WRKDIR}
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/portlint.pl
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/portlint.pl \
${WRKSRC}/portlintgrep.pl
do-install:
@@ -43,11 +37,8 @@ do-install:
${STAGEDIR}${PREFIX}/bin/portlint
${INSTALL_MAN} ${WRKSRC}/portlint.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m ${BINMODE} -d \
- ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/portlintgrep.pl \
${STAGEDIR}${EXAMPLESDIR}/portlintgrep
-.endif
.include <bsd.port.mk>