aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-08-17 07:12:56 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-08-17 07:12:56 +0000
commit0963c5f0b610a8615db408db75c4fb755a96a34a (patch)
treebf3d949b00eebd838b44c68518dcb4b046eb57eb /ports-mgmt
parent2481d44934778c9e1e4df9d0f3425ac5a9dcc6e5 (diff)
downloadports-0963c5f0b610a8615db408db75c4fb755a96a34a.tar.gz
ports-0963c5f0b610a8615db408db75c4fb755a96a34a.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.subdir.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.subdir.mk b/ports-mgmt/portmk/Mk/bsd.port.subdir.mk
index 82ba7d542b74..0ee1bce07b0b 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.subdir.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.subdir.mk
@@ -48,10 +48,10 @@ STRIP?= -s
.if !defined(NOPRECIOUSMAKEVARS)
.if !defined(ARCH)
-ARCH!= /usr/bin/uname -p
+ARCH!= ${DESTDIR}/usr/bin/uname -p
.endif
.if !defined(OSREL)
-OSREL!= /usr/bin/uname -r | sed -e 's/[-(].*//'
+OSREL!= ${DESTDIR}/usr/bin/uname -r | sed -e 's/[-(].*//'
.endif
.if !defined(OSVERSION)
.if exists(/sbin/sysctl)
@@ -61,23 +61,23 @@ OSVERSION!= /usr/sbin/sysctl -n kern.osreldate
.endif
.endif
.if !defined(PORTOBJFORMAT)
-PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
+PORTOBJFORMAT!= test -x ${DESTDIR}/usr/bin/objformat && ${DESTDIR}/usr/bin/objformat || echo aout
.endif
.endif
-ID?= /usr/bin/id
+ID?= ${DESTDIR}/usr/bin/id
UID!= ${ID} -u
-LOCALBASE?= ${DESTDIR}/usr/local
+LOCALBASE?= ${DESTDIR}${LOCALBASE_REL}
.if exists(${LOCALBASE}/sbin/pkg_info)
PKG_INFO?= ${LOCALBASE}/sbin/pkg_info
.else
-PKG_INFO?= /usr/sbin/pkg_info
+PKG_INFO?= ${DESTDIR}/usr/sbin/pkg_info
.endif
-SED?= /usr/bin/sed
+SED?= ${DESTDIR}/usr/bin/sed
PKGINSTALLVER!= ${PKG_INFO} -P 2>/dev/null | ${SED} -e 's/.*: //'
.if !defined(OPSYS)
-OPSYS!= /usr/bin/uname -s
+OPSYS!= ${DESTDIR}/usr/bin/uname -s
.endif
ECHO_MSG?= echo