aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-10-06 14:49:28 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-10-06 14:49:28 +0000
commit523b049d6378e67662e718d440c558e0f1318a4f (patch)
treeb1b8b1e3c7e87acf46475423d48719f649be8d34 /ports-mgmt
parent1c98d180144190c32a25a27344080170a2f25497 (diff)
downloadports-523b049d6378e67662e718d440c558e0f1318a4f.tar.gz
ports-523b049d6378e67662e718d440c558e0f1318a4f.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/pkg_add_it/Makefile23
-rw-r--r--ports-mgmt/pkg_add_it/distinfo3
-rw-r--r--ports-mgmt/pkg_add_it/pkg-descr22
4 files changed, 49 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 233452ca8d4a..143fc4860017 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -18,6 +18,7 @@
SUBDIR += p5-FreeBSD-Ports-INDEXhash
SUBDIR += pib
SUBDIR += pkg-orphan
+ SUBDIR += pkg_add_it
SUBDIR += pkg_cleanup
SUBDIR += pkg_cutleaves
SUBDIR += pkg_install
diff --git a/ports-mgmt/pkg_add_it/Makefile b/ports-mgmt/pkg_add_it/Makefile
new file mode 100644
index 000000000000..419735aff69e
--- /dev/null
+++ b/ports-mgmt/pkg_add_it/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pkg_add_it
+# Date created: 05 October 2008
+# Whom: Marin Atanasov <dnaeon@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkg_add_it
+PORTVERSION= 1.0
+CATEGORIES= ports-mgmt
+MASTER_SITES= http://www.unix-heaven.org/ports-mgmt/
+
+MAINTAINER= dnaeon@gmail.com
+COMMENT= Interactive interface for the pkg_add(1) command
+
+MAN1= pkg_add_it.1
+PLIST_FILES= sbin/pkg_add_it
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pkg_add_it ${PREFIX}/sbin/pkg_add_it
+ ${INSTALL_MAN} ${WRKSRC}/pkg_add_it.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg_add_it/distinfo b/ports-mgmt/pkg_add_it/distinfo
new file mode 100644
index 000000000000..56d60173f3ef
--- /dev/null
+++ b/ports-mgmt/pkg_add_it/distinfo
@@ -0,0 +1,3 @@
+MD5 (pkg_add_it-1.0.tar.gz) = 558589812547be1f7ea878381f5899d1
+SHA256 (pkg_add_it-1.0.tar.gz) = c96fabdbe501659a00a7aba3c6310022d956f4aae39cbf3c27537e300a222c39
+SIZE (pkg_add_it-1.0.tar.gz) = 9199
diff --git a/ports-mgmt/pkg_add_it/pkg-descr b/ports-mgmt/pkg_add_it/pkg-descr
new file mode 100644
index 000000000000..0559e60ba336
--- /dev/null
+++ b/ports-mgmt/pkg_add_it/pkg-descr
@@ -0,0 +1,22 @@
+This program provides an interactive interface for the pkg_add(1) tool.
+
+It's purpose is to search for a package pattern, making easier for the user
+to find a package and install it. This tool is not a clone of pkg_add(1).
+It uses pkg_add(1) to install packages while providing an interactive
+interface, so the user could easily choose and install a given package.
+
+This tool is written in C and does not require any additional packages to be
+installed. It should build and run on any system which supports pkg_add(1).
+
+The pkg_add_it(1) tool supports local and remote pattern search:
+
+ * Local pattern search - recursively scanning a directory for
+ a given package pattern
+ * Remote pattern search - accomplished by searching the INDEX file.
+ If INDEX is not in current directory pkg_add_it(1) fetches it and
+ then scans the INDEX file for a pattern
+
+To learn more about the pkg_add_it(1) tool read the manual page.
+
+Author: Marin Atanasov <dnaeon@gmail.com>
+WWW: http://www.unix-heaven.org/pkg_add_it.html