aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-02-04 14:16:32 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-02-04 14:16:32 +0000
commit4bae1c78a6eb232ad6a59c2b59d42e7b885da84d (patch)
tree04193464c1a2022d062821d90518729c129dc2b2 /ports-mgmt
parent25ab2c090e00b2e211e808e02878c73cbb710667 (diff)
downloadports-4bae1c78a6eb232ad6a59c2b59d42e7b885da84d.tar.gz
ports-4bae1c78a6eb232ad6a59c2b59d42e7b885da84d.zip
Fix variable substitution in pkg-message
Also, while here: - Update licenses. - Lint with portfmt and portclippy. - Fix typos in pkg-message. Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=525168
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg-provides/Makefile17
-rw-r--r--ports-mgmt/pkg-provides/files/pkg-message.in (renamed from ports-mgmt/pkg-provides/pkg-message)8
2 files changed, 14 insertions, 11 deletions
diff --git a/ports-mgmt/pkg-provides/Makefile b/ports-mgmt/pkg-provides/Makefile
index 6979cc5a0646..2983341e8b3e 100644
--- a/ports-mgmt/pkg-provides/Makefile
+++ b/ports-mgmt/pkg-provides/Makefile
@@ -3,27 +3,30 @@
PORTNAME= pkg-provides
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= Pkg plugin for querying which package provides a particular file
-LICENSE= BSD2CLAUSE
+LICENSE= BSD2CLAUSE BSD3CLAUSE BSD4CLAUSE
+LICENSE_COMB= multi
NOT_FOR_ARCHS= armv6 mips mips64
-LIB_DEPENDS= libpcre.so:devel/pcre
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
+LIB_DEPENDS= libpcre.so:devel/pcre
-USE_LDCONFIG= yes
USE_GITHUB= yes
-
-SUB_LIST= LOCALBASE=${LOCALBASE}
-
GH_ACCOUNT= rosorio
GH_TAGNAME= 71b876c
+USE_LDCONFIG= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= LOCALBASE=${LOCALBASE}
-PLIST_FILES= lib/pkg/provides.so man/man8/pkg-provides.8.gz
+PLIST_FILES= lib/pkg/provides.so \
+ man/man8/pkg-provides.8.gz
do-install:
${MKDIR} ${STAGEDIR}${LOCALBASE}/lib/pkg/
diff --git a/ports-mgmt/pkg-provides/pkg-message b/ports-mgmt/pkg-provides/files/pkg-message.in
index 0431a5d1d3a7..fcf05e2fce5d 100644
--- a/ports-mgmt/pkg-provides/pkg-message
+++ b/ports-mgmt/pkg-provides/files/pkg-message.in
@@ -3,19 +3,19 @@
message: <<EOM
In order to use the pkg-provides plugin you need to enable plugins in pkg.
To do this, uncomment the following lines in %%LOCALBASE%%/etc/pkg.conf file
-and add pkg-provides to the supported plugin list
+and add pkg-provides to the supported plugin list:
PKG_PLUGINS_DIR = "%%LOCALBASE%%/lib/pkg/";
PKG_ENABLE_PLUGINS = true;
PLUGINS [ provides ];
-After that run `pkg plugins' to see the plugins handled by pkg`.
+After that run `pkg plugins' to see the plugins handled by pkg.
EOM
}
{ type: upgrade
maximum_version: "0.6.0"
message: <<EOM
-To update the provides database run `pkg provides -u`
+To update the provides database run `pkg provides -u`.
EOM
}
{
@@ -24,7 +24,7 @@ EOM
message: <<EOM
Pkg-provides from v0.6.0 introduces a new database file format.
-To update the provides database run `pkg provides -uf`
+To update the provides database run `pkg provides -uf`.
EOM
}
]