aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-06-27 19:35:04 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-06-27 19:35:04 +0000
commit56136a652958b42b96e6f08ec4678ba2ceeb84db (patch)
tree72d6b1813a88bbdec9daa76be6926d644abfafd6 /ports-mgmt
parent3b3c0d0130481ae682180b140f146e793fcf32dc (diff)
downloadports-56136a652958b42b96e6f08ec4678ba2ceeb84db.tar.gz
ports-56136a652958b42b96e6f08ec4678ba2ceeb84db.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.database.mk373
-rw-r--r--ports-mgmt/portmk/Mk/bsd.php.mk334
2 files changed, 0 insertions, 707 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.database.mk b/ports-mgmt/portmk/Mk/bsd.database.mk
deleted file mode 100644
index b862fcba4f36..000000000000
--- a/ports-mgmt/portmk/Mk/bsd.database.mk
+++ /dev/null
@@ -1,373 +0,0 @@
-# -*- mode: Makefile; tab-width: 4; -*-
-# ex: ts=4
-#
-# $FreeBSD$
-#
-
-.if defined(_POSTMKINCLUDED) && !defined(Database_Post_Include)
-
-Database_Post_Include= bsd.database.mk
-Database_Include_MAINTAINER= ports@FreeBSD.org
-
-# This file contains some routines to interact with different databases, such
-# as mysql, postgresql and berkley DB. For including this file define macro
-# USE_[DATABASE], for example USE_MYSQL. Defining macro like USE_[DATABASE]_VER
-# or WANT_[DATABSE]_VER will include this file too.
-#
-##
-# USE_MYSQL - Add MySQL client dependency.
-# If no version is given (by the maintainer via the port or
-# by the user via defined variable), try to find the
-# currently installed version. Fall back to default if
-# necessary (MySQL4.1 = 41).
-# DEFAULT_MYSQL_VER
-# - MySQL default version. Can be overriden within a port.
-# Default: 41.
-# WANT_MYSQL_VER
-# - Maintainer can set an arbitrary version of MySQL by using it.
-# BROKEN_WITH_MYSQL
-# - This variable can be defined if the ports doesn't support
-# one or more version of MySQL.
-# WITH_MYSQL_VER
-# - User defined variable to set MySQL version.
-# MYSQL_VER
-# - Detected MySQL version.
-##
-# USE_PGSQL - Add PostgreSQL client dependency.
-# If no version is given (by the maintainer via the port or
-# by the user via defined variable), try to find the
-# currently installed version. Fall back to default if
-# necessary (PostgreSQL-7.4 = 74).
-# DEFAULT_PGSQL_VER
-# - PostgreSQL default version. Can be overridden within a port.
-# Default: 74.
-# WANT_PGSQL_VER
-# - Maintainer can set an arbitrary version of PostgreSQL by
-# using it.
-# BROKEN_WITH_PGSQL
-# - This variable can be defined if the ports doesn't support
-# one or more versions of PostgreSQL.
-# PGSQL_VER
-# - Detected PostgreSQL version.
-##
-# USE_BDB - Add Berkeley DB library dependency.
-# If no version is given (by the maintainer via the port or
-# by the user via defined variable), try to find the
-# currently installed version. Fall back to default if
-# necessary (db41+).
-# INVALID_BDB_VER - This variable can be defined when the port doesn't
-# support one or more versions of Berkeley DB.
-# WANT_BDB_VER - Maintainer can set a version of Berkeley DB to always
-# build this port with (overrides WITH_BDB_VER).
-# WITH_BDB_VER - User defined global variable to set Berkeley DB version
-# <UNIQUENAME>_WITH_BDB_VER - User defined port specific variable to set
-# Berkeley DB version
-# WITH_BDB_HIGHEST - Use the highest installed version of Berkeley DB
-# BDB_LIB_NAME - This variable is automatically set to the name of the
-# Berkeley DB library (default: db41)
-# BDB_LIB_CXX_NAME - This variable is automatically set to the name of the
-# Berkeley DB c++ library (default: db41_cxx)
-# BDB_INCLUDE_DIR - This variable is automatically set to the location of
-# the Berkeley DB include directory.
-# (default: ${LOCALBASE}/include/db41)
-# BDB_LIB_DIR - This variable is automatically set to the location of
-# the Berkeley DB library directory.
-# BDB_VER - Detected Berkeley DB version.
-##
-# USE_SQLITE - Add dependency on sqlite library. Valid values are:
-# 3 and 2. If version is not specified directly then
-# sqlite3 is used (if USE_SQLITE= yes).
-# SQLITE_VER - Detected sqlite version.
-
-.if defined(USE_MYSQL)
-DEFAULT_MYSQL_VER?= 50
-# MySQL client version currently supported.
-MYSQL323_LIBVER= 10
-MYSQL40_LIBVER= 12
-MYSQL41_LIBVER= 14
-MYSQL50_LIBVER= 15
-MYSQL51_LIBVER= 15
-
-# Setting/finding MySQL version we want.
-.if exists(${LOCALBASE}/bin/mysql)
-_MYSQL_VER!= ${LOCALBASE}/bin/mysql --version | ${SED} -e 's/.*Distrib \([0-9]\)\.\([0-9]*\).*/\1\2/'
-.endif
-
-.if defined(WANT_MYSQL_VER)
-.if defined(WITH_MYSQL_VER) && ${WITH_MYSQL_VER} != ${WANT_MYSQL_VER}
-IGNORE= cannot install: the port wants mysql${WANT_MYSQL_VER}-client and you try to install mysql${WITH_MYSQL_VER}-client.
-.endif
-MYSQL_VER= ${WANT_MYSQL_VER}
-.elif defined(WITH_MYSQL_VER)
-MYSQL_VER= ${WITH_MYSQL_VER}
-.else
-.if defined(_MYSQL_VER)
-MYSQL_VER= ${_MYSQL_VER}
-.else
-MYSQL_VER= ${DEFAULT_MYSQL_VER}
-.endif
-.endif # WANT_MYSQL_VER
-
-.if defined(_MYSQL_VER)
-.if ${_MYSQL_VER} != ${MYSQL_VER}
-IGNORE= cannot install: MySQL versions mismatch: mysql${_MYSQL_VER}-client is installed and wanted version is mysql${MYSQL_VER}-client
-.endif
-.endif
-
-# And now we are checking if we can use it
-.if defined(MYSQL${MYSQL_VER}_LIBVER)
-.if defined(BROKEN_WITH_MYSQL)
-. for VER in ${BROKEN_WITH_MYSQL}
-. if (${MYSQL_VER} == "${VER}")
-IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${BROKEN_WITH_MYSQL})
-. endif
-. endfor
-.endif # BROKEN_WITH_MYSQL
-LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
-.else
-IGNORE= cannot install: unknown MySQL version: ${MYSQL_VER}
-.endif # Check for correct libs
-.endif # USE_MYSQL
-
-.if defined(USE_PGSQL)
-DEFAULT_PGSQL_VER?= 74
-PGSQL73_LIBVER= 3
-PGSQL74_LIBVER= 3
-PGSQL80_LIBVER= 4
-PGSQL81_LIBVER= 4
-
-# Setting/finding PostgreSQL version we want.
-.if exists(${LOCALBASE}/bin/pg_config)
-_PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)[^0-9].*/\1\2/p'
-.endif
-
-.if defined(WANT_PGSQL_VER) && defined(_PGSQL_VER) && ${WANT_PGSQL_VER} != ${_PGSQL_VER}
-IGNORE= cannot install: the port wants postgresql${WANT_PGSQL_VER}-client but you have postgresql${_PGSQL_VER}-client installed
-.endif
-
-.if defined(_PGSQL_VER)
-PGSQL_VER= ${_PGSQL_VER}
-.elif defined(WANT_PGSQL_VER)
-PGSQL_VER= ${WANT_PGSQL_VER}
-.else
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-.endif
-
-# And now we are checking if we can use it
-.if defined(PGSQL${PGSQL_VER}_LIBVER)
-.if defined(BROKEN_WITH_PGSQL)
-. for VER in ${BROKEN_WITH_PGSQL}
-. if (${PGSQL_VER} == "${VER}")
-IGNORE= cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${BROKEN_WITH_PGSQL} not supported)
-. endif
-. endfor
-.endif # BROKEN_WITH_PGSQL
-LIB_DEPENDS+= pq.${PGSQL${PGSQL_VER}_LIBVER}:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
-.else
-IGNORE= cannot install: unknown PostgreSQL version: ${PGSQL_VER}
-.endif # Check for correct version
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-.endif # USE_PGSQL
-
-
-.if defined(USE_BDB)
-
-_DB_PORTS= 2 3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+
-# Dependence lines for different db versions
-db2_DEPENDS= db2.0:${PORTSDIR}/databases/db2
-db3_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-db40_DEPENDS= db4.0:${PORTSDIR}/databases/db4
-db41_DEPENDS= db41.1:${PORTSDIR}/databases/db41
-db42_DEPENDS= db-4.2.2:${PORTSDIR}/databases/db42
-db43_DEPENDS= db-4.3.0:${PORTSDIR}/databases/db43
-db44_DEPENDS= db-4.4.0:${PORTSDIR}/databases/db44
-# Detect db versions by finding some files
-db3_FIND= ${LOCALBASE}/include/db3/db.h
-db40_FIND= ${LOCALBASE}/include/db4/db.h
-db41_FIND= ${LOCALBASE}/include/db41/db.h
-db42_FIND= ${LOCALBASE}/include/db42/db.h
-db43_FIND= ${LOCALBASE}/include/db43/db.h
-db44_FIND= ${LOCALBASE}/include/db44/db.h
-
-# For specifying [3, 40, 41, ..]+
-_DB_3P= 3 40 41 42 43 44
-_DB_40P= 40 41 42 43 44
-_DB_41P= 41 42 43 44
-_DB_42P= 42 43 44
-_DB_43P= 43 44
-
-# Override the global WITH_BDB_VER with the
-# port specific <UNIQUENAME>_WITH_BDB_VER
-.if defined(${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER)
-WITH_BDB_VER= ${${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER}
-.endif
-
-.if defined(WITH_BDB_VER)
-. if ${WITH_BDB_VER} == 4
-USE_BDB= 40
-. elif ${WITH_BDB_VER} != 1
-USE_BDB= ${WITH_BDB_VER}
-. endif
-.endif
-_WANT_BDB_VER= ${USE_BDB}
-
-# Assume the default bdb version as 41
-.if ${USE_BDB:L} == "yes"
-_WANT_BDB_VER= 41+
-.endif
-
-# Detect bdb version
-_BDB_VER= no
-_BDB_BROKEN= no
-
-# Override the user defined WITH_BDB_VER with the WANT_BDB_VER
-.if defined(WANT_BDB_VER)
-.for bdb in ${_DB_PORTS}
-.if ${WANT_BDB_VER} == "${bdb}" && ${_BDB_VER} == "no"
-_BDB_VER= ${WANT_BDB_VER}
-.endif
-.endfor
-USE_BDB= ${WANT_BDB_VER}
-.else
-.for bdb in ${_DB_PORTS}
-.if ${_WANT_BDB_VER} == "${bdb}" && ${_BDB_VER} == "no"
-_MATCHED_DB_VER:= ${bdb:S/+//}
-. if ${_MATCHED_DB_VER} == "${bdb}"
-# USE_BDB is exactly specified
-_BDB_VER= ${bdb}
-.else
-# USE_BDB is specified as VER+
-. for dbx in ${_DB_${_MATCHED_DB_VER}P}
-. if exists(${db${dbx}_FIND})
-_BRKDB= no
-# Skip versions we are broken with
-. if defined(INVALID_BDB_VER)
-_CHK_BDB:= ${dbx}
-. for BRKDB in ${INVALID_BDB_VER}
-. if ${_CHK_BDB} == "${BRKDB}"
-_BRKDB= yes
-. endif
-. endfor
-. endif
-. if ${_BRKDB} == no
-. if defined(WITH_BDB_HIGHEST)
-# Use the highest version of Berkeley DB found
-_BDB_VER= ${dbx}
-. elif ${_BDB_VER} == no
-# Use the first Berkeley DB found
-_BDB_VER= ${dbx}
-. endif
-. endif
-. endif
-. endfor
-. if ${_BDB_VER} == "no"
-# No existing db4 version is detected in system
-_BDB_VER= ${_MATCHED_DB_VER}
-. endif
-. endif
-.endif
-.endfor
-.endif
-
-# USE_BDB is specified incorrectly, so mark this as IGNORE
-.if ${_BDB_VER} == "no"
-IGNORE= cannot install: unknown bdb version: ${USE_BDB}
-.else
-# Now check if we can use it
-. if defined(INVALID_BDB_VER)
-. for VER in ${INVALID_BDB_VER}
-_CHK_PLUS:= ${VER:S/+//}
-# INVALID_BDB_VER is specified as VER+
-. if ${_CHK_PLUS} != "${VER}"
-. if ${_BDB_VER} == "${_CHK_PLUS}
-_BDB_BROKEN= yes
-. else
-. for VER_P in ${_DB_${_CHK_PLUS}P}
-. if ${_BDB_VER} == "${VER_P}"
-_BDB_BROKEN= yes
-. endif
-. endfor
-. endif
-. elif ${_BDB_VER} == "${VER}"
-_BDB_BROKEN= yes
-. endif
-. endfor
-. endif
-. if ${_BDB_BROKEN} == "yes"
-IGNORE= cannot install: does not work with bdb version: ${_BDB_VER} (${INVALID_BDB_VER} not supported)
-. else
-# Now add the dependancy on Berkeley DB ${_BDB_VER) version
-.if defined(BDB_BUILD_DEPENDS)
-BUILD_DEPENDS+= ${db${_BDB_VER}_FIND}:${db${_BDB_VER}_DEPENDS:C/^db.*://}
-.else
-LIB_DEPENDS+= ${db${_BDB_VER}_DEPENDS}
-.endif
-. if ${_BDB_VER} == 40
-BDB_LIB_NAME= db4
-BDB_LIB_CXX_NAME= db4_cxx
-BDB_INCLUDE_DIR= ${LOCALBASE}/include/db4
-. elif ${_BDB_VER} == 42
-BDB_LIB_NAME= db-4.2
-BDB_LIB_CXX_NAME= db_cxx-4.2
-BDB_LIB_DIR= ${LOCALBASE}/lib/db42
-. elif ${_BDB_VER} == 43
-BDB_LIB_NAME= db-4.3
-BDB_LIB_CXX_NAME= db_cxx-4.3
-BDB_LIB_DIR= ${LOCALBASE}/lib/db43
-. elif ${_BDB_VER} == 44
-BDB_LIB_NAME= db-4.4
-BDB_LIB_CXX_NAME= db_cxx-4.4
-BDB_LIB_DIR= ${LOCALBASE}/lib/db44
-. endif
-BDB_LIB_NAME?= db${_BDB_VER}
-BDB_LIB_CXX_NAME?= db${_BDB_VER}_cxx
-BDB_INCLUDE_DIR?= ${LOCALBASE}/include/db${_BDB_VER}
-BDB_LIB_DIR?= ${LOCALBASE}/lib
-. endif
-BDB_VER= ${_BDB_VER}
-.endif
-
-# Obsolete variables
-.if defined(OBSOLETE_BDB_VAR)
-. for var in ${OBSOLETE_BDB_VAR}
-. if defined(${var})
-BAD_VAR+= ${var},
-. endif
-. endfor
-. if defined(BAD_VAR)
-_IGNORE_MSG= Obsolete variable(s) ${BAD_VAR} use WITH_BDB_VER or ${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER to select Berkeley DB version
-. if defined(IGNORE)
-IGNORE+= ${_IGNORE_MSG}
-. else
-IGNORE= ${_IGNORE_MSG}
-. endif
-. endif
-.endif
-
-.endif # USE_BDB
-
-# Handling sqlite dependency
-.if defined(USE_SQLITE)
-
-.if ${USE_SQLITE:L} == "yes"
-_SQLITE_VER= 3
-.else
-_SQLITE_VER= ${USE_SQLITE}
-.endif
-
-# USE_SQLITE is specified incorrectly, so mark this as IGNORE
-.if ${_SQLITE_VER} == "3"
-LIB_DEPENDS+= sqlite${_SQLITE_VER}:${PORTSDIR}/databases/sqlite${_SQLITE_VER}
-SQLITE_VER= ${_SQLITE_VER}
-.elif ${_SQLITE_VER} == "2"
-LIB_DEPENDS+= sqlite.${_SQLITE_VER}:${PORTSDIR}/databases/sqlite${_SQLITE_VER}
-SQLITE_VER= ${_SQLITE_VER}
-.else
-IGNORE= cannot install: unknown sqlite version: ${_SQLITE_VER}
-.endif
-
-.endif # defined(USE_SQLITE)
-
-.endif # defined(_POSTMKINCLUDED) && !defined(Database_Post_Include)
diff --git a/ports-mgmt/portmk/Mk/bsd.php.mk b/ports-mgmt/portmk/Mk/bsd.php.mk
deleted file mode 100644
index ed8965f58650..000000000000
--- a/ports-mgmt/portmk/Mk/bsd.php.mk
+++ /dev/null
@@ -1,334 +0,0 @@
-#
-# bsd.php.mk - Support for PHP-based ports.
-#
-# Created by: Alex Dupre <ale@FreeBSD.org>
-#
-# For FreeBSD committers:
-# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
-#
-# $FreeBSD: /tmp/pcvs/ports/ports-mgmt/portmk/Mk/Attic/bsd.php.mk,v 1.5 2006-06-05 19:29:23 linimon Exp $
-#
-# Adding 'USE_PHP=yes' to a port includes this Makefile after bsd.ports.pre.mk.
-# If the port requires a predefined set of PHP extensions, they can be
-# listed in this way:
-#
-# USE_PHP= ext1 ext2 ext3
-#
-# The port can set these options in its Makefile before bsd.ports.pre.mk:
-#
-# DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
-# BROKEN_WITH_PHP=N - The port doesn't work with PHP version N.
-# USE_PHPIZE=yes - Use to build a PHP extension.
-# USE_PHPEXT=yes - Use to build, install and register a PHP extension.
-# USE_PHP_BUILD=yes - Set PHP also as a build dependency.
-# WANT_PHP_CLI=yes - Want the CLI version of PHP.
-# WANT_PHP_CGI=yes - Want the CGI version of PHP.
-# WANT_PHP_MOD=yes - Want the Apache Module for PHP.
-# WANT_PHP_WEB=yes - Want the Apache Module or the CGI version of PHP.
-#
-# You may combine multiple WANT_PHP_* knobs.
-# Don't specify any WANT_PHP_* knob if your port will work with every PHP SAPI.
-#
-
-PHP_Include_MAINTAINER= ale@FreeBSD.org
-
-.if exists(${LOCALBASE}/etc/php.conf)
-.include "${LOCALBASE}/etc/php.conf"
-PHP_EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -ne 's,^${LOCALBASE}/lib/php/\(.*\),\1,p'
-.else
-DEFAULT_PHP_VER?= 5
-
-PHP_VER?= ${DEFAULT_PHP_VER}
-.if ${PHP_VER} == 4
-PHP_EXT_DIR= 20020429
-.else
-PHP_EXT_DIR= 20050922
-.endif
-
-HTTPD?= ${LOCALBASE}/sbin/httpd
-.if exists(${HTTPD})
-APACHE_VERSION!= ${HTTPD} -V | ${SED} -ne 's/^Server version: Apache\/\([0-9]\)\.\([0-9]*\).*/\1\2/p'
-. if ${APACHE_VERSION} > 13
-APXS?= ${LOCALBASE}/sbin/apxs
-APACHE_MPM!= ${APXS} -q MPM_NAME
-. if ${APACHE_MPM} == "worker"
-PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
-. endif
-. endif
-.elif defined(APACHE_PORT)
-APACHE_VERSION!= ${ECHO_CMD} ${APACHE_PORT} | ${SED} -ne 's,.*/apache\([0-9]*\).*,\1,p'
-. if ${APACHE_VERSION} > 13 && defined(WITH_MPM) && ${WITH_MPM} == "worker"
-PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
-. endif
-.endif
-
-.if defined(WITH_DEBUG)
-PHP_EXT_DIR:= ${PHP_EXT_DIR}-debug
-.endif
-PHP_SAPI?= ""
-.endif
-PHP_EXT_INC?= ""
-
-.if defined(BROKEN_WITH_PHP)
-. for VER in ${BROKEN_WITH_PHP}
-. if ${PHP_VER} == "${VER}"
-BROKEN= Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})
-. endif
-. endfor
-.endif
-
-.if defined(WANT_PHP_WEB)
-. if defined(WANT_PHP_CGI) || defined(WANT_PHP_MOD)
-check-makevars::
- @${ECHO_CMD} "If you define WANT_PHP_WEB you cannot set also WANT_PHP_CGI"
- @${ECHO_CMD} "or WANT_PHP_MOD. Use only one of them."
- @${FALSE}
-. else
-. if defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mmod} == ""
-check-makevars::
- @${ECHO_CMD} "This port requires the Apache Module or the CGI version of PHP, but you have"
- @${ECHO_CMD} "already installed a PHP port without them."
- @${FALSE}
-. endif
-. endif
-.else
-
-.if defined(WANT_PHP_CGI)
-. if defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == ""
-check-makevars::
- @${ECHO_CMD} "This port requires the CGI version of PHP, but you have already"
- @${ECHO_CMD} "installed a PHP port without CGI."
- @${FALSE}
-. endif
-.else
-
-.if defined(WANT_PHP_CLI)
-. if defined(PHP_VERSION) && ${PHP_SAPI:Mcli} == ""
-check-makevars::
- @${ECHO_CMD} "This port requires the CLI version of PHP, but you have already"
- @${ECHO_CMD} "installed a PHP port without CLI."
- @${FALSE}
-. endif
-.else
-
-.if defined(WANT_PHP_MOD)
-. if defined(PHP_VERSION) && ${PHP_SAPI:Mmod} == ""
-check-makevars::
- @${ECHO_CMD} "This port requires the Apache Module for PHP, but you have already"
- @${ECHO_CMD} "installed a PHP port without the Apache Module."
- @${FALSE}
-. endif
-.endif
-
-.endif
-
-.endif
-
-.endif
-
-PHP_PORT= ${PORTSDIR}/lang/php${PHP_VER}
-
-.if defined(USE_PHP_BUILD)
-BUILD_DEPENDS+= ${LOCALBASE}/include/php/main/php.h:${PHP_PORT}
-.endif
-RUN_DEPENDS+= ${LOCALBASE}/include/php/main/php.h:${PHP_PORT}
-
-PLIST_SUB+= PHP_EXT_DIR=${PHP_EXT_DIR}
-SUB_LIST+= PHP_EXT_DIR=${PHP_EXT_DIR}
-
-.if defined(USE_PHPIZE) || defined(USE_PHPEXT)
-BUILD_DEPENDS+= phpize:${PHP_PORT}
-GNU_CONFIGURE= YES
-USE_AUTOTOOLS+= autoconf:259:env
-CONFIGURE_ARGS+=--with-php-config=${LOCALBASE}/bin/php-config
-
-configure-message: phpize-message do-phpize
-
-phpize-message:
- @${ECHO_MSG} "===> PHPizing for ${PKGNAME}"
-
-do-phpize:
- @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${LOCALBASE}/bin/phpize)
-.endif
-
-.if defined(USE_PHPEXT)
-PHP_MODNAME?= ${PORTNAME}
-PHP_HEADER_DIRS?= ""
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
- @${INSTALL_DATA} ${WRKSRC}/modules/${PHP_MODNAME}.so \
- ${PREFIX}/lib/php/${PHP_EXT_DIR}
-. for header in . ${PHP_HEADER_DIRS}
- @${MKDIR} ${PREFIX}/include/php/ext/${PHP_MODNAME}/${header}
- @${INSTALL_DATA} ${WRKSRC}/${header}/*.h \
- ${PREFIX}/include/php/ext/${PHP_MODNAME}/${header}
-. endfor
- @${GREP} "#define \(COMPILE\|HAVE\|USE\)_" ${WRKSRC}/config.h \
- > ${PREFIX}/include/php/ext/${PHP_MODNAME}/config.h
- @${ECHO_CMD} \#include \"ext/${PHP_MODNAME}/config.h\" \
- >> ${PREFIX}/include/php/ext/php_config.h
- @${MKDIR} ${PREFIX}/etc/php
- @${ECHO_CMD} extension=${PHP_MODNAME}.so \
- >> ${PREFIX}/etc/php/extensions.ini
-
-add-plist-info: add-plist-phpext
-add-plist-phpext:
- @${ECHO_CMD} "lib/php/${PHP_EXT_DIR}/${PHP_MODNAME}.so" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/lib/php/${PHP_EXT_DIR} 2> /dev/null || true" \
- >> ${TMPPLIST}
- @${FIND} -P ${PREFIX}/include/php/ext/${PHP_MODNAME} ! -type d 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${PREFIX}/include/php/ext/${PHP_MODNAME} -type d 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
- @${ECHO_CMD} "@exec echo \#include \\\"ext/${PHP_MODNAME}/config.h\\\" >> %D/include/php/ext/php_config.h" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec cp %D/include/php/ext/php_config.h %D/include/php/ext/php_config.h.orig" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec grep -v ext/${PHP_MODNAME}/config.h %D/include/php/ext/php_config.h.orig > %D/include/php/ext/php_config.h || true" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rm %D/include/php/ext/php_config.h.orig" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@exec mkdir -p %D/etc/php" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@exec echo extension=${PHP_MODNAME}.so >> %D/etc/php/extensions.ini" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec cp %D/etc/php/extensions.ini %D/etc/php/extensions.ini.orig" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec grep -v extension=${PHP_MODNAME}\\\.so %D/etc/php/extensions.ini.orig > %D/etc/php/extensions.ini || true" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rm %D/etc/php/extensions.ini.orig" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec [ -s %D/etc/php/extensions.ini ] || rm %D/etc/php/extensions.ini" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/etc/php 2> /dev/null || true" \
- >> ${TMPPLIST}
-
-security-check: php-ini
-
-php-ini:
- @${ECHO_CMD} "****************************************************************************"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "The following line has been added to your ${PREFIX}/etc/php/extensions.ini"
- @${ECHO_CMD} "configuration file to automatically load the installed extension:"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "extension=${PHP_MODNAME}.so"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "****************************************************************************"
-.endif
-
-# Extensions
-.if ${USE_PHP:L} != "yes"
-# non-version specific components
-_USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
- exif fileinfo filepro fribidi ftp gd gettext gmp \
- hash iconv imagick imap interbase ldap mbstring mcrypt \
- mhash ming mssql mysql ncurses odbc \
- openssl panda pcntl pcre pdf pgsql posix \
- pspell radius readline recode session shmop snmp \
- sockets sybase_ct sysvmsg sysvsem sysvshm \
- tokenizer wddx xml xmlrpc yaz zip zlib
-# version specific components
-_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbx dio domxml mcal mcve \
- mnogosearch oracle overload pfpro xslt yp
-_USE_PHP_VER5= ${_USE_PHP_ALL} dom mysqli pdo simplexml soap sqlite \
- tidy xmlreader xmlwriter xsl
-
-bcmath_DEPENDS= math/php${PHP_VER}-bcmath
-bz2_DEPENDS= archivers/php${PHP_VER}-bz2
-calendar_DEPENDS= misc/php${PHP_VER}-calendar
-crack_DEPENDS= security/php${PHP_VER}-crack
-ctype_DEPENDS= textproc/php${PHP_VER}-ctype
-curl_DEPENDS= ftp/php${PHP_VER}-curl
-dba_DEPENDS= databases/php${PHP_VER}-dba
-dbase_DEPENDS= databases/php${PHP_VER}-dbase
-dbx_DEPENDS= databases/php${PHP_VER}-dbx
-dio_DEPENDS= devel/php${PHP_VER}-dio
-dom_DEPENDS= textproc/php${PHP_VER}-dom
-domxml_DEPENDS= textproc/php${PHP_VER}-domxml
-exif_DEPENDS= graphics/php${PHP_VER}-exif
-fileinfo_DEPENDS= sysutils/pecl-fileinfo
-filepro_DEPENDS=databases/php${PHP_VER}-filepro
-fribidi_DEPENDS=converters/pecl-fribidi
-ftp_DEPENDS= ftp/php${PHP_VER}-ftp
-gd_DEPENDS= graphics/php${PHP_VER}-gd
-gettext_DEPENDS=devel/php${PHP_VER}-gettext
-gmp_DEPENDS= math/php${PHP_VER}-gmp
-hash_DEPENDS= security/pecl-hash
-iconv_DEPENDS= converters/php${PHP_VER}-iconv
-imagick_DEPENDS=graphics/pecl-imagick
-imap_DEPENDS= mail/php${PHP_VER}-imap
-interbase_DEPENDS= databases/php${PHP_VER}-interbase
-ldap_DEPENDS= net/php${PHP_VER}-ldap
-mbstring_DEPENDS= converters/php${PHP_VER}-mbstring
-mcal_DEPENDS= misc/php${PHP_VER}-mcal
-mcrypt_DEPENDS= security/php${PHP_VER}-mcrypt
-mcve_DEPENDS= devel/php${PHP_VER}-mcve
-mhash_DEPENDS= security/php${PHP_VER}-mhash
-ming_DEPENDS= graphics/php${PHP_VER}-ming
-mnogosearch_DEPENDS= www/php${PHP_VER}-mnogosearch
-mssql_DEPENDS= databases/php${PHP_VER}-mssql
-mysql_DEPENDS= databases/php${PHP_VER}-mysql
-mysqli_DEPENDS= databases/php${PHP_VER}-mysqli
-ncurses_DEPENDS=devel/php${PHP_VER}-ncurses
-odbc_DEPENDS= databases/php${PHP_VER}-odbc
-openssl_DEPENDS=security/php${PHP_VER}-openssl
-oracle_DEPENDS= databases/php${PHP_VER}-oracle
-overload_DEPENDS=lang/php${PHP_VER}-overload
-panda_DEPENDS= print/pecl-panda
-pcntl_DEPENDS= devel/php${PHP_VER}-pcntl
-pcre_DEPENDS= devel/php${PHP_VER}-pcre
-pdf_DEPENDS= print/pecl-pdflib
-pdo_DEPENDS= databases/pecl-PDO
-pfpro_DEPENDS= finance/php${PHP_VER}-pfpro
-pgsql_DEPENDS= databases/php${PHP_VER}-pgsql
-posix_DEPENDS= sysutils/php${PHP_VER}-posix
-pspell_DEPENDS= textproc/php${PHP_VER}-pspell
-radius_DEPENDS= net/pecl-radius
-readline_DEPENDS= devel/php${PHP_VER}-readline
-recode_DEPENDS= converters/php${PHP_VER}-recode
-session_DEPENDS=www/php${PHP_VER}-session
-shmop_DEPENDS= devel/php${PHP_VER}-shmop
-simplexml_DEPENDS= textproc/php${PHP_VER}-simplexml
-snmp_DEPENDS= net-mgmt/php${PHP_VER}-snmp
-soap_DEPENDS= net/php${PHP_VER}-soap
-sockets_DEPENDS=net/php${PHP_VER}-sockets
-sqlite_DEPENDS= databases/php${PHP_VER}-sqlite
-sybase_ct_DEPENDS= databases/php${PHP_VER}-sybase_ct
-sysvmsg_DEPENDS=devel/php${PHP_VER}-sysvmsg
-sysvsem_DEPENDS=devel/php${PHP_VER}-sysvsem
-sysvshm_DEPENDS=devel/php${PHP_VER}-sysvshm
-tidy_DEPENDS= www/php${PHP_VER}-tidy
-tokenizer_DEPENDS= devel/php${PHP_VER}-tokenizer
-wddx_DEPENDS= textproc/php${PHP_VER}-wddx
-xml_DEPENDS= textproc/php${PHP_VER}-xml
-xmlreader_DEPENDS= textproc/php${PHP_VER}-xmlreader
-xmlrpc_DEPENDS= net/php${PHP_VER}-xmlrpc
-xmlwriter_DEPENDS= textproc/php${PHP_VER}-xmlwriter
-xsl_DEPENDS= textproc/php${PHP_VER}-xsl
-xslt_DEPENDS= textproc/php${PHP_VER}-xslt
-yaz_DEPENDS= net/pecl-yaz
-yp_DEPENDS= net/php${PHP_VER}-yp
-zip_DEPENDS= archivers/pecl-zip
-zlib_DEPENDS= archivers/php${PHP_VER}-zlib
-
-. for extension in ${USE_PHP}
-. if ${_USE_PHP_VER${PHP_VER}:M${extension}} != ""
-. if ${PHP_EXT_INC:M${extension}} == ""
-. if defined(USE_PHP_BUILD)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/${extension}.so:${PORTSDIR}/${${extension}_DEPENDS}
-. endif
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/${extension}.so:${PORTSDIR}/${${extension}_DEPENDS}
-. endif
-. else
-isyes= ${extension}
-. if ${isyes:L} != "yes"
-check-makevars::
- @${ECHO_CMD} "Unknown extension ${extension} for PHP ${PHP_VER}."
- @${FALSE}
-. endif
-. endif
-. endfor
-.endif