aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-03-31 15:11:48 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-03-31 15:11:48 +0000
commita8952f1eea1274e7e3f626f3345fb206df349385 (patch)
treeb76e55bc4537cedf326a6876dee495ff5d0ce043 /ports-mgmt
parent0af93cfec86ff42adb23e74bae4f45a491d268f1 (diff)
downloadports-a8952f1eea1274e7e3f626f3345fb206df349385.tar.gz
ports-a8952f1eea1274e7e3f626f3345fb206df349385.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/pkg_install-devel/Makefile109
-rw-r--r--ports-mgmt/pkg_install-devel/distinfo3
-rw-r--r--ports-mgmt/pkg_install-devel/files/Makefile.inc4
-rw-r--r--ports-mgmt/pkg_install-devel/pkg-deinstall28
-rw-r--r--ports-mgmt/pkg_install-devel/pkg-descr17
-rw-r--r--ports-mgmt/pkg_install-devel/pkg-install46
-rw-r--r--ports-mgmt/pkg_install-devel/pkg-plist7
-rw-r--r--ports-mgmt/pkg_install-devel/pkg-req21
9 files changed, 0 insertions, 236 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 83ca12541d1a..3b96299a9b9f 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -21,7 +21,6 @@
SUBDIR += pkg_cleanup
SUBDIR += pkg_cutleaves
SUBDIR += pkg_install
- SUBDIR += pkg_install-devel
SUBDIR += pkg_remove
SUBDIR += pkg_replace
SUBDIR += pkg_rmleaves
diff --git a/ports-mgmt/pkg_install-devel/Makefile b/ports-mgmt/pkg_install-devel/Makefile
deleted file mode 100644
index 804f3aac5afb..000000000000
--- a/ports-mgmt/pkg_install-devel/Makefile
+++ /dev/null
@@ -1,109 +0,0 @@
-# New ports collection makefile for: pkg_install
-# Date created: 25 Jan 2004
-# Whom: Oliver Eikemeier
-#
-# $FreeBSD$
-#
-
-PORTNAME= pkg_install
-PORTVERSION= 20040811
-CATEGORIES= ports-mgmt
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= eik
-PKGNAMESUFFIX= -devel
-
-MAINTAINER= clement@FreeBSD.org
-COMMENT= Development version of the FreeBSD 5.x package tools
-
-CONFLICTS= pkg_install-[0-9]*
-
-MANCOMPRESSED= yes
-
-MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 \
- pkg_info.1 pkg_version.1
-
-PKGREQ= ${WRKDIR}/pkg-req
-
-.if defined(PREFIX)
-.if ${PREFIX} == "/usr"
-PKGNAMESUFFIX= -base-devel
-.endif
-.endif
-
-BACKUPDIR?= /var/backups
-
-.if !defined(NOCRYPT) && !defined(NO_OPENSSL)
-USE_OPENSSL= yes
-MAN1+= pkg_check.1 pkg_sign.1
-PLIST_SUB+= OPENSSL=""
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
-.else
-MAKE_ARGS= -DNO_OPENSSL
-PLIST_SUB+= OPENSSL="@comment "
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if defined(DFOSVERSION)
-PKG_OSVERSION= ${DFOSVERSION}
-SED_SCRIPT= -e 's/%%OSVERSIONCHK%%/"$$OSVERSION" -ge 110000/g'
-.else
-PKG_OSVERSION= ${OSVERSION}
-SED_SCRIPT= -e 's/%%OSVERSIONCHK%%/"$$OSVERSION" -ge 491101 -a "$$OSVERSION" -lt 500000 -o "$$OSVERSION" -ge 502120/g'
-.endif
-
-pre-everything::
- @${ECHO} "======================================================================================="
- @${ECHO}
- @${ECHO} "Build ${PKGNAME} with PREFIX=/usr to replace the base package tools"
- @${ECHO}
- @${ECHO} "======================================================================================="
-
-.if !defined(DFOSVERSION) && ${OSVERSION} < 460102
-check-already-installed:
-.if !defined(NO_PKG_REGISTER) && !defined(FORCE_PKG_REGISTER)
- @if [ -d ${PKG_DBDIR}/${PKGNAME} ]; then \
- ${ECHO_CMD} "===> ${PKGNAME} is already installed - perhaps an older version?"; \
- ${ECHO_CMD} " If so, you may wish to \`\`make deinstall'' and install"; \
- ${ECHO_CMD} " this port again by \`\`make reinstall'' to upgrade it properly."; \
- ${ECHO_CMD} " If you really wish to overwrite the old port of ${PKGNAME}"; \
- ${ECHO_CMD} " without deleting it first, set the variable \"FORCE_PKG_REGISTER\""; \
- ${ECHO_CMD} " in your environment or the \"make install\" command line."; \
- exit 1; \
- fi
-.else
- @${DO_NADA}
-.endif
-.endif
-
-pre-configure:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
- -e 's|%%MANPREFIX%%|${MANPREFIX}|g' \
- ${FILESDIR}/Makefile.inc > ${WRKDIR}/Makefile.inc
-
-# __FBSDID is undefied for old FreeBSD versions and DragonFlyBSD
-.if defined(DFOSVERSION) || ${OSVERSION} < 440001 || ${OSVERSION} >= 500000 && ${OSVERSION} < 500024
-post-patch:
- @${FIND} ${WRKSRC} -name '*.c' \
- | ${XARGS} ${PERL} -pi.orig -e 's/__FBSDID\(("[^"]*")\)/static const char rcsid[] = $$1/'
-.endif
-
-post-build:
- @${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-req >${WRKDIR}/pkg-req
-
-.if !defined(PACKAGE_BUILDING)
-pre-install:
- @${SETENV} PKG_PREFIX=${PREFIX:Q} OSVERSION=${PKG_OSVERSION:Q} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
-.endif
-
-# Call pkg-install in `do-install:' instead of `pre-install:' because it might
-# deinstall pkg_info, which is fatal during `check-already-installed:'.
-do-install:
- ${SETENV} PKG_PREFIX=${PREFIX:Q} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-
-test: build
- @(cd ${BUILD_WRKSRC}/version && ${SH} test-pkg_version.sh)
-
-.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg_install-devel/distinfo b/ports-mgmt/pkg_install-devel/distinfo
deleted file mode 100644
index bb4af1ce463d..000000000000
--- a/ports-mgmt/pkg_install-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (pkg_install-20040811.tar.gz) = d95f6a6a11cfba51cd4ea451f444ae47
-SHA256 (pkg_install-20040811.tar.gz) = c7c0f67e52c2758272a4e81d8dcb4ac1eaaf314bac677cf8f1026b22baad7367
-SIZE (pkg_install-20040811.tar.gz) = 88003
diff --git a/ports-mgmt/pkg_install-devel/files/Makefile.inc b/ports-mgmt/pkg_install-devel/files/Makefile.inc
deleted file mode 100644
index 3f26acacff36..000000000000
--- a/ports-mgmt/pkg_install-devel/files/Makefile.inc
+++ /dev/null
@@ -1,4 +0,0 @@
-# $FreeBSD$
-
-BINDIR=%%PREFIX%%/sbin
-MANDIR=%%MANPREFIX%%/man/man
diff --git a/ports-mgmt/pkg_install-devel/pkg-deinstall b/ports-mgmt/pkg_install-devel/pkg-deinstall
deleted file mode 100644
index 32c71c3ad15f..000000000000
--- a/ports-mgmt/pkg_install-devel/pkg-deinstall
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PAX=/bin/pax
-ECHO_CMD=echo
-RM=/bin/rm
-BACKUPDIR=/var/backups
-
-PREFIX=${PKG_PREFIX:-/usr/local}
-if [ "${PREFIX}" = "/usr" ]; then
- MANPREFIX="${TARGETDIR}/share"
-else
- MANPREFIX="${TARGETDIR}"
-fi
-
-case $2 in
-POST-DEINSTALL)
- if [ "${PREFIX}" = "/usr" ]; then
- if [ -e "${BACKUPDIR}/pkg_install.tgz" ]; then
- ${PAX} -r -pe -z -f "${BACKUPDIR}/pkg_install.tgz"
- ${RM} "${BACKUPDIR}/pkg_install.tgz"
- ${ECHO_CMD} "===> Base pkg_install restored."
- fi
- fi
- ;;
-esac
diff --git a/ports-mgmt/pkg_install-devel/pkg-descr b/ports-mgmt/pkg_install-devel/pkg-descr
deleted file mode 100644
index abe2ae1d30b3..000000000000
--- a/ports-mgmt/pkg_install-devel/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-Development version of the FreeBSD 5.x pkg_install suite of tools
-
-This version fixes some bugs of the -CURRENT tools. You should
-only install it it you have problems with the current version
-or want to test the new features.
-
-If you want to replace the base system tools, install via:
- make install PREFIX=/usr
-You can revert to the normal tools simply by uninstalling the
-port or restoring them with:
- cd /usr/src/usr.sbin/pkg_install; make install
-if you have the sources installed.
-
-WWW: http://cvs.sf.net/viewcvs.py/portaudit/pkg_install/
-
--- Oliver Eikemeier
-eik@FreeBSD.org
diff --git a/ports-mgmt/pkg_install-devel/pkg-install b/ports-mgmt/pkg_install-devel/pkg-install
deleted file mode 100644
index f29172829e88..000000000000
--- a/ports-mgmt/pkg_install-devel/pkg-install
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PAX=/bin/pax
-ECHO_CMD=echo
-MKDIR="/bin/mkdir -p"
-RM=/bin/rm
-BACKUPDIR=/var/backups
-
-TOOLS="add check create delete info sign update version"
-
-PREFIX=${PKG_PREFIX:-/usr/local}
-if [ "${PREFIX}" = "/usr" ]; then
- MANPREFIX="${TARGETDIR}/share"
-else
- MANPREFIX="${TARGETDIR}"
-fi
-
-case $2 in
-PRE-INSTALL)
- if [ "${PREFIX}" = "/usr" ]; then
- if [ -e "${BACKUPDIR}/pkg_install.tgz" ]; then
- ${ECHO_CMD} "===> Please remove \`\`${BACKUPDIR}/pkg_install.tgz'' manually."
- exit 1
- fi
- if [ "${PREFIX}" = "/usr" ]; then
- files=""
- for tool in ${TOOLS}; do
- if [ -e "${PREFIX}/sbin/pkg_${tool}" ]; then
- files="${files} ${PREFIX}/sbin/pkg_${tool}"
- fi
- if [ -e "${MANPREFIX}/man/man1/pkg_${tool}.1.gz" ]; then
- files="${files} ${MANPREFIX}/man/man1/pkg_${tool}.1.gz"
- ${RM} -f "${MANPREFIX}/man/cat1/pkg_${tool}.1.gz"
- fi
- done
- ${MKDIR} ${BACKUPDIR}
- ${PAX} -w -z -f "${BACKUPDIR}/pkg_install.tgz" ${files}
- ${RM} -f ${files}
- ${ECHO_CMD} "===> Base pkg_install saved."
- fi
- fi
- ;;
-esac
diff --git a/ports-mgmt/pkg_install-devel/pkg-plist b/ports-mgmt/pkg_install-devel/pkg-plist
deleted file mode 100644
index 565e68ca0ecf..000000000000
--- a/ports-mgmt/pkg_install-devel/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-sbin/pkg_add
-%%OPENSSL%%sbin/pkg_check
-sbin/pkg_create
-sbin/pkg_delete
-sbin/pkg_info
-%%OPENSSL%%sbin/pkg_sign
-sbin/pkg_version
diff --git a/ports-mgmt/pkg_install-devel/pkg-req b/ports-mgmt/pkg_install-devel/pkg-req
deleted file mode 100644
index caf4ed361cf9..000000000000
--- a/ports-mgmt/pkg_install-devel/pkg-req
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-if [ -z "$OSVERSION" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
-fi
-
-case $2 in
-INSTALL)
- if [ %%OSVERSIONCHK%% ]; then
- echo "$1: Your base pkg_install tools are already up-to-date."
- exit 1
- fi
- ;;
-esac