aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-05 01:08:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-05 01:08:46 +0000
commit0d0d56457bb54d930410a5b55092e1624f3012e5 (patch)
tree6dc64f85ffb41f8710ebfdf60aa600dd824c2b2a /ports-mgmt
parent91cd12aa0e86e4c646fc2cbb9aa97320aac54680 (diff)
downloadports-0d0d56457bb54d930410a5b55092e1624f3012e5.tar.gz
ports-0d0d56457bb54d930410a5b55092e1624f3012e5.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile50
-rw-r--r--ports-mgmt/barry/Makefile6
-rw-r--r--ports-mgmt/bpm/Makefile4
-rw-r--r--ports-mgmt/instant-tinderbox/Makefile2
-rw-r--r--ports-mgmt/jailaudit/Makefile4
-rw-r--r--ports-mgmt/kports-qt4/Makefile6
-rw-r--r--ports-mgmt/kports/Makefile6
-rw-r--r--ports-mgmt/managepkg/Makefile2
-rw-r--r--ports-mgmt/newportsversioncheck/Makefile2
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile2
-rw-r--r--ports-mgmt/p5-FreeBSD-Ports/Makefile2
-rw-r--r--ports-mgmt/pib/Makefile2
-rw-r--r--ports-mgmt/pkg-orphan/Makefile2
-rw-r--r--ports-mgmt/pkg_cutleaves/Makefile2
-rw-r--r--ports-mgmt/pkg_install-devel/Makefile2
-rw-r--r--ports-mgmt/pkg_install/Makefile2
-rw-r--r--ports-mgmt/pkg_remove/Makefile2
-rw-r--r--ports-mgmt/pkg_rmleaves/Makefile2
-rw-r--r--ports-mgmt/pkg_trackinst/Makefile2
-rw-r--r--ports-mgmt/pkg_tree/Makefile2
-rw-r--r--ports-mgmt/pkgfe/Makefile8
-rw-r--r--ports-mgmt/port-authoring-tools/Makefile4
-rw-r--r--ports-mgmt/port-maintenance-tools/Makefile12
-rw-r--r--ports-mgmt/portaudit-db/Makefile2
-rw-r--r--ports-mgmt/portaudit/Makefile6
-rw-r--r--ports-mgmt/portbrowser/Makefile2
-rw-r--r--ports-mgmt/portcheck/Makefile4
-rw-r--r--ports-mgmt/portcheckout/Makefile2
-rw-r--r--ports-mgmt/portconf/Makefile2
-rw-r--r--ports-mgmt/portdowngrade/Makefile2
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/portell/Makefile2
-rw-r--r--ports-mgmt/portless/Makefile2
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portmanager/Makefile2
-rw-r--r--ports-mgmt/portmaster/Makefile2
-rw-r--r--ports-mgmt/portmk/Makefile2
-rw-r--r--ports-mgmt/portscout/Makefile2
-rw-r--r--ports-mgmt/portsearch/Makefile2
-rw-r--r--ports-mgmt/portsman/Makefile2
-rw-r--r--ports-mgmt/portsnap/Makefile2
-rw-r--r--ports-mgmt/portsopt/Makefile2
-rw-r--r--ports-mgmt/porttools/Makefile4
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile2
-rw-r--r--ports-mgmt/portupgrade/Makefile2
-rw-r--r--ports-mgmt/psearch/Makefile2
-rw-r--r--ports-mgmt/qtpkg/Makefile2
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile2
-rw-r--r--ports-mgmt/tinderbox/Makefile2
-rw-r--r--ports-mgmt/vulnerability-test-port/Makefile2
50 files changed, 119 insertions, 71 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 5970e3555c76..84e2b3e7c5ca 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -1,6 +1,54 @@
# $FreeBSD$
#
- COMMENT = Ports for managing, installing and developing FreeBSD ports and packages
+ COMMENT = Ports for managing, installing and developing FreeBSD ports and packages
+
+ SUBDIR += barry
+ SUBDIR += bpm
+ SUBDIR += instant-tinderbox
+ SUBDIR += jailaudit
+ SUBDIR += kports
+ SUBDIR += managepkg
+ SUBDIR += newportsversioncheck
+ SUBDIR += p5-FreeBSD-Portindex
+ SUBDIR += p5-FreeBSD-Ports
+ SUBDIR += pib
+ SUBDIR += pkg-orphan
+ SUBDIR += pkg_cutleaves
+ SUBDIR += pkg_install
+ SUBDIR += pkg_install-devel
+ SUBDIR += pkg_remove
+ SUBDIR += pkg_rmleaves
+ SUBDIR += pkg_trackinst
+ SUBDIR += pkg_tree
+ SUBDIR += pkgfe
+ SUBDIR += port-authoring-tools
+ SUBDIR += port-maintenance-tools
+ SUBDIR += portaudit
+ SUBDIR += portaudit-db
+ SUBDIR += portbrowser
+ SUBDIR += portcheck
+ SUBDIR += portcheckout
+ SUBDIR += portconf
+ SUBDIR += portdowngrade
+ SUBDIR += porteasy
+ SUBDIR += portell
+ SUBDIR += portless
+ SUBDIR += portlint
+ SUBDIR += portmanager
+ SUBDIR += portmaster
+ SUBDIR += portmk
+ SUBDIR += portscout
+ SUBDIR += portsearch
+ SUBDIR += portsman
+ SUBDIR += portsnap
+ SUBDIR += portsopt
+ SUBDIR += porttools
+ SUBDIR += portupgrade
+ SUBDIR += portupgrade-devel
+ SUBDIR += psearch
+ SUBDIR += qtpkg
+ SUBDIR += tinderbox
+ SUBDIR += vulnerability-test-port
.include <bsd.port.subdir.mk>
diff --git a/ports-mgmt/barry/Makefile b/ports-mgmt/barry/Makefile
index 0bb507024a8f..359709b90f36 100644
--- a/ports-mgmt/barry/Makefile
+++ b/ports-mgmt/barry/Makefile
@@ -8,15 +8,15 @@
PORTNAME= barry
PORTVERSION= 0.7
PORTREVISION= 2
-CATEGORIES= sysutils kde
+CATEGORIES= ports-mgmt kde
MASTER_SITES= http://www.student.uni-oldenburg.de/frerich.raabe/barry/ \
http://freebsd.so14k.com/barry/
MAINTAINER= ports@FreeBSD.org
COMMENT= A nice KDE frontend to the ports system
-BUILD_DEPENDS= ${LOCALBASE}/sbin/portsdb:${PORTSDIR}/sysutils/portupgrade
-RUN_DEPENDS= ${LOCALBASE}/sbin/portsdb:${PORTSDIR}/sysutils/portupgrade
+BUILD_DEPENDS= ${LOCALBASE}/sbin/portsdb:${PORTSDIR}/ports-mgmt/portupgrade
+RUN_DEPENDS= ${LOCALBASE}/sbin/portsdb:${PORTSDIR}/ports-mgmt/portupgrade
USE_BZIP2= yes
USE_KDELIBS_VER=3
diff --git a/ports-mgmt/bpm/Makefile b/ports-mgmt/bpm/Makefile
index 812315f8a08e..0ff21bbd1638 100644
--- a/ports-mgmt/bpm/Makefile
+++ b/ports-mgmt/bpm/Makefile
@@ -8,14 +8,14 @@
PORTNAME= bpm
PORTVERSION= 0.4.1b
PORTREVISION= 10
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.meowfishies.com/code/bpm/
EXTRACT_SUFX= .tgz
MAINTAINER= sethk@meowfishies.com
COMMENT= A graphical BSD ports collection manager
-RUN_DEPENDS= portupgrade:${PORTSDIR}/sysutils/portupgrade \
+RUN_DEPENDS= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
gdialog:${PORTSDIR}/x11/zenity
USE_X_PREFIX= yes
diff --git a/ports-mgmt/instant-tinderbox/Makefile b/ports-mgmt/instant-tinderbox/Makefile
index f1928acd0c57..03a317c02db9 100644
--- a/ports-mgmt/instant-tinderbox/Makefile
+++ b/ports-mgmt/instant-tinderbox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= instant-tinderbox
PORTVERSION= 1.0
PORTREVISION= 2
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
DISTFILES=
MAINTAINER= edwin@mavetju.org
diff --git a/ports-mgmt/jailaudit/Makefile b/ports-mgmt/jailaudit/Makefile
index bc9738dc4a98..1081a43d61c4 100644
--- a/ports-mgmt/jailaudit/Makefile
+++ b/ports-mgmt/jailaudit/Makefile
@@ -7,13 +7,13 @@
PORTNAME= jailaudit
PORTVERSION= 1.2
-CATEGORIES= security
+CATEGORIES= ports-mgmt
MASTER_SITES= http://outpost.h3q.com/software/jailaudit/
MAINTAINER= cryx-ports@h3q.com
COMMENT= Script to generate portaudit reports for jails
-RUN_DEPENDS= ${LOCALBASE}/sbin/portaudit:${PORTSDIR}/security/portaudit
+RUN_DEPENDS= ${LOCALBASE}/sbin/portaudit:${PORTSDIR}/ports-mgmt/portaudit
USE_BZIP2= yes
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index 389fd0f6aaee..cbe981c26528 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kports
PORTVERSION= 0.6.1
-CATEGORIES= sysutils kde
+CATEGORIES= ports-mgmt kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,7 @@ USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
PREFIX= ${KDE_PREFIX}
-RUN_DEPENDS+= portupgrade:${PORTSDIR}/sysutils/portupgrade
+RUN_DEPENDS+= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
OPTIONS= PORTAUDIT "Require Portaudit" on
@@ -32,7 +32,7 @@ IGNORE= doesn't compile properly on 4.x systems
.endif
.if !defined(WITHOUT_PORTAUDIT)
-RUN_DEPENDS+= portaudit:${PORTSDIR}/security/portaudit
+RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/kports/Makefile b/ports-mgmt/kports/Makefile
index 389fd0f6aaee..cbe981c26528 100644
--- a/ports-mgmt/kports/Makefile
+++ b/ports-mgmt/kports/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kports
PORTVERSION= 0.6.1
-CATEGORIES= sysutils kde
+CATEGORIES= ports-mgmt kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,7 @@ USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
PREFIX= ${KDE_PREFIX}
-RUN_DEPENDS+= portupgrade:${PORTSDIR}/sysutils/portupgrade
+RUN_DEPENDS+= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
OPTIONS= PORTAUDIT "Require Portaudit" on
@@ -32,7 +32,7 @@ IGNORE= doesn't compile properly on 4.x systems
.endif
.if !defined(WITHOUT_PORTAUDIT)
-RUN_DEPENDS+= portaudit:${PORTSDIR}/security/portaudit
+RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/managepkg/Makefile b/ports-mgmt/managepkg/Makefile
index a9ad75191fe4..eb393312c329 100644
--- a/ports-mgmt/managepkg/Makefile
+++ b/ports-mgmt/managepkg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= managepkg
PORTVERSION= 1.1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.cul.de/data/\
http://home.arcor.de/fehlner/fbsd_ports/\
http://home.arcor.de/teambushido/fbsd_ports/
diff --git a/ports-mgmt/newportsversioncheck/Makefile b/ports-mgmt/newportsversioncheck/Makefile
index 359881bafd3e..49fe1c6a0cc7 100644
--- a/ports-mgmt/newportsversioncheck/Makefile
+++ b/ports-mgmt/newportsversioncheck/Makefile
@@ -8,7 +8,7 @@
PORTNAME= newportsversioncheck
PORTVERSION= 1.3
PORTREVISION= 1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index b526813222ae..c89d8e638151 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -6,7 +6,7 @@
PORTNAME= FreeBSD-Portindex
PORTVERSION= 1.9
-CATEGORIES= sysutils perl5
+CATEGORIES= ports-mgmt perl5
MASTER_SITES= http://www.infracaninophile.co.uk/portindex/
PKGNAMEPREFIX= p5-
diff --git a/ports-mgmt/p5-FreeBSD-Ports/Makefile b/ports-mgmt/p5-FreeBSD-Ports/Makefile
index 913d0a555360..53ad4c883f1c 100644
--- a/ports-mgmt/p5-FreeBSD-Ports/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Ports/Makefile
@@ -7,7 +7,7 @@
PORTNAME= FreeBSD-Ports
PORTVERSION= 0.04
-CATEGORIES= textproc perl5
+CATEGORIES= ports-mgmt perl5
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= tom
PKGNAMEPREFIX= p5-
diff --git a/ports-mgmt/pib/Makefile b/ports-mgmt/pib/Makefile
index 970acd68edd6..74f9d8e54793 100644
--- a/ports-mgmt/pib/Makefile
+++ b/ports-mgmt/pib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pib
PORTVERSION= 1.2
-CATEGORIES= sysutils tk82
+CATEGORIES= ports-mgmt tk82
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= msmith
diff --git a/ports-mgmt/pkg-orphan/Makefile b/ports-mgmt/pkg-orphan/Makefile
index 81f8e6a08146..e1ba3c45de3b 100644
--- a/ports-mgmt/pkg-orphan/Makefile
+++ b/ports-mgmt/pkg-orphan/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg-orphan
PORTVERSION= 0.1.1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
diff --git a/ports-mgmt/pkg_cutleaves/Makefile b/ports-mgmt/pkg_cutleaves/Makefile
index e14a3377cc1a..1ae29e945ce4 100644
--- a/ports-mgmt/pkg_cutleaves/Makefile
+++ b/ports-mgmt/pkg_cutleaves/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_cutleaves
PORTVERSION= 20061113
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.gegenunendlich.de/projects/${PORTNAME}/
MAINTAINER= stefan@FreeBSD.org
diff --git a/ports-mgmt/pkg_install-devel/Makefile b/ports-mgmt/pkg_install-devel/Makefile
index 6e7d688b42c0..804f3aac5afb 100644
--- a/ports-mgmt/pkg_install-devel/Makefile
+++ b/ports-mgmt/pkg_install-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_install
PORTVERSION= 20040811
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= eik
PKGNAMESUFFIX= -devel
diff --git a/ports-mgmt/pkg_install/Makefile b/ports-mgmt/pkg_install/Makefile
index 069bdd76c2cf..ec3a1970a35d 100644
--- a/ports-mgmt/pkg_install/Makefile
+++ b/ports-mgmt/pkg_install/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_install
PORTVERSION= 20060113
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.FreeBSD.org/~marcus/
MASTER_SITE_SUBDIR= marcus
diff --git a/ports-mgmt/pkg_remove/Makefile b/ports-mgmt/pkg_remove/Makefile
index 944303a7ba87..f36487594de1 100644
--- a/ports-mgmt/pkg_remove/Makefile
+++ b/ports-mgmt/pkg_remove/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_remove
PORTVERSION= 1.1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/pkg_rmleaves/Makefile b/ports-mgmt/pkg_rmleaves/Makefile
index 3780d2d46bf1..26d1d120d431 100644
--- a/ports-mgmt/pkg_rmleaves/Makefile
+++ b/ports-mgmt/pkg_rmleaves/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_rmleaves
PORTVERSION= 20050922
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://utenti.gufi.org/~drizzt/codes/ports/${PORTNAME}/
MAINTAINER= drizzt@gufi.org
diff --git a/ports-mgmt/pkg_trackinst/Makefile b/ports-mgmt/pkg_trackinst/Makefile
index 1d483e7e4124..f71752d4e026 100644
--- a/ports-mgmt/pkg_trackinst/Makefile
+++ b/ports-mgmt/pkg_trackinst/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pkg_trackinst
PORTVERSION= 1.2.3
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://people.freebsd.org/~perky/distfiles/
MAINTAINER= perky@FreeBSD.org
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index 87841c41d6a3..d3199fc41b26 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pkg_tree
PORTVERSION= 1.1
PORTREVISION= 1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
diff --git a/ports-mgmt/pkgfe/Makefile b/ports-mgmt/pkgfe/Makefile
index 5d9bf2ddf27a..a2244c9ba5a4 100644
--- a/ports-mgmt/pkgfe/Makefile
+++ b/ports-mgmt/pkgfe/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkgfe
PORTVERSION= 20061204
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://helpfreebsd.net/pkgfe/releases/ \
http://kodu.neti.ee/~madis555/pkgfe/releases/ \
http://ketas.life.ee/pkgfe/releases/ \
@@ -17,15 +17,15 @@ MASTER_SITES= http://helpfreebsd.net/pkgfe/releases/ \
MAINTAINER= madis555@hot.ee
COMMENT= Ncurses frontend for ports collection
-RUN_DEPENDS= portupgrade:${PORTSDIR}/sysutils/portupgrade \
- portaudit:${PORTSDIR}/security/portaudit
+RUN_DEPENDS= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
+ portaudit:${PORTSDIR}/ports-mgmt/portaudit
MAN8= pkgfe.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 600033 && ( ${OSVERSION} < 504103 || ${OSVERSION} > 600000 )
-RUN_DEPENDS+= portsnap:${PORTSDIR}/sysutils/portsnap
+RUN_DEPENDS+= portsnap:${PORTSDIR}/ports-mgmt/portsnap
.endif
NO_BUILD= yes
diff --git a/ports-mgmt/port-authoring-tools/Makefile b/ports-mgmt/port-authoring-tools/Makefile
index ec3939be0205..548834ad7e7c 100644
--- a/ports-mgmt/port-authoring-tools/Makefile
+++ b/ports-mgmt/port-authoring-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= port-authoring-tools
PORTVERSION= 1.0
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
@@ -20,7 +20,7 @@ RUN_DEPENDS= \
${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
${LOCALBASE}/sbin/libchk:${PORTSDIR}/sysutils/libchk \
- ${LOCALBASE}/bin/port:${PORTSDIR}/devel/porttools
+ ${LOCALBASE}/bin/port:${PORTSDIR}/ports-mgmt/porttools
NO_BUILD= yes
diff --git a/ports-mgmt/port-maintenance-tools/Makefile b/ports-mgmt/port-maintenance-tools/Makefile
index 4e1b575c9870..696e7c1eae1c 100644
--- a/ports-mgmt/port-maintenance-tools/Makefile
+++ b/ports-mgmt/port-maintenance-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= port-maintenance-tools
PORTVERSION= 1.0
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
@@ -19,11 +19,11 @@ COMMENT= "meta-port" for administrative tools to maintain ports
RUN_DEPENDS= \
${LOCALBASE}/bin/cvsup:${PORTSDIR}/net/cvsup-without-gui \
${LOCALBASE}/bin/fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
- ${LOCALBASE}/sbin/pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
- ${LOCALBASE}/bin/pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
- ${LOCALBASE}/bin/porteasy:${PORTSDIR}/misc/porteasy \
- ${LOCALBASE}/bin/portell:${PORTSDIR}/misc/portell \
- ${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/sysutils/portdowngrade
+ ${LOCALBASE}/sbin/pkg_cutleaves:${PORTSDIR}/ports-mgmt/pkg_cutleaves \
+ ${LOCALBASE}/bin/pkg_tree:${PORTSDIR}/ports-mgmt/pkg_tree \
+ ${LOCALBASE}/bin/porteasy:${PORTSDIR}/ports-mgmt/porteasy \
+ ${LOCALBASE}/bin/portell:${PORTSDIR}/ports-mgmt/portell \
+ ${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/ports-mgmt/portdowngrade
NO_BUILD= yes
diff --git a/ports-mgmt/portaudit-db/Makefile b/ports-mgmt/portaudit-db/Makefile
index db754b90df57..a59cf59369b2 100644
--- a/ports-mgmt/portaudit-db/Makefile
+++ b/ports-mgmt/portaudit-db/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portaudit-db
PORTVERSION= 0.2.3
-CATEGORIES= security
+CATEGORIES= ports-mgmt
DISTFILES=
MAINTAINER= secteam@FreeBSD.org
diff --git a/ports-mgmt/portaudit/Makefile b/ports-mgmt/portaudit/Makefile
index 8d585f433cba..8394913d4500 100644
--- a/ports-mgmt/portaudit/Makefile
+++ b/ports-mgmt/portaudit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portaudit
PORTVERSION= 0.5.11
-CATEGORIES= security
+CATEGORIES= ports-mgmt
DISTFILES=
MAINTAINER= secteam@FreeBSD.org
@@ -40,11 +40,11 @@ SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g' \
.if !defined(DFOSVERSION)
.if ${OSVERSION} < 491101 || ${OSVERSION} >= 500000 && ${OSVERSION} < 502120
-RUN_DEPENDS= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/sysutils/pkg_install-devel
+RUN_DEPENDS= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/ports-mgmt/pkg_install-devel
.endif
.else
.if ${DFOSVERSION} < 110000
-RUN_DEPENDS= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/sysutils/pkg_install-devel
+RUN_DEPENDS= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/ports-mgmt/pkg_install-devel
.endif
.endif
diff --git a/ports-mgmt/portbrowser/Makefile b/ports-mgmt/portbrowser/Makefile
index fdd60b045b5b..6155e35d92a4 100644
--- a/ports-mgmt/portbrowser/Makefile
+++ b/ports-mgmt/portbrowser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portbrowser
PORTVERSION= 0.3
PORTREVISION= 3
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.bytelabs.org/
DISTNAME= pb-browser-${PORTVERSION}
EXTRACT_SUFX= .tgz
diff --git a/ports-mgmt/portcheck/Makefile b/ports-mgmt/portcheck/Makefile
index ef45650db19c..39e879534f6d 100644
--- a/ports-mgmt/portcheck/Makefile
+++ b/ports-mgmt/portcheck/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portcheck
PORTVERSION= 1.12
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.usebsd.com/pub/portcheck/files/ \
http://www.bitcare.dk/pub/portcheck/files/
EXTRACT_SUFX= .tbz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tbz
MAINTAINER= naim@usebsd.com
COMMENT= Maintains the ports tree and checks up the installed packages
-RUN_DEPENDS= ${LOCALBASE}/sbin/portaudit:${PORTSDIR}/security/portaudit
+RUN_DEPENDS= ${LOCALBASE}/sbin/portaudit:${PORTSDIR}/ports-mgmt/portaudit
PLIST_FILES= bin/portcheck
MAN1= portcheck.1
diff --git a/ports-mgmt/portcheckout/Makefile b/ports-mgmt/portcheckout/Makefile
index 5370ee92e9b7..697afb68122f 100644
--- a/ports-mgmt/portcheckout/Makefile
+++ b/ports-mgmt/portcheckout/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portcheckout
PORTVERSION= 2.0
-CATEGORIES= devel
+CATEGORIES= ports-mgmt
MASTER_SITES= http://wolfram.schneider.org/src/
MAINTAINER= wosch@FreeBSD.org
diff --git a/ports-mgmt/portconf/Makefile b/ports-mgmt/portconf/Makefile
index 2ef7a2244422..927d07aa3e2a 100644
--- a/ports-mgmt/portconf/Makefile
+++ b/ports-mgmt/portconf/Makefile
@@ -9,7 +9,7 @@
PORTNAME= portconf
PORTVERSION= 1.2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portdowngrade/Makefile b/ports-mgmt/portdowngrade/Makefile
index 7ebf370b9eee..ed21b23602b5 100644
--- a/ports-mgmt/portdowngrade/Makefile
+++ b/ports-mgmt/portdowngrade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portdowngrade
PORTVERSION= 0.6
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index 556ec885ec92..e47e264a32ad 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -9,7 +9,7 @@
PORTNAME= porteasy
PORTVERSION= 2.8.4
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portell/Makefile b/ports-mgmt/portell/Makefile
index b8d457b903e5..44be14539190 100644
--- a/ports-mgmt/portell/Makefile
+++ b/ports-mgmt/portell/Makefile
@@ -8,7 +8,7 @@
PORTNAME= portell
PORTVERSION= 0.2
PORTREVISION= 1
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .zip
diff --git a/ports-mgmt/portless/Makefile b/ports-mgmt/portless/Makefile
index d1a3e2045b44..64601a1ad152 100644
--- a/ports-mgmt/portless/Makefile
+++ b/ports-mgmt/portless/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portless
PORTVERSION= 0.2.5
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
MASTER_SITES= # empty
DISTFILES= # none
EXTRACT_ONLY= # empty
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 4f76bdce8de5..5c21434b36aa 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,7 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.9.2
-CATEGORIES= devel
+CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index 691aedd351c5..838283e76011 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -8,7 +8,7 @@
PORTNAME= portmanager
PORTVERSION= 0.4.1
PORTREVISION= 7
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portmanager
diff --git a/ports-mgmt/portmaster/Makefile b/ports-mgmt/portmaster/Makefile
index ebb5ce2ac668..9ce488d2a883 100644
--- a/ports-mgmt/portmaster/Makefile
+++ b/ports-mgmt/portmaster/Makefile
@@ -9,7 +9,7 @@
PORTNAME= portmaster
PORTVERSION= 1.12
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portmk/Makefile b/ports-mgmt/portmk/Makefile
index e44e7ef46327..20efdbb7025e 100644
--- a/ports-mgmt/portmk/Makefile
+++ b/ports-mgmt/portmk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmk
PORTVERSION= 0.1.1
-CATEGORIES= devel
+CATEGORIES= ports-mgmt
DISTFILES=
MAINTAINER= clement@FreeBSD.org
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
index f527c8e332c7..656d24b8380c 100644
--- a/ports-mgmt/portscout/Makefile
+++ b/ports-mgmt/portscout/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portscout
PORTVERSION= 0.7.2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/ \
http://www.inerd.com/software/${PORTNAME}/
diff --git a/ports-mgmt/portsearch/Makefile b/ports-mgmt/portsearch/Makefile
index 5f7c9567e1d9..baac34c903a8 100644
--- a/ports-mgmt/portsearch/Makefile
+++ b/ports-mgmt/portsearch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portsearch
PORTVERSION= 1.3.0
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= vd/portsearch
diff --git a/ports-mgmt/portsman/Makefile b/ports-mgmt/portsman/Makefile
index 8f92cf3505ab..9274f79ce308 100644
--- a/ports-mgmt/portsman/Makefile
+++ b/ports-mgmt/portsman/Makefile
@@ -8,7 +8,7 @@
PORTNAME= portsman
PORTVERSION= 0.2
PORTREVISION= 2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://download.berlios.de/portsman/
# temporary
DISTNAME= ${PORTNAME}-${PORTVERSION}-rc2
diff --git a/ports-mgmt/portsnap/Makefile b/ports-mgmt/portsnap/Makefile
index b97666d66047..c40c0a7520e3 100644
--- a/ports-mgmt/portsnap/Makefile
+++ b/ports-mgmt/portsnap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portsnap
PORTVERSION= 1.1
-CATEGORIES= sysutils net
+CATEGORIES= ports-mgmt net
MASTER_SITES= http://www.daemonology.net/portsnap/
MAINTAINER= cperciva@daemonology.net
diff --git a/ports-mgmt/portsopt/Makefile b/ports-mgmt/portsopt/Makefile
index 944683835499..b321756858c9 100644
--- a/ports-mgmt/portsopt/Makefile
+++ b/ports-mgmt/portsopt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portsopt
PORTVERSION= 1.2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.chruetertee.ch/files/download/
MAINTAINER= beat@chruetertee.ch
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index 885a5e681f17..3d5fb54df6af 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -7,14 +7,14 @@
PORTNAME= porttools
PORTVERSION= 0.77
-CATEGORIES= devel
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sergei@FreeBSD.org
COMMENT= Tools for testing and submitting port updates and new ports
-RUN_DEPENDS= portlint:${PORTSDIR}/devel/portlint \
+RUN_DEPENDS= portlint:${PORTSDIR}/ports-mgmt/portlint \
cdiff:${PORTSDIR}/textproc/cdiff \
sudo:${PORTSDIR}/security/sudo
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 6e9545f23617..d53890d4a8bc 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= portupgrade-devel
PORTVERSION= 2.2.2
PORTREVISION= 1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portupgrade
DISTNAME= pkgtools-${DISTVERSION}
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 4b317b13b286..9466a0c6947d 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -9,7 +9,7 @@ PORTNAME= portupgrade
PORTVERSION= 2.2.2
PORTREVISION= 3
PORTEPOCH= 2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= pkgtools-${DISTVERSION}
diff --git a/ports-mgmt/psearch/Makefile b/ports-mgmt/psearch/Makefile
index a244eec28413..f38528c08f01 100644
--- a/ports-mgmt/psearch/Makefile
+++ b/ports-mgmt/psearch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= psearch
PORTVERSION= 1.2
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
MASTER_SITES= http://www.maxlor.com/files/
MAINTAINER= benlutz@datacomm.ch
diff --git a/ports-mgmt/qtpkg/Makefile b/ports-mgmt/qtpkg/Makefile
index 5034cc1af97f..1246bac7b4bd 100644
--- a/ports-mgmt/qtpkg/Makefile
+++ b/ports-mgmt/qtpkg/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qtpkg
PORTVERSION= 1.0
PORTREVISION= 1
-CATEGORIES= sysutils
+CATEGORIES= ports-mgmt
# mastersite disappeared around July 6 2003
MASTER_SITES= # http://gauss.cord.edu/homepages/twschulz/demo/
DISTNAME= qtpkg
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 0e827b9b857b..469eb7293cc5 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.4
PORTREVISION= 3
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= itetcu@FreeBSD.org
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 0e827b9b857b..469eb7293cc5 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.4
PORTREVISION= 3
-CATEGORIES= misc
+CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= itetcu@FreeBSD.org
diff --git a/ports-mgmt/vulnerability-test-port/Makefile b/ports-mgmt/vulnerability-test-port/Makefile
index 27642976798e..5457da85008e 100644
--- a/ports-mgmt/vulnerability-test-port/Makefile
+++ b/ports-mgmt/vulnerability-test-port/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vulnerability-test-port
PORTVERSION= ${INSTALLATION_DATE}
-CATEGORIES= security
+CATEGORIES= ports-mgmt
DISTFILES=
MAINTAINER= ports@FreeBSD.org