aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2008-07-01 01:22:51 +0000
committerMark Linimon <linimon@FreeBSD.org>2008-07-01 01:22:51 +0000
commita721f9fd9241e87ab1cb0f72b8340bd07208d015 (patch)
treed7f1ea5f52e814eaf46fe4bf01d2bd581470f63d /ports-mgmt
parent7e68a6957b38a12e7e99b6026e42bcdd3f674144 (diff)
downloadports-a721f9fd9241e87ab1cb0f72b8340bd07208d015.tar.gz
ports-a721f9fd9241e87ab1cb0f72b8340bd07208d015.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 20dc22ff17c3..c0f7b7b76125 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -422,6 +422,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_EFL - If set, this port use EFL libraries.
# Implies inclusion of bsd.efl.mk. (Also see
# that file for more information on USE_EFL_*).
+# USE_FPC - If set, this port relies on the Free Pascal language.
+# Implies inclusion of bsd.fpc.mk. (Also see
+# that file for more information on WANT_FPC_*).
# USE_JAVA - If set, this port relies on the Java language.
# Implies inclusion of bsd.java.mk. (Also see
# that file for more information on USE_JAVA_*).
@@ -440,6 +443,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# (Also see that file for more information on
# USE_GNUSTEP_*).
##
+# USE_GECKO - If set, this port uses the Gecko/Mozilla product.
+# See bsd.gecko.mk for more details.
+##
# USE_GNOME - A list of the Gnome dependencies the port has (e.g.,
# glib12, gtk12). Implies that the port needs Gnome.
# Implies inclusion of bsd.gnome.mk. See bsd.gnome.mk
@@ -1510,6 +1516,14 @@ PERL= ${LOCALBASE}/bin/perl
.endif
.endif
+.if defined(USE_FPC) || defined(WANT_FPC_BASE) || defined(WANT_FPC_ALL)
+.if exists(${DEVELPORTSDIR}/Mk/bsd.fpc.mk)
+.include "${DEVELPORTSDIR}/Mk/bsd.fpc.mk"
+.else
+.include "${PORTSDIR}/Mk/bsd.fpc.mk"
+.endif
+.endif
+
.if defined(USE_JAVA)
.if exists(${DEVELPORTSDIR}/Mk/bsd.java.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.java.mk"
@@ -1566,6 +1580,14 @@ PERL= ${LOCALBASE}/bin/perl
.endif
.endif
+.if defined(WANT_GECKO) || defined(USE_GECKO)
+.if exists(${DEVELPORTSDIR}/Mk/bsd.gecko.mk)
+.include "${DEVELPORTSDIR}/Mk/bsd.gecko.mk"
+.else
+.include "${PORTSDIR}/Mk/bsd.gecko.mk"
+.endif
+.endif
+
.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(USE_GTK)
.if exists(${DEVELPORTSDIR}/Mk/bsd.gnome.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.gnome.mk"
@@ -2183,6 +2205,14 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.endif
.endif
+.if defined(WANT_GECKO) || defined(USE_GECKO)
+.if exists(${DEVELPORTSDIR}/Mk/bsd.gecko.mk)
+.include "${DEVELPORTSDIR}/Mk/bsd.gecko.mk"
+.else
+.include "${PORTSDIR}/Mk/bsd.gecko.mk"
+.endif
+.endif
+
.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(USE_GTK)
.if exists(${DEVELPORTSDIR}/Mk/bsd.gnome.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.gnome.mk"