aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-02-18 19:58:31 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-02-18 19:58:31 +0000
commitc28b240e07483a19b9cf93aff458d6637db1be4a (patch)
tree4c6791bf9c38b2dceaed2e9146dcda9e4a21f9c2 /ports-mgmt
parenta459454401a48f6b47191412395fa5f56cf2729c (diff)
Update to the latest available commit
This way we can remove the local patches and get a fix one of the reported bugs: https://github.com/freebsd/pytoport/issues/10 Also, lint the makefile while here.
Notes
Notes: svn path=/head/; revision=526472
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/py-pytoport/Makefile11
-rw-r--r--ports-mgmt/py-pytoport/distinfo6
-rw-r--r--ports-mgmt/py-pytoport/files/patch-setup.py11
3 files changed, 8 insertions, 20 deletions
diff --git a/ports-mgmt/py-pytoport/Makefile b/ports-mgmt/py-pytoport/Makefile
index 981297a86c67..513f212ba9b1 100644
--- a/ports-mgmt/py-pytoport/Makefile
+++ b/ports-mgmt/py-pytoport/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= pytoport
-PORTVERSION= 0.4.1
DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.1-4
+DISTVERSIONSUFFIX= -g08c2a0f
CATEGORIES= ports-mgmt python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,14 +14,12 @@ COMMENT= Generate FreeBSD ports from Python modules on PyPI
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-GH_ACCOUNT= freebsd
-GH_PROJECT= pytoport
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}spdx-lookup>=0.3.0:misc/py-spdx-lookup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spdx-lookup>=0.3.0:misc/py-spdx-lookup@${PY_FLAVOR}
USES= python:3.3+
USE_GITHUB= yes
+GH_ACCOUNT= freebsd
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/ports-mgmt/py-pytoport/distinfo b/ports-mgmt/py-pytoport/distinfo
index 18f57b6f31c6..2d3ed65cde6b 100644
--- a/ports-mgmt/py-pytoport/distinfo
+++ b/ports-mgmt/py-pytoport/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463315915
-SHA256 (freebsd-pytoport-v0.4.1_GH0.tar.gz) = 025f9c3c5dbb8261ec5930f0ab1bc1229d32e6fc4b5d3c28ebe311ec34322f4d
-SIZE (freebsd-pytoport-v0.4.1_GH0.tar.gz) = 6008
+TIMESTAMP = 1582055543
+SHA256 (freebsd-pytoport-v0.4.1-4-g08c2a0f_GH0.tar.gz) = 6e86cb276051749683771116910cf34c6d6b0644947e68eb46b43ca056ac499f
+SIZE (freebsd-pytoport-v0.4.1-4-g08c2a0f_GH0.tar.gz) = 6030
diff --git a/ports-mgmt/py-pytoport/files/patch-setup.py b/ports-mgmt/py-pytoport/files/patch-setup.py
deleted file mode 100644
index af3229160008..000000000000
--- a/ports-mgmt/py-pytoport/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2016-05-15 12:19:34 UTC
-+++ setup.py
-@@ -5,7 +5,7 @@ with open('README.rst') as f:
-
- setup(
- name = "pytoport",
-- version = "0.5.0a1",
-+ version = "0.4.1",
- packages = find_packages(),
- author = "Brendan Molloy",
- author_email = "brendan+pypi@bbqsrc.net",