aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-10-27 18:19:13 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-10-27 18:19:13 +0000
commit62fe43164b24643716d501e7a43c6487b13f3fd9 (patch)
tree03b3ab1d30622f7cf923d011d94626e0c223cfde /ports-mgmt
parent707913186336f43e9d97d11972376dad30265569 (diff)
downloadports-62fe43164b24643716d501e7a43c6487b13f3fd9.tar.gz
ports-62fe43164b24643716d501e7a43c6487b13f3fd9.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile40
-rw-r--r--ports-mgmt/tinderbox-devel/pkg-plist19
-rw-r--r--ports-mgmt/tinderbox/Makefile26
-rw-r--r--ports-mgmt/tinderbox/pkg-plist19
4 files changed, 45 insertions, 59 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 96105003b8f8..f262f4a7cd5c 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -22,19 +22,19 @@ OPTIONS_MULTI_DB= PGSQL MYSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= APACHE HIAWATHA LIGHTTPD NGINX
-OPTIONS_DEFINE= CHECK_FOR_ROOT EMAILS LSOF LOG_COMPRESS PARALLEL \
- TMPFS
+OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS \
+ PARALLEL TMPFS
-CHECK_FOR_ROOT_DESC= Check if ./tc is run by uid 0
+CHECK_ROOT_DESC= Check if ./tc is run by uid 0
EMAILS_DESC= Support for build failure/completion emails
LSOF_DESC= For killMountProcesses() when using nullfs
-LOG_COMPRESS_DESC= Support bzip'ing the logs
+LOG_COMPRESS_DESC= Support bzip log compression
PARALLEL_DESC= Apply PARALLEL extra patch
TMPFS_DESC= Apply TMPFS extra patch
HIAWATHA_DESC= Hiawatha server
NGINX_DESC= Nginx server
-OPTIONS_DEFAULT= MYSQL APACHE CHECK_FOR_ROOT EMAILS LSOF \
+OPTIONS_DEFAULT= MYSQL APACHE CHECK_ROOT EMAILS LSOF \
LOG_COMPRESS PARALLEL
NO_BUILD= yes
@@ -44,10 +44,6 @@ SUB_FILES= pkg-message
#SNAP= .r3-20120404
#SNAP= -20110101 # 22:28:07 UTC
-MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
- tc-configJail.1 tc-configTinderd.1 tc-init.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE} || ${PORT_OPTIONS:MHIAWATHA} || ${PORT_OPTIONS:MLIGHTTPD} || ${PORT_OPTIONS:MNGINX}
@@ -115,30 +111,18 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-tmpfs.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-parallel.patch
.endif
-.if ! defined(WEBUI)
-post-extract:
- @${RM} -R ${WRKSRC}/webui
-.endif
-
post-patch:
-.if ! ${PORT_OPTIONS:MCHECK_FOR_ROOT}
+.if ! ${PORT_OPTIONS:MCHECK_ROOT}
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
.endif
- @cd ${WRKSRC} && ${FIND} -E . -regex '.*(orig|bak)' -exec ${RM} {} \;
do-install:
- @${MKDIR} ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "Installing man pages ..."
- cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1 && \
- cd ${WRKSRC} && ${RM} -r ${WRKSRC}/man
- @${ECHO_CMD} "Installing rc script ..."
- ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${PREFIX}/etc/rc.d/${PORTNAME}
- @${ECHO_CMD} "Installing tinderbox ..."
- ${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "All Done"
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC} --exclude man --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC}/man/man1 --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${STAGEDIR}${PREFIX}/etc/rc.d/${PORTNAME}
.include <bsd.port.mk>
diff --git a/ports-mgmt/tinderbox-devel/pkg-plist b/ports-mgmt/tinderbox-devel/pkg-plist
index 81600d942948..448c6cccd375 100644
--- a/ports-mgmt/tinderbox-devel/pkg-plist
+++ b/ports-mgmt/tinderbox-devel/pkg-plist
@@ -1,4 +1,11 @@
etc/rc.d/tinderbox
+man/man1/tc-configCcache.1.gz
+man/man1/tc-configDistfile.1.gz
+man/man1/tc-configGet.1.gz
+man/man1/tc-configJail.1.gz
+man/man1/tc-configTinderd.1.gz
+man/man1/tc-init.1.gz
+tinderbox/scripts/.version
tinderbox/scripts/README
tinderbox/scripts/contrib/hooks/compress_wrkdir/README.txt
tinderbox/scripts/contrib/hooks/compress_wrkdir/compress_wrkdir.sh
@@ -9,8 +16,8 @@ tinderbox/scripts/contrib/hooks/kse-fix/kse-fix.sh
tinderbox/scripts/contrib/hooks/kse-fix/libmap.conf
tinderbox/scripts/contrib/hooks/make-jobs-safe/README.txt
tinderbox/scripts/contrib/hooks/make-jobs-safe/make-jobs-safe.sh
-tinderbox/scripts/contrib/hooks/mass-build-pgsql/mass-build-pgsql.sh
tinderbox/scripts/contrib/hooks/mass-build-pgsql/README.txt
+tinderbox/scripts/contrib/hooks/mass-build-pgsql/mass-build-pgsql.sh
tinderbox/scripts/ds.ph.dist
tinderbox/scripts/etc/env/.keep_me
tinderbox/scripts/etc/rc.d/tinderd
@@ -61,10 +68,10 @@ tinderbox/scripts/upgrade/builds.map
tinderbox/scripts/upgrade/config.map
tinderbox/scripts/upgrade/hooks.map
tinderbox/scripts/upgrade/jails.map
-tinderbox/scripts/upgrade/mig_pgsql_tinderbox-3.3_to_4.0.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-3.3_to_4.0.0.sql
-tinderbox/scripts/upgrade/user_permissions.map
+tinderbox/scripts/upgrade/mig_pgsql_tinderbox-3.3_to_4.0.0.sql
tinderbox/scripts/upgrade/order.lst
+tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/core/Build.php
%%WEBUI%%tinderbox/scripts/webui/core/BuildGroups.php
%%WEBUI%%tinderbox/scripts/webui/core/BuildPortsQueue.php
@@ -158,7 +165,7 @@ tinderbox/scripts/upgrade/order.lst
@dirrm tinderbox/scripts/contrib/hooks/kse-fix
@dirrm tinderbox/scripts/contrib/hooks/create-pkgng-repo
@dirrm tinderbox/scripts/contrib/hooks/compress_wrkdir
-@dirrm tinderbox/scripts/contrib/hooks
-@dirrm tinderbox/scripts/contrib
-@dirrm tinderbox/scripts
+@dirrmtry tinderbox/scripts/contrib/hooks
+@dirrmtry tinderbox/scripts/contrib
+@dirrmtry tinderbox/scripts
@dirrmtry tinderbox
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 574b77712c5a..e51565e8385f 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS
CHECK_ROOT_DESC= Check if ./tc is run by uid 0
EMAILS_DESC= Support for build failure/completion emails
LSOF_DESC= For killMountProcesses() when using nullfs
-LOG_COMPRESS_DESC= Support bzip'ing the logs
+LOG_COMPRESS_DESC= Support bzip log compression
HIAWATHA_DESC= Hiawatha server
NGINX_DESC= Nginx server
@@ -38,10 +38,6 @@ NO_BUILD= yes
WANT_PERL= yes
SUB_FILES= pkg-message
-MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
- tc-configJail.1 tc-configTinderd.1 tc-init.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE} || ${PORT_OPTIONS:MHIAWATHA} || ${PORT_OPTIONS:MLIGHTTPD} || ${PORT_OPTIONS:MNGINX}
@@ -53,7 +49,6 @@ WANT_PHP_WEB= yes
USE_PHP= session
PLIST_SUB+= WEBUI=""
.else
-EXTRACT_BEFORE_ARGS= --exclude webui -xf
PLIST_SUB+= WEBUI="@comment "
.endif
@@ -107,20 +102,13 @@ post-patch:
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
.endif
- @cd ${WRKSRC} && ${FIND} -E . -regex '.*(orig|bak)' -exec ${RM} {} \;
do-install:
- @${MKDIR} ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "Installing man pages ..."
- cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1 && \
- cd ${WRKSRC} && ${RM} -r ${WRKSRC}/man
- @${ECHO_CMD} "Installing rc script ..."
- ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${PREFIX}/etc/rc.d/${PORTNAME}
- @${ECHO_CMD} "Installing tinderbox ..."
- ${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "All Done"
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC} --exclude man --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC}/man/man1 --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${STAGEDIR}${PREFIX}/etc/rc.d/${PORTNAME}
.include <bsd.port.mk>
diff --git a/ports-mgmt/tinderbox/pkg-plist b/ports-mgmt/tinderbox/pkg-plist
index 81600d942948..448c6cccd375 100644
--- a/ports-mgmt/tinderbox/pkg-plist
+++ b/ports-mgmt/tinderbox/pkg-plist
@@ -1,4 +1,11 @@
etc/rc.d/tinderbox
+man/man1/tc-configCcache.1.gz
+man/man1/tc-configDistfile.1.gz
+man/man1/tc-configGet.1.gz
+man/man1/tc-configJail.1.gz
+man/man1/tc-configTinderd.1.gz
+man/man1/tc-init.1.gz
+tinderbox/scripts/.version
tinderbox/scripts/README
tinderbox/scripts/contrib/hooks/compress_wrkdir/README.txt
tinderbox/scripts/contrib/hooks/compress_wrkdir/compress_wrkdir.sh
@@ -9,8 +16,8 @@ tinderbox/scripts/contrib/hooks/kse-fix/kse-fix.sh
tinderbox/scripts/contrib/hooks/kse-fix/libmap.conf
tinderbox/scripts/contrib/hooks/make-jobs-safe/README.txt
tinderbox/scripts/contrib/hooks/make-jobs-safe/make-jobs-safe.sh
-tinderbox/scripts/contrib/hooks/mass-build-pgsql/mass-build-pgsql.sh
tinderbox/scripts/contrib/hooks/mass-build-pgsql/README.txt
+tinderbox/scripts/contrib/hooks/mass-build-pgsql/mass-build-pgsql.sh
tinderbox/scripts/ds.ph.dist
tinderbox/scripts/etc/env/.keep_me
tinderbox/scripts/etc/rc.d/tinderd
@@ -61,10 +68,10 @@ tinderbox/scripts/upgrade/builds.map
tinderbox/scripts/upgrade/config.map
tinderbox/scripts/upgrade/hooks.map
tinderbox/scripts/upgrade/jails.map
-tinderbox/scripts/upgrade/mig_pgsql_tinderbox-3.3_to_4.0.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-3.3_to_4.0.0.sql
-tinderbox/scripts/upgrade/user_permissions.map
+tinderbox/scripts/upgrade/mig_pgsql_tinderbox-3.3_to_4.0.0.sql
tinderbox/scripts/upgrade/order.lst
+tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/core/Build.php
%%WEBUI%%tinderbox/scripts/webui/core/BuildGroups.php
%%WEBUI%%tinderbox/scripts/webui/core/BuildPortsQueue.php
@@ -158,7 +165,7 @@ tinderbox/scripts/upgrade/order.lst
@dirrm tinderbox/scripts/contrib/hooks/kse-fix
@dirrm tinderbox/scripts/contrib/hooks/create-pkgng-repo
@dirrm tinderbox/scripts/contrib/hooks/compress_wrkdir
-@dirrm tinderbox/scripts/contrib/hooks
-@dirrm tinderbox/scripts/contrib
-@dirrm tinderbox/scripts
+@dirrmtry tinderbox/scripts/contrib/hooks
+@dirrmtry tinderbox/scripts/contrib
+@dirrmtry tinderbox/scripts
@dirrmtry tinderbox