aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2015-04-01 18:19:03 +0000
committerJason Helfman <jgh@FreeBSD.org>2015-04-01 18:19:03 +0000
commitd00918bcaf22a3581eb93739842618de91d912dd (patch)
tree6bf956d8001798820c1dc1ea577f0d095e098f79 /ports-mgmt
parentf8da6407a7d786d9a829242df121c5d1a4b5e36c (diff)
downloadports-d00918bcaf22a3581eb93739842618de91d912dd.tar.gz
ports-d00918bcaf22a3581eb93739842618de91d912dd.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/port-authoring-tools/Makefile8
-rw-r--r--ports-mgmt/port-maintenance-tools/Makefile9
2 files changed, 3 insertions, 14 deletions
diff --git a/ports-mgmt/port-authoring-tools/Makefile b/ports-mgmt/port-authoring-tools/Makefile
index 48dd0a3ad4c9..efe77986c216 100644
--- a/ports-mgmt/port-authoring-tools/Makefile
+++ b/ports-mgmt/port-authoring-tools/Makefile
@@ -4,21 +4,15 @@ PORTNAME= port-authoring-tools
PORTVERSION= 1.0
PORTREVISION= 1
CATEGORIES= ports-mgmt
-MASTER_SITES= # empty
-DISTFILES= # empty
-EXTRACT_ONLY= # empty
MAINTAINER= jgh@FreeBSD.org
COMMENT= "meta-port" for tools to test and submit changes to ports
+USES= metaport
# note: portlint is brought in by porttools
RUN_DEPENDS= \
${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
${LOCALBASE}/sbin/libchk:${PORTSDIR}/sysutils/libchk \
${LOCALBASE}/bin/port:${PORTSDIR}/ports-mgmt/porttools
-NO_BUILD= yes
-NO_MTREE= yes
-NO_INSTALL= yes
-
.include <bsd.port.mk>
diff --git a/ports-mgmt/port-maintenance-tools/Makefile b/ports-mgmt/port-maintenance-tools/Makefile
index 4cc83c068cbd..d2644298f390 100644
--- a/ports-mgmt/port-maintenance-tools/Makefile
+++ b/ports-mgmt/port-maintenance-tools/Makefile
@@ -4,13 +4,12 @@ PORTNAME= port-maintenance-tools
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= ports-mgmt
-MASTER_SITES= # empty
-DISTFILES= # empty
-EXTRACT_ONLY= # empty
MAINTAINER= jgh@FreeBSD.org
COMMENT= Meta-port for administrative tools to maintain ports
+USES= metaport
+
RUN_DEPENDS= \
${LOCALBASE}/sbin/portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
@@ -20,8 +19,4 @@ RUN_DEPENDS= \
${LOCALBASE}/bin/portell:${PORTSDIR}/ports-mgmt/portell \
${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/ports-mgmt/portdowngrade
-NO_BUILD= yes
-NO_MTREE= yes
-NO_INSTALL= yes
-
.include <bsd.port.mk>