aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2018-03-28 17:57:02 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2018-03-28 17:57:02 +0000
commit8a4c4fcb599fa5ab474f3ac2b0557bedfc19fa78 (patch)
treebd0ea0d77a978aafdb37efc791ae2a63f8b04296 /ports-mgmt
parent64bd689405eea48555766a7e81b6b1766d4c8c87 (diff)
downloadports-8a4c4fcb599fa5ab474f3ac2b0557bedfc19fa78.tar.gz
ports-8a4c4fcb599fa5ab474f3ac2b0557bedfc19fa78.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile19
-rw-r--r--ports-mgmt/poudriere-devel/distinfo6
-rw-r--r--ports-mgmt/poudriere-devel/pkg-plist2
3 files changed, 17 insertions, 10 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 2402c50570d2..2953cfbd5851 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= poudriere
-DISTVERSION= 3.2.99.20180313
+DISTVERSION= 3.2.99.20180328
PORTREVISION= 0
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
@@ -18,14 +18,14 @@ CONFLICTS_INSTALL= poudriere-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= freebsd
-GH_TAGNAME= 3.2.5-303-g3a844af55
+GH_TAGNAME= 3.2.5-363-g9c2944629
#DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${GH_TAGNAME}
GNU_CONFIGURE= yes
ETCDIR= ${PREFIX}/etc/poudriere.d
-OPTIONS_DEFINE= CERTS DIALOG4PORTS EXAMPLES QEMU ZSH
-OPTIONS_DEFAULT=CERTS DIALOG4PORTS ZSH
+OPTIONS_DEFINE= BASH CERTS DIALOG4PORTS EXAMPLES QEMU ZSH
+OPTIONS_DEFAULT=BASH CERTS DIALOG4PORTS ZSH
OPTIONS_SUB= yes
CERTS_DESC= Install checksum and SSL certificates for jail creation
@@ -59,10 +59,17 @@ post-patch:
${REINPLACE_CMD} '/.PHONY: poudriere/d' ${WRKSRC}/Makefile.*
post-install:
+ ${LN} -fs ${LOCALBASE}/share/freebsd/MANIFESTS \
+ ${STAGEDIR}${DATADIR}/MANIFESTS
+
+post-install-BASH-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
${INSTALL_DATA} ${WRKSRC}/completions/zsh/_poudriere \
${STAGEDIR}${PREFIX}/share/zsh/site-functions/
- ${LN} -fs ${LOCALBASE}/share/freebsd/MANIFESTS \
- ${STAGEDIR}${DATADIR}/MANIFESTS
+
+post-install-ZSH-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions/
+ ${INSTALL_DATA} ${WRKSRC}/completions/bash/poudriere \
+ ${STAGEDIR}${PREFIX}/share/bash-completion/completions/
.include <bsd.port.mk>
diff --git a/ports-mgmt/poudriere-devel/distinfo b/ports-mgmt/poudriere-devel/distinfo
index 6f97ed8b25bb..d591256b758a 100644
--- a/ports-mgmt/poudriere-devel/distinfo
+++ b/ports-mgmt/poudriere-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520961575
-SHA256 (freebsd-poudriere-3.2.99.20180313-3.2.5-303-g3a844af55_GH0.tar.gz) = 04af1d3fb380a5ffcbe3235122215e37bc9cf40106969b3cd1633fe824bb2895
-SIZE (freebsd-poudriere-3.2.99.20180313-3.2.5-303-g3a844af55_GH0.tar.gz) = 4371681
+TIMESTAMP = 1522259201
+SHA256 (freebsd-poudriere-3.2.99.20180328-3.2.5-363-g9c2944629_GH0.tar.gz) = d6ddc3eeb3396735068dd7abf432534546407f4009e0198948dd6ea4f7125ee1
+SIZE (freebsd-poudriere-3.2.99.20180328-3.2.5-363-g9c2944629_GH0.tar.gz) = 4375203
diff --git a/ports-mgmt/poudriere-devel/pkg-plist b/ports-mgmt/poudriere-devel/pkg-plist
index eb6b76fba784..dcbf8c6f2a8d 100644
--- a/ports-mgmt/poudriere-devel/pkg-plist
+++ b/ports-mgmt/poudriere-devel/pkg-plist
@@ -22,7 +22,6 @@ libexec/poudriere/rexec
libexec/poudriere/sh
libexec/poudriere/timeout
libexec/poudriere/timestamp
-libexec/poudriere/tsort
man/man8/poudriere.8.gz
man/man8/poudriere-bulk.8.gz
man/man8/poudriere-distclean.8.gz
@@ -108,4 +107,5 @@ man/man8/poudriere-version.8.gz
%%DATADIR%%/queue.sh
%%DATADIR%%/status.sh
%%DATADIR%%/testport.sh
+%%BASH%%share/bash-completion/completions/poudriere
%%ZSH%%share/zsh/site-functions/_poudriere