aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-01 22:46:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-01 22:46:25 +0000
commit5b8604bff3a6d3c55c1a63a08ab7bb3a01dc2f99 (patch)
tree1e13dbe2937fe23888f87f47b15f4dd2b12872a2 /ports-mgmt
parentc6f2e7323f000246c6df81e7d776cda726ea318b (diff)
downloadports-5b8604bff3a6d3c55c1a63a08ab7bb3a01dc2f99.tar.gz
ports-5b8604bff3a6d3c55c1a63a08ab7bb3a01dc2f99.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.12
-rw-r--r--ports-mgmt/portlint/src/portlint.pl6
3 files changed, 5 insertions, 6 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 06b2435281aa..f1f6eb159591 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTVERSION= 2.4.6
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.1 b/ports-mgmt/portlint/src/portlint.1
index 1f598d9fa1e8..65d4ad176f7f 100644
--- a/ports-mgmt/portlint/src/portlint.1
+++ b/ports-mgmt/portlint/src/portlint.1
@@ -67,7 +67,7 @@ New port flag.
Adds several checks specific to newly submitted port.
If you are willing to submit the directory to be checked as a new port,
use this option.
-.It Fl t
+.It Fl V
Print the portlint version and exit.
.It Fl M Ar ENV
Set make variables to
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 8b320ffb29bd..ed92700d9a0e 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.19 2003/10/27 01:57:35 marcus Exp $
+# $Id: portlint.pl,v 1.20 2003/10/27 05:08:25 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -903,8 +903,8 @@ sub checkmakefile {
if ($whole =~ /NOPORTSDOC/) {
&perror("WARN: NOPORTSDOC found. Do you mean NOPORTDOCS?");
}
- if ($sharedocused && $whole !~ /defined\s*\(NOPORTDOCS\)/
- && $whole !~ /def\s*\(NOPORTDOCS\)/
+ if ($sharedocused && $whole !~ /defined\s*\(?NOPORTDOCS\)?/
+ && $whole !~ /def\s*\(?NOPORTDOCS\)?/
&& $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
&perror("WARN: use \".if !defined(NOPORTDOCS)\" to wrap ".
"installation of files into $localbase/share/doc.");