aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-03-07 17:00:43 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-03-07 17:00:43 +0000
commit0b19c786094caf2500ef5b5dc5d7e4ed8699373f (patch)
tree928b3721d29e219ef3812c73030c915aaa2c2de7 /ports-mgmt
parentcfbfb3d2f3f291374d865470ab263895bba19892 (diff)
downloadports-0b19c786094caf2500ef5b5dc5d7e4ed8699373f.tar.gz
ports-0b19c786094caf2500ef5b5dc5d7e4ed8699373f.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl8
2 files changed, 8 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 3a6b09f4c26d..6c14f60a2638 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,7 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index f877f1b2de97..cd92ae79cb62 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -629,7 +629,8 @@ sub checkpatch {
}
if ($committer && $whole =~ /\$([A-Za-z0-9]+)[:\$]/) {
&perror("WARN: $file includes possible RCS tag \"\$$1\$\". ".
- "use binary mode (-ko) on commit/import.");
+ "use binary mode (-ko) on commit/import.") unless
+ $1 eq $rcsidstr;
}
close(IN);
@@ -1527,6 +1528,11 @@ LIB_DEPENDS BUILD_DEPENDS RUN_DEPENDS FETCH_DEPENDS DEPENDS DEPENDS_TARGET
"discouraged. redefine \"do-$1\" instead.");
}
+ # check for incorrect use of the pre-everything target.
+ if ($tmp =~ /\npre-everything:[^:]/) {
+ &perror("FATAL: use pre-everything:: instead of pre-everything:");
+ }
+
1;
}