aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2015-04-13 04:53:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2015-04-13 04:53:25 +0000
commit88071ad77fa6a73ee59b8384be88f817b7597dee (patch)
treed79421acd6809d99790f535bcbe2c20c27d511da /ports-mgmt
parent482f6df82cb337a78d7c43b5fa9c9670fcbecdbf (diff)
downloadports-88071ad77fa6a73ee59b8384be88f817b7597dee.tar.gz
ports-88071ad77fa6a73ee59b8384be88f817b7597dee.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl17
2 files changed, 16 insertions, 3 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 56c695655fa9..75ce25de6a93 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.16.2
+PORTVERSION= 2.16.3
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index bd361af55f5b..f6f7c028c164 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.350 2015/02/04 17:07:25 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.354 2015/04/13 04:48:55 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 16;
-my $micro = 2;
+my $micro = 3;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -923,6 +923,13 @@ sub checkpatch {
$whole = '';
while (<IN>) {
$whole .= $_;
+ if (/^--- /) {
+ if ($_ !~ /UTC\s*$/) {
+ &perror("WARN", $file, -1, "patch was not generated using ".
+ "``make makepatch''. It is recommended to use ".
+ "``make makepatch'' to ensure proper patch format.");
+ }
+ }
}
if ($committer && $whole =~ /\wjavavm\w/) {
@@ -3278,6 +3285,9 @@ sub get_makevar {
chomp $result;
$result =~ s/\n\n/\n\0\n/g;
+ if (${^CHILD_ERROR_NATIVE} != 0) {
+ die "\nFATAL ERROR: make(1) died with status ${^CHILD_ERROR_NATIVE} and returned '$result'";
+ }
return $result;
}
@@ -3290,6 +3300,9 @@ sub get_makevar_raw {
chomp $result;
$result =~ s/\n\n/\n\0\n/g;
+ if (${^CHILD_ERROR_NATIVE} != 0) {
+ die "\nFATAL ERROR: make(1) died with status ${^CHILD_ERROR_NATIVE} and returned '$result'";
+ }
return $result;
}