aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-12-06 09:48:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-12-06 09:50:49 +0000
commita4e4b7af4c77317a6ab41554d9e0e92e9b6a0e78 (patch)
treef3e4239ae80c0e9c50d663cc2149613be733fa25 /ports-mgmt
parent7d6dadb260cfea770e752e451a28cd401c546708 (diff)
downloadports-a4e4b7af4c77317a6ab41554d9e0e92e9b6a0e78.tar.gz
ports-a4e4b7af4c77317a6ab41554d9e0e92e9b6a0e78.zip
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portconfig/Makefile5
-rw-r--r--ports-mgmt/portconfig/distinfo6
-rw-r--r--ports-mgmt/portconfig/files/patch-portconfig.c25
3 files changed, 30 insertions, 6 deletions
diff --git a/ports-mgmt/portconfig/Makefile b/ports-mgmt/portconfig/Makefile
index 2600f138cd1f..68cacd6c0a66 100644
--- a/ports-mgmt/portconfig/Makefile
+++ b/ports-mgmt/portconfig/Makefile
@@ -1,6 +1,5 @@
PORTNAME= portconfig
-PORTVERSION= 0.1
-PORTREVISION= 1
+PORTVERSION= 0.1.1
CATEGORIES= ports-mgmt
MAINTAINER= bapt@FreeBSD.org
@@ -10,7 +9,7 @@ LICENSE= BSD2CLAUSE
USE_GITLAB= yes
GL_ACCOUNT= alfix
-GL_COMMIT= 0292159f4e2431a2f7c1cebe13e28de34d0c8932
+GL_COMMIT= 222ee8a8f6a790fe6a9c72f7b615e47ecdb56399
USES= localbase:ldflags
BUILD_DEPENDS= ${LOCALBASE}/lib/libbsddialog.a:devel/bsddialog
diff --git a/ports-mgmt/portconfig/distinfo b/ports-mgmt/portconfig/distinfo
index 9d4cf106a990..0b524941e5d6 100644
--- a/ports-mgmt/portconfig/distinfo
+++ b/ports-mgmt/portconfig/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637675764
-SHA256 (alfix-portconfig-0292159f4e2431a2f7c1cebe13e28de34d0c8932_GL0.tar.gz) = 195bc0e36921b29ee4130b8f29f535c344ce572bbfbc2d49fd6a3f64357801e0
-SIZE (alfix-portconfig-0292159f4e2431a2f7c1cebe13e28de34d0c8932_GL0.tar.gz) = 202114
+TIMESTAMP = 1638783870
+SHA256 (alfix-portconfig-222ee8a8f6a790fe6a9c72f7b615e47ecdb56399_GL0.tar.gz) = 20e0ccbe417607502a37c0cd86e04a5cf5c5d54577549f0448cf585e2458bff0
+SIZE (alfix-portconfig-222ee8a8f6a790fe6a9c72f7b615e47ecdb56399_GL0.tar.gz) = 202181
diff --git a/ports-mgmt/portconfig/files/patch-portconfig.c b/ports-mgmt/portconfig/files/patch-portconfig.c
new file mode 100644
index 000000000000..0351f0638be1
--- /dev/null
+++ b/ports-mgmt/portconfig/files/patch-portconfig.c
@@ -0,0 +1,25 @@
+--- portconfig.c.orig 2021-11-29 17:22:25 UTC
++++ portconfig.c
+@@ -253,9 +253,6 @@ main(int argc, char *argv[])
+ theme = BSDDIALOG_THEME_DIALOG;
+ newstr = "+";
+ }
+- else if (strcasecmp(env, "magenta") == 0) {
+- theme = BSDDIALOG_THEME_MAGENTA;
+- }
+ else if (strcasecmp(env, "blackwhite") == 0) {
+ theme = BSDDIALOG_THEME_BLACKWHITE;
+ }
+@@ -290,10 +287,10 @@ main(int argc, char *argv[])
+ confhelp.title = "HELP";
+ confhelp.hfile = NULL;
+ for (;;) {
+- output = bsddialog_mixedlist(conf, helpmsg, h, w, 0, ngroups,
++ output = bsddialog_mixedlist(&conf, helpmsg, h, w, 0, ngroups,
+ groups, NULL, NULL);
+ if (output == BSDDIALOG_HELP) {
+- output = bsddialog_textbox(confhelp, conf.hfile, 0, 0);
++ output = bsddialog_textbox(&confhelp, conf.hfile, 0, 0);
+ if(output == BSDDIALOG_ERROR)
+ break;
+ }