aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2011-01-01 20:10:56 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2011-01-01 20:10:56 +0000
commit5e235d553e6dcb0a25460230766cfd7700f719a3 (patch)
treebfc047f3e3c3e4d424d9fae1d2443d3cd5b51d33 /ports-mgmt
parentf9dac246ccbd616bb29ec19a90baba568dcc6d68 (diff)
downloadports-5e235d553e6dcb0a25460230766cfd7700f719a3.tar.gz
ports-5e235d553e6dcb0a25460230766cfd7700f719a3.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile19
-rw-r--r--ports-mgmt/tinderbox-devel/distinfo5
-rw-r--r--ports-mgmt/tinderbox-devel/pkg-plist7
3 files changed, 23 insertions, 8 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 8c9d98e77bce..ec4f4531de36 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tinderbox
DISTVERSION= 3.4-${SNAP}
CATEGORIES= ports-mgmt
-MASTER_SITES= http://freebsd.unixfreunde.de/${PORTNAME}/
+MASTER_SITES= http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}
@@ -18,22 +18,23 @@ CONFLICTS= tinderbox-[0-9]*
OPTIONS= PGSQL "With pgsql" Off \
MYSQL "With mysql" On \
- CSUP "Use csup for updates" On \
CVSUP "Use cvsup for updates" Off \
WEBUI "Install web interface" On \
APACHE "Use Apache for web interface" On \
HIAWATHA "Use Hiawatha for web interface" Off \
LIGHTTPD "Use LightHTTPD for web interface" Off \
CHECK_FOR_ROOT "Check if ./tc is run by uid 0" On \
+ EMAILS "Support for build failure/completion emails" On \
LSOF "For killMountProcesses() when using nullfs" On \
- TMPFS "Enable TMPFS extra patch" Off \
- PARALLEL "Enable PARALLEL extra patch" Off
+ LOG_COMPRESS "Support bzip'ing the logs" On \
+ TMPFS "Enable TMPFS extra patch" On \
+ PARALLEL "Enable PARALLEL extra patch" On
NO_BUILD= yes
WANT_PERL= yes
SUB_FILES= pkg-message
-SNAP= 20100104 # 07:00 PM
+SNAP= 20110101 # 18:00:00 UTC
MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
tc-configJail.1 tc-configTinderd.1 tc-init.1
@@ -83,10 +84,18 @@ RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
RUN_DEPENDS+= hiawatha:${PORTSDIR}/www/hiawatha
.endif
+.if defined(WITH_EMAILS)
+RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
.if defined(WITH_LSOF)
RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
.endif
+.if defined(WITH_LOG_COMPRESS)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Compress/Bzip2.pm:${PORTSDIR}/archivers/p5-Compress-Bzip2
+.endif
+
.if defined(WITH_TMPFS) && defined(WITH_PARALLEL)
EXTRA_PATCHES+= ${FILESDIR}/extra-tmpfs_para.patch
.elif defined(WITH_TMPFS) && !defined(WITH_PARALLEL)
diff --git a/ports-mgmt/tinderbox-devel/distinfo b/ports-mgmt/tinderbox-devel/distinfo
index 6dee7dffb21c..2936f85d3f7a 100644
--- a/ports-mgmt/tinderbox-devel/distinfo
+++ b/ports-mgmt/tinderbox-devel/distinfo
@@ -1,3 +1,2 @@
-MD5 (tinderbox/tinderbox-3.4-20100104.tar.gz) = 1feac7578b1854d48581d87b55967362
-SHA256 (tinderbox/tinderbox-3.4-20100104.tar.gz) = 02a62cb91437d9fabeb163b2dcbde88e59069fc48c6d01cff66b6d0a6532330e
-SIZE (tinderbox/tinderbox-3.4-20100104.tar.gz) = 134138
+SHA256 (tinderbox/tinderbox-3.4-20110101.tar.gz) = be33d6bdd81c16e70bfc19b786ef1bca9d2bb359bb27d8377f8d5696cdede22c
+SIZE (tinderbox/tinderbox-3.4-20110101.tar.gz) = 141721
diff --git a/ports-mgmt/tinderbox-devel/pkg-plist b/ports-mgmt/tinderbox-devel/pkg-plist
index 1c48a549e22d..668d0b7bbf3f 100644
--- a/ports-mgmt/tinderbox-devel/pkg-plist
+++ b/ports-mgmt/tinderbox-devel/pkg-plist
@@ -1,6 +1,8 @@
etc/rc.d/tinderbox
tinderbox/scripts/Makefile
tinderbox/scripts/README
+tinderbox/scripts/contrib/hooks/compress_wrkdir/README.txt
+tinderbox/scripts/contrib/hooks/compress_wrkdir/compress_wrkdir.sh
tinderbox/scripts/contrib/hooks/kse-fix/README.txt
tinderbox/scripts/contrib/hooks/kse-fix/kse-fix.sh
tinderbox/scripts/contrib/hooks/kse-fix/libmap.conf
@@ -59,6 +61,7 @@ tinderbox/scripts/upgrade/order.lst
tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/.cvsignore
%%WEBUI%%tinderbox/scripts/webui/core/Build.php
+%%WEBUI%%tinderbox/scripts/webui/core/BuildGroups.php
%%WEBUI%%tinderbox/scripts/webui/core/BuildPortsQueue.php
%%WEBUI%%tinderbox/scripts/webui/core/Config.php
%%WEBUI%%tinderbox/scripts/webui/core/Jail.php
@@ -76,6 +79,7 @@ tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/inc_tinderbox.php.dist
%%WEBUI%%tinderbox/scripts/webui/index.php
%%WEBUI%%tinderbox/scripts/webui/module/module.php
+%%WEBUI%%tinderbox/scripts/webui/module/moduleBuildGroups.php
%%WEBUI%%tinderbox/scripts/webui/module/moduleBuildPorts.php
%%WEBUI%%tinderbox/scripts/webui/module/moduleBuilds.php
%%WEBUI%%tinderbox/scripts/webui/module/moduleConfig.php
@@ -89,6 +93,7 @@ tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/templates/default/config.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/default/current_buildports.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/default/describe_port.tpl
+%%WEBUI%%tinderbox/scripts/webui/templates/default/display_build_groups.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/default/display_login.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/default/display_markup_log.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/default/failed_buildports.tpl
@@ -108,6 +113,7 @@ tinderbox/scripts/upgrade/user_permissions.map
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/config.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/current_buildports.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/describe_port.tpl
+%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_build_groups.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_login.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/display_markup_log.tpl
%%WEBUI%%tinderbox/scripts/webui/templates/paefchen/failed_buildports.tpl
@@ -144,6 +150,7 @@ tinderbox/scripts/upgrade/user_permissions.map
@dirrm tinderbox/scripts/etc
@dirrm tinderbox/scripts/contrib/hooks/make-jobs-safe
@dirrm tinderbox/scripts/contrib/hooks/kse-fix
+@dirrm tinderbox/scripts/contrib/hooks/compress_wrkdir
@dirrm tinderbox/scripts/contrib/hooks
@dirrm tinderbox/scripts/contrib
@dirrm tinderbox/scripts